[3.2][3.3][RC] Prime Post Revisions

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
Happykeppi
Registered User
Posts: 23
Joined: Thu Aug 06, 2009 9:06 am
Location: Germany
Contact:

Re: [3.2][BETA] Prime Post Revisions

Post by Happykeppi »

Thanks for the extension, which works very well at this state. I only had a minor issue with the post revision body while using prosilver based theme 'milk'. The span labels following the icons overlayed each other and screwed up the design and layout. Not sure if it's a general problem or just related to my current style. It originally looked like this:

Image

I deleted the following parts as I believe it would be sufficient to have a caption via mouse over anyway.

body.html
Line 81: '<span>{L_PRIMEPOSTREVISIONS_RESTORE}</span>'
Line 86: '<span>{L_PRIMEPOSTREVISIONS_DELETE}</span>'


overall_footer_body_after.html
Line: 14 '<span>{L_PRIMEPOSTREVISIONS_COMPARE}</span>'

I have also updated the German translations, which still had some labes not translated or mixed up (like 'PRIMEPOSTREVISIONS_INFO' and 'PRIMEPOSTREVISIONS_EDIT_BY' in the "de" version).

Git Hub:
https://github.com/happykeppi/primepostrevisions
leschek
Registered User
Posts: 791
Joined: Tue Jul 18, 2006 12:49 pm
Contact:

Re: [3.2][BETA] Prime Post Revisions

Post by leschek »

primehalo wrote:
Wed Jun 06, 2018 7:45 pm
That bug got introduced in my last update when I forgot to set the auto-increment. I've released v1.0.0 beta 4 which fixes it.
Thank you for great support.
User avatar
primehalo
Former Team Member
Posts: 2893
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: [3.2][BETA] Prime Post Revisions

Post by primehalo »

Happykeppi wrote:
Thu Jun 07, 2018 9:29 am
Thanks for the extension, which works very well at this state. I only had a minor issue with the post revision body while using prosilver based theme 'milk'. The span labels following the icons overlayed each other and screwed up the design and layout. Not sure if it's a general problem or just related to my current style. It originally looked like this:

Image

I deleted the following parts as I believe it would be sufficient to have a caption via mouse over anyway.

body.html
Line 81: '<span>{L_PRIMEPOSTREVISIONS_RESTORE}</span>'
Line 86: '<span>{L_PRIMEPOSTREVISIONS_DELETE}</span>'


overall_footer_body_after.html
Line: 14 '<span>{L_PRIMEPOSTREVISIONS_COMPARE}</span>'

I have also updated the German translations, which still had some labes not translated or mixed up (like 'PRIMEPOSTREVISIONS_INFO' and 'PRIMEPOSTREVISIONS_EDIT_BY' in the "de" version).

Git Hub:
https://github.com/happykeppi/primepostrevisions

The icons issue was because I failed to add the sr-only class to the SPAN tags. I fixed this in v1.0.0 beta5 and merged your German language files.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!
Happykeppi
Registered User
Posts: 23
Joined: Thu Aug 06, 2009 9:06 am
Location: Germany
Contact:

Re: [3.2][BETA] Prime Post Revisions

Post by Happykeppi »

Alright, thank you! :P
Tarantino
Registered User
Posts: 796
Joined: Sat Feb 18, 2012 1:51 pm
Contact:

Re: [3.2][BETA] Prime Post Revisions

Post by Tarantino »

If I had the old MOD installed and now at 3.2 I install this ext will it use all the data from the old mod? Is it retro-compatible?
User avatar
primehalo
Former Team Member
Posts: 2893
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: [3.2][BETA] Prime Post Revisions

Post by primehalo »

Unfortunately, no, and I never got around to writing a conversion script.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!
Tarantino
Registered User
Posts: 796
Joined: Sat Feb 18, 2012 1:51 pm
Contact:

Re: [3.2][BETA] Prime Post Revisions

Post by Tarantino »

I see. I hope its in the plans at least :P Thanks for the quick reply!
User avatar
primehalo
Former Team Member
Posts: 2893
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: [3.2][BETA] Prime Post Revisions

Post by primehalo »

Unfortunately, that's also a nope. I had no need for it personally and phpBB 3.0 is so old I figured it wasn't worth the time.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!
SuperFedya
Registered User
Posts: 251
Joined: Sun Jul 14, 2002 9:14 pm
Contact:

Re: [3.2][BETA] Prime Post Revisions

Post by SuperFedya »

Enable/Delete this mod on phpbb 3.2.3 make mysql on server extremely slow and require a reboot...
User avatar
primehalo
Former Team Member
Posts: 2893
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: [3.2][BETA] Prime Post Revisions

Post by primehalo »

SuperFedya wrote:
Tue Oct 30, 2018 1:17 pm
Enable/Delete this mod on phpbb 3.2.3 make mysql on server extremely slow and require a reboot...
I did not experience this.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!
SuperFedya
Registered User
Posts: 251
Joined: Sun Jul 14, 2002 9:14 pm
Contact:

Re: [3.2][BETA] Prime Post Revisions

Post by SuperFedya »

primehalo wrote:
Wed Oct 31, 2018 12:17 am
SuperFedya wrote:
Tue Oct 30, 2018 1:17 pm
Enable/Delete this mod on phpbb 3.2.3 make mysql on server extremely slow and require a reboot...
I did not experience this.
For my server enabling or delete this module consume 100% cpu.

Any way to enable it via CURL? Or CLI?

Or how to remove this module manually?
User avatar
primehalo
Former Team Member
Posts: 2893
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: [3.2][BETA] Prime Post Revisions

Post by primehalo »

I have no idea why this extension would cause 100 CPU usage on your server. To remove it manually have you tried just renaming the folder to something else? If that works then you should be able to just delete the folder.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!
User avatar
david63
Registered User
Posts: 18098
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: [3.2][BETA] Prime Post Revisions

Post by david63 »

primehalo wrote:
Fri Jan 11, 2019 7:16 am
To remove it manually have you tried just renaming the folder to something else?
That will never work and will, in fact, cause other errors.
SuperFedya wrote:
Fri Jan 11, 2019 4:36 am
Any way to enable it via CURL? Or CLI?

Or how to remove this module manually?
See - Knowledge Base - Disabling all extensions at once
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored
User avatar
24unix
Registered User
Posts: 29
Joined: Fri Dec 27, 2019 6:02 pm

Re: [3.2][BETA] Prime Post Revisions

Post by 24unix »

primehalo wrote:
Fri Jan 11, 2019 7:16 am
I have no idea why this extension would cause 100 CPU usage on your server. To remove it manually have you tried just renaming the folder to something else? If that works then you should be able to just delete the folder.
The high load comes from the database migration, my dev forum* posts_table is ~1,5 Million lines, an ALTER TABLE takes ~1900 seconds.
Screenshot 2019-12-27 at 07.07.14 PM.png
As you can see, the migrations run twice :-( I uploaded the extension via "Upload Extensions", but was not able to enable it.
Instead of waiting, or at least checking what is happening, I tried to activate it via "Manage Extensios".
Bad idea for a production system, but therefore I'v got my test environment.

* That is of course not my server for extension development, but a test version of my life-forum.

So, if I will use the extension, I'd rather install it during the night … :-)
User avatar
Janvitus
Registered User
Posts: 19
Joined: Mon Sep 30, 2019 12:04 pm

Re: [3.2][BETA] Prime Post Revisions

Post by Janvitus »

Hello,
I've installed this ext and it works fine, but I've only one problem, once a day the extension fills the admis registry with this message:
Auto-pruned post revisions » Revisions deleted: 0
All forums set to 0 on auto prune revisions and every day PPR spawning the message above. Messages don't stop (around 300-400 pages!) until I clear the board cache.

Apache and phpbb debug don't report anything unusual.

Any idea?



Nota: phpbb 3.2.9, php 7.2.
Post Reply

Return to “Extensions in Development”