[3.2][BETA] SEO Metadata

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Anti-Spam Guide
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
User avatar
AbaddonOrmuz
Registered User
Posts: 640
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo Ramos
Contact:

Re: [3.2][BETA] SEO Metadata

Post by AbaddonOrmuz » Tue Jul 02, 2019 5:00 pm

jsvh wrote:
Mon Jul 01, 2019 8:54 pm
I am having a similar issue with the image not showing.
I only provide support for my extension, not for Open Graph/Twitter Cards issues in general.

You're not using my extension so you're on your own.
Some of my phpBB extensions: [ Imgur | SEO Metadata | Markdown ]
Check out all my extensions
Arch Linux user

jsvh
Registered User
Posts: 3
Joined: Mon Jul 01, 2019 8:46 pm

Re: [3.2][BETA] SEO Metadata

Post by jsvh » Wed Jul 03, 2019 12:24 am

AbaddonOrmuz wrote:
Tue Jul 02, 2019 5:00 pm
jsvh wrote:
Mon Jul 01, 2019 8:54 pm
I am having a similar issue with the image not showing.
I only provide support for my extension, not for Open Graph/Twitter Cards issues in general.

You're not using my extension so you're on your own.
My mistake. I switched to your extension now and disabled the other one. Still doing the same thing.

User avatar
AbaddonOrmuz
Registered User
Posts: 640
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo Ramos
Contact:

Re: [3.2][BETA] SEO Metadata

Post by AbaddonOrmuz » Wed Jul 03, 2019 6:07 pm

jsvh wrote:
Wed Jul 03, 2019 12:24 am
My mistake. I switched to your extension now and disabled the other one. Still doing the same thing.
Make sure you disabled the option "Local images" in the settings page (ACP > Extensions > SEO Metadata), it's enabled by default.

Clear the cache, after that.
Some of my phpBB extensions: [ Imgur | SEO Metadata | Markdown ]
Check out all my extensions
Arch Linux user

jsvh
Registered User
Posts: 3
Joined: Mon Jul 01, 2019 8:46 pm

Re: [3.2][BETA] SEO Metadata

Post by jsvh » Wed Jul 03, 2019 6:14 pm

AbaddonOrmuz wrote:
Wed Jul 03, 2019 6:07 pm
jsvh wrote:
Wed Jul 03, 2019 12:24 am
My mistake. I switched to your extension now and disabled the other one. Still doing the same thing.
Make sure you disabled the option "Local images" in the settings page (ACP > Extensions > SEO Metadata), it's enabled by default.

Clear the cache, after that.
That did it! Thank you!

koraldon
Registered User
Posts: 509
Joined: Sat Jun 30, 2007 12:42 pm

Re: [3.2][BETA] SEO Metadata

Post by koraldon » Sat Jul 13, 2019 5:33 am

Hi,
I have upgraded from 1.1RC3 to 1.2Beta2, and I have encountered an ajax issue.
I'm using quickreply reloaded, which worked great with 1.1RC3, but now with 1.2Beta2 it doesn't reload the page after sending a new post, but produces an ajax error... it does send the message though.
I really like both of those extensions, and would be great if this can be fixed.

Thanks

User avatar
AbaddonOrmuz
Registered User
Posts: 640
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo Ramos
Contact:

Re: [3.2][BETA] SEO Metadata

Post by AbaddonOrmuz » Sat Jul 13, 2019 6:26 am

koraldon wrote:
Sat Jul 13, 2019 5:33 am
Hi,
I have upgraded from 1.1RC3 to 1.2Beta2, and I have encountered an ajax issue.
I'm using quickreply reloaded, which worked great with 1.1RC3, but now with 1.2Beta2 it doesn't reload the page after sending a new post, but produces an ajax error... it does send the message though.
I really like both of those extensions, and would be great if this can be fixed.

Thanks
This doesn't do any AJAX calls so whatever issue you're having, I highly doubt it's because of this.

You might want to contact the QuickReply Reloaded author and provide useful information, you want it to be fixed but you don't even say what the problem is, "produces an ajax error" doesn't even describe the problem.
Some of my phpBB extensions: [ Imgur | SEO Metadata | Markdown ]
Check out all my extensions
Arch Linux user

koraldon
Registered User
Posts: 509
Joined: Sat Jun 30, 2007 12:42 pm

Re: [3.2][BETA] SEO Metadata

Post by koraldon » Sat Jul 13, 2019 7:18 pm

I will try and explain.
The quickreply reloaded extension loads the page again after you have posted a quick reply, using Ajax.
What happens is that after you send a quick reply, it posts the reply but fails reloading the page, giving an ajax error. Sadly there is no detailed error what occured.

I will also contact the Quickreply reloaded creators, but is there anything in this extension update that might strip out the data from a reload like URL maybe?

User avatar
AbaddonOrmuz
Registered User
Posts: 640
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo Ramos
Contact:

Re: [3.2][BETA] SEO Metadata

Post by AbaddonOrmuz » Sat Jul 13, 2019 8:59 pm

koraldon wrote:
Sat Jul 13, 2019 7:18 pm
I will try and explain.
The quickreply reloaded extension loads the page again after you have posted a quick reply, using Ajax.
What happens is that after you send a quick reply, it posts the reply but fails reloading the page, giving an ajax error. Sadly there is no detailed error what occured.
I'm aware how that extension works. What I meant was, I doubt the error is exactly "AJAX Error", it should give you a message, and why that exact message is needed? you might ask. Well, with the exact message text one could dig in the code and maybe know why is happening, saying that there's an "ajax error" doesn't help because it's too ambiguous.
koraldon wrote:
Sat Jul 13, 2019 7:18 pm
I will also contact the Quickreply reloaded creators, but is there anything in this extension update that might strip out the data from a reload like URL maybe?
No, once you visit the topic for the first time, the work is already done, so when you reply to a topic this extension already finished its job, at least until you purge the cache, that's why I highly doubt this extension is the cause of the issue you're having.
Some of my phpBB extensions: [ Imgur | SEO Metadata | Markdown ]
Check out all my extensions
Arch Linux user

User avatar
Wuppi
Registered User
Posts: 16
Joined: Mon Jun 17, 2019 9:22 am
Contact:

Re: [3.2][BETA] SEO Metadata

Post by Wuppi » Tue Jul 16, 2019 6:04 pm

I have a question about the extension - purely technical - no bug or feature request :). Today I cleaned up the "Who is online?" - blocked bots, etc. Suddenly I see a GUEST downloading a picture. The guest has the IP of the server => now it became curious. Why does the server download pictures?

I called the server owner and asked what exactly the IP downloads: Various pictures.

I then blocked the IP via htaccess ("403/forbidden"). The calls gave now 403 in the log for these ominous picture downloads - but no further visible problems. When he said that only the first image is downloaded, I knew what was responsible. This has to do with your extension.

We verified that:
Public area, image with >200x200px. No IP-Block: I get a matching ogp-image-tag, width, height. Correct. I set an IP block: I only get the "default image tag".

So your script calls the attachment and checks if it is allowed to do that as a guest ... only then it comes into the Meta-OGP-Tags. With a refresh of the page the graphic is not retrieved again. Here is cached. How is cached here? In /cache/ ?

And why is the graphic called as a guest? Wouldn't it be better to query the database whether guests are allowed to view the image?

... ok and now a (small; absolutely no priority) feature request: the call is made by guest without UserAgent. It would be less irritating if the guest has a UserAgent with something like "SEO Metadata-Extension" - that would have saved us (and maybe other admins who are interested in what's going on in the forum *G*) the research time :)

User avatar
AbaddonOrmuz
Registered User
Posts: 640
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo Ramos
Contact:

Re: [3.2][BETA] SEO Metadata

Post by AbaddonOrmuz » Tue Jul 16, 2019 7:19 pm

Wuppi wrote:
Tue Jul 16, 2019 6:04 pm
I have a question about the extension - purely technical - no bug or feature request :). Today I cleaned up the "Who is online?" - blocked bots, etc. Suddenly I see a GUEST downloading a picture. The guest has the IP of the server => now it became curious. Why does the server download pictures?
It doesn't download pictures, it uses the phpBB interface to see attachments, which happens to be also used to download files (attachments). I created a test post, inspect the image URL.

viewtopic.php?t=2516906
Wuppi wrote:
Tue Jul 16, 2019 6:04 pm
I called the server owner and asked what exactly the IP downloads: Various pictures.

I then blocked the IP via htaccess ("403/forbidden"). The calls gave now 403 in the log for these ominous picture downloads - but no further visible problems. When he said that only the first image is downloaded, I knew what was responsible. This has to do with your extension.
False assumption, as I said, that's what phpBB does, I only construct that URL to point to an attachment of the topic.
Wuppi wrote:
Tue Jul 16, 2019 6:04 pm
We verified that:
Public area, image with >200x200px. No IP-Block: I get a matching ogp-image-tag, width, height. Correct. I set an IP block: I only get the "default image tag".
Well that's intended, you blocked your own server IP.
Wuppi wrote:
Tue Jul 16, 2019 6:04 pm
So your script calls the attachment and checks if it is allowed to do that as a guest ... only then it comes into the Meta-OGP-Tags. With a refresh of the page the graphic is not retrieved again. Here is cached. How is cached here? In /cache/ ?
Another false assumption, it doesn't check if a guest can see attachments, only if the image is readable.

If you don't want guest can see attachments, change the appropriate settings and permissions in the ACP, so the next time the script tries to get the image information, it will fail (403 status, probably) and that attachment will be ignored. But note that if you change guests permissions for attachments, you will invalidate the SEO Metadata settings for that, so you will be always be getting either non-attachment images or the default one.

The image is not cached, only its URL, width, height and MIME type.

The location of the cached information depends of the driver you're using, defined in config.php. Is cache/production only if you're using the file driver and you set production as the container.
Wuppi wrote:
Tue Jul 16, 2019 6:04 pm
And why is the graphic called as a guest? Wouldn't it be better to query the database whether guests are allowed to view the image?
Because that's how crawlers (Facebook, Twitter, Google, etc) see your website when you share a topic.

What you propose is done by changing the attachments permissions and settings, but as I previously said, if you block guests to see attachments, you're disabling attachments in this extension.
Wuppi wrote:
Tue Jul 16, 2019 6:04 pm
... ok and now a (small; absolutely no priority) feature request: the call is made by guest without UserAgent. It would be less irritating if the guest has a UserAgent with something like "SEO Metadata-Extension" - that would have saved us (and maybe other admins who are interested in what's going on in the forum *G*) the research time :)
It doesn't solve any problem, and that feature is very specific for you, I don't think that's enough for a new feature.

I don't see what's "irritating" about that, besides, an user agent is not even reliable, anyone can spoof it.
Some of my phpBB extensions: [ Imgur | SEO Metadata | Markdown ]
Check out all my extensions
Arch Linux user

koraldon
Registered User
Posts: 509
Joined: Sat Jun 30, 2007 12:42 pm

Re: [3.2][BETA] SEO Metadata

Post by koraldon » Sat Jul 20, 2019 11:20 am

I rolled back to 1.1.0 and the conflict with quickreply reloaded disappeared, AJAX is now working well, just FYI
Thanks.

User avatar
AbaddonOrmuz
Registered User
Posts: 640
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo Ramos
Contact:

Re: [3.2][BETA] SEO Metadata

Post by AbaddonOrmuz » Mon Aug 19, 2019 4:01 am

Version 1.2.0-beta3 released, see the changelog for more information.
Some of my phpBB extensions: [ Imgur | SEO Metadata | Markdown ]
Check out all my extensions
Arch Linux user

User avatar
jackennils
Registered User
Posts: 207
Joined: Mon Jun 01, 2009 7:48 pm

Re: [3.2][BETA] SEO Metadata

Post by jackennils » Mon Aug 19, 2019 4:42 pm

Hello Alfredo,

I just updated to 1.2.0-beta3 from 1.1.0 and I get this debug info on every topic:
Image

Please help!

User avatar
AbaddonOrmuz
Registered User
Posts: 640
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo Ramos
Contact:

Re: [3.2][BETA] SEO Metadata

Post by AbaddonOrmuz » Mon Aug 19, 2019 6:53 pm

jackennils wrote:
Mon Aug 19, 2019 4:42 pm
I just updated to 1.2.0-beta3 from 1.1.0 and I get this debug info on every topic:
Image
Hi,

Could you send me the full log in a private message? I don't see anything related to my extension, and that warning about the restriction the image shows could be related to the server setup.

I'm not calling those methods, so the issue is elsewhere.
Some of my phpBB extensions: [ Imgur | SEO Metadata | Markdown ]
Check out all my extensions
Arch Linux user

User avatar
jackennils
Registered User
Posts: 207
Joined: Mon Jun 01, 2009 7:48 pm

Re: [3.2][BETA] SEO Metadata

Post by jackennils » Mon Aug 19, 2019 7:00 pm

Check your PMs.

The ext update was the only thing I have changed. I now went back to 1.1.0 and everything was fine again.

Post Reply

Return to “Extensions in Development”