[ALPHA] [3.2] PG Social Network

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Get Involved
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
Post Reply
User avatar
Mathieu M.
Registered User
Posts: 176
Joined: Tue Nov 02, 2010 11:42 am
Location: France
Name: Mathieu

Re: [ALPHA] [3.2] PG Social Network

Post by Mathieu M. » Fri Jan 04, 2019 9:32 pm

Hi,

Great stuff here! :shock:

Some bugs with last version:
  • Cover image doesn't work (not saved)
  • A link for creating new page (blog?) that generates an error when submitting page title
  • Some langage mistakes (well, when your extension will be more "stable", I could translate it to French if you want)
Thx a lot for your work! :D
πŸ˜„πŸ˜„πŸ˜πŸ˜„πŸ˜„

NastyBoy
Registered User
Posts: 119
Joined: Wed May 31, 2017 7:03 pm
Location: Germany
Name: Tim
Contact:

Re: [ALPHA] [3.2] PG Social Network

Post by NastyBoy » Sat Jan 05, 2019 2:58 pm

Thank you for this Update is very good

User avatar
PGreca
Registered User
Posts: 36
Joined: Mon Oct 29, 2018 12:36 pm
Location: Italy
Contact:

Re: [ALPHA] [3.2] PG Social Network

Post by PGreca » Sat Jan 05, 2019 8:16 pm

Mathieu M. wrote: ↑
Fri Jan 04, 2019 9:32 pm
Hi,

Great stuff here! :shock:

Some bugs with last version:
  • Cover image doesn't work (not saved)
  • A link for creating new page (blog?) that generates an error when submitting page title
  • Some langage mistakes (well, when your extension will be more "stable", I could translate it to French if you want)
Thx a lot for your work! :D
  • I have fixed the problem with change cover.
  • What title you have tried?
Thanks Fonzi for update translation sk

User avatar
Mathieu M.
Registered User
Posts: 176
Joined: Tue Nov 02, 2010 11:42 am
Location: France
Name: Mathieu

Re: [ALPHA] [3.2] PG Social Network

Post by Mathieu M. » Sat Jan 05, 2019 8:57 pm

PGreca wrote: ↑
Sat Jan 05, 2019 8:16 pm
I have fixed the problem with change cover.
Well, it's impossible for me to save a new cover image (I press "Enter" key or "Update profile" button)
PGreca wrote: ↑
Sat Jan 05, 2019 8:16 pm
What title you have tried?
On page activity, you have a link "Pages" on leftside. If I click on it and then "Create page", I write a "Test" title and save. It gives me:

Code: Select all

SQL ERROR [ mysqli ]

Unknown column 'page_about' in 'field list' [1054]

SQL

INSERT INTO phpbb_pg_social_pages (page_type, page_status, page_founder, page_regdate, page_username, page_username_clean, page_avatar, page_cover, page_cover_position, page_about) VALUES (0, 0, '2', 1546721772, 'Test', 'test', '', '', '', '')

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 997
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 193
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/ext/pgreca/pgsocial/social/social_page.php
LINE: 81
CALL: phpbb\db\driver\factory->sql_query()

FILE: [ROOT]/ext/pgreca/pgsocial/controller/pages.php
LINE: 186
CALL: pgreca\pgsocial\social\social_page->page_create()

FILE: [ROOT]/vendor/symfony/http-kernel/HttpKernel.php
LINE: 135
CALL: pgreca\pgsocial\controller\pages->handlepage()

FILE: [ROOT]/vendor/symfony/http-kernel/HttpKernel.php
LINE: 57
CALL: Symfony\Component\HttpKernel\HttpKernel->handleRaw()

FILE: [ROOT]/app.php
LINE: 35
CALL: Symfony\Component\HttpKernel\HttpKernel->handle()
πŸ˜„πŸ˜„πŸ˜πŸ˜„πŸ˜„

User avatar
eunaumtenhoid
Registered User
Posts: 860
Joined: Wed Jun 03, 2009 12:46 am
Location: ????

Re: [ALPHA] [3.2] PG Social Network

Post by eunaumtenhoid » Sun Jan 06, 2019 1:52 pm

login and password dont work for demo

share style too?
My translations of the extensions for Brazilian Portuguese
https://github.com/phpBBTraducoes

User avatar
PGreca
Registered User
Posts: 36
Joined: Mon Oct 29, 2018 12:36 pm
Location: Italy
Contact:

Re: [ALPHA] [3.2] PG Social Network

Post by PGreca » Sun Jan 06, 2019 2:29 pm

eunaumtenhoid wrote: ↑
Sun Jan 06, 2019 1:52 pm
login and password dont work for demo

share style too?
I have disabled test account for abuses of them by testers. Sorry. If you want test you need register.
I edited the main post of topic.
Mathieu M. wrote: ↑
Sat Jan 05, 2019 8:57 pm
Well, it's impossible for me to save a new cover image (I press "Enter" key or "Update profile" button)
MMM strange, can you tell me more?
Mathieu M. wrote: ↑
Sat Jan 05, 2019 8:57 pm
Unknown column 'page_about' in 'field list' [1054]
Ops, i forget on migration :P

Tell me if you found other bugs.. (sorry for the incovenience)

User avatar
Mathieu M.
Registered User
Posts: 176
Joined: Tue Nov 02, 2010 11:42 am
Location: France
Name: Mathieu

Re: [ALPHA] [3.2] PG Social Network

Post by Mathieu M. » Sun Jan 06, 2019 3:13 pm

PGreca wrote: ↑
Sun Jan 06, 2019 2:29 pm
Mathieu M. wrote:Well, it's impossible for me to save a new cover image (I press "Enter" key or "Update profile" button)
MMM strange, can you tell me more?
Well, my test board is running phpBB 3.2.5 and my PHP version is 7.1. Oh, and I test it with Firefox on my computer. Tell me if you want more informations.
πŸ˜„πŸ˜„πŸ˜πŸ˜„πŸ˜„

User avatar
PGreca
Registered User
Posts: 36
Joined: Mon Oct 29, 2018 12:36 pm
Location: Italy
Contact:

Re: [ALPHA] [3.2] PG Social Network

Post by PGreca » Sun Jan 06, 2019 4:30 pm

Mathieu M. wrote: ↑
Sun Jan 06, 2019 3:13 pm
PGreca wrote: ↑
Sun Jan 06, 2019 2:29 pm
Mathieu M. wrote:Well, it's impossible for me to save a new cover image (I press "Enter" key or "Update profile" button)
MMM strange, can you tell me more?
Well, my test board is running phpBB 3.2.5 and my PHP version is 7.1. Oh, and I test it with Firefox on my computer. Tell me if you want more informations.
If you haven't post activities or photo and albums, can you try to disable and cancel dates of the extension?
I think is a conflict with my wrong oldest compilation of migration.

(I saw the problem to "blink" chat on firefox, i will fix soon)

User avatar
Mathieu M.
Registered User
Posts: 176
Joined: Tue Nov 02, 2010 11:42 am
Location: France
Name: Mathieu

Re: [ALPHA] [3.2] PG Social Network

Post by Mathieu M. » Sun Jan 06, 2019 4:48 pm

PGreca wrote: ↑
Sun Jan 06, 2019 4:30 pm
Mathieu M. wrote: ↑
Sun Jan 06, 2019 3:13 pm
PGreca wrote: ↑
Sun Jan 06, 2019 2:29 pm
Mathieu M. wrote:Well, it's impossible for me to save a new cover image (I press "Enter" key or "Update profile" button)
MMM strange, can you tell me more?
Well, my test board is running phpBB 3.2.5 and my PHP version is 7.1. Oh, and I test it with Firefox on my computer. Tell me if you want more informations.
If you haven't post activities or photo and albums, can you try to disable and cancel dates of the extension?
I think is a conflict with my wrong oldest compilation of migration.

(I saw the problem to "blink" chat on firefox, i will fix soon)
I tried this and no effect, the cover image doesn't update.
πŸ˜„πŸ˜„πŸ˜πŸ˜„πŸ˜„

maxwellqc13
Registered User
Posts: 145
Joined: Fri Mar 10, 2017 9:51 pm
Location: Iowa
Name: Max

Re: [ALPHA] [3.2] PG Social Network

Post by maxwellqc13 » Thu Jan 10, 2019 5:18 am

Great work I have been trying to expand the profile ofor some time this covers it and more.. I have been running PGS on my test site for a couple months now with some issues but most seem to have been addressed or acknowledged. Below is a shot of one. this site had phpBB 3.2.4

Image

I built a new test site this weekend with 3.2.5 and had everything running as I wanted then I enabled the newest version of PGS and had some issues when it tried to create the tables. Have not had this before and did not change any core items on this test site vs prior ones with PGS on it other then version updates.

Here is the error and what the board is running.
Image


Image

User avatar
PGreca
Registered User
Posts: 36
Joined: Mon Oct 29, 2018 12:36 pm
Location: Italy
Contact:

Re: [ALPHA] [3.2] PG Social Network

Post by PGreca » Thu Jan 10, 2019 10:37 am

I edited the migrations for to depends from his parent.
Try now if his return error or work.

maxwellqc13
Registered User
Posts: 145
Joined: Fri Mar 10, 2017 9:51 pm
Location: Iowa
Name: Max

Re: [ALPHA] [3.2] PG Social Network

Post by maxwellqc13 » Thu Jan 10, 2019 10:17 pm

PGreca wrote: ↑
Thu Jan 10, 2019 10:37 am
I edited the migrations for to depends from his parent.
Try now if his return error or work.
I just tried from the most recent commit and received the same error. I am stuck at the moment as it will not enable due to the sql issue and I can't remove either. If I try and delete data it just spins till error out with no results.


Image

User avatar
PGreca
Registered User
Posts: 36
Joined: Mon Oct 29, 2018 12:36 pm
Location: Italy
Contact:

Re: [ALPHA] [3.2] PG Social Network

Post by PGreca » Fri Jan 11, 2019 12:42 pm

maxwellqc13 wrote: ↑
Thu Jan 10, 2019 5:18 am
Image
I hope you have a backup database before to tryed install ext..

If you can add manually the table of the photos, because i haven't other ideas to resolve it..
CREATE TABLE `phpbb_pg_social_photos` ( `photo_id` int( 11 ) unsigned NOT NULL AUTO_INCREMENT ,
`photo_where` int( 1 ) unsigned NOT NULL DEFAULT '0',
`album_id` int( 11 ) unsigned NOT NULL DEFAULT '0',
`user_id` int( 11 ) unsigned NOT NULL DEFAULT '0',
`photo_file` varchar( 255 ) COLLATE utf8_bin NOT NULL DEFAULT '',
`photo_time` int( 11 ) unsigned NOT NULL DEFAULT '0',
`photo_desc` mediumtext COLLATE utf8_bin NOT NULL ,
`gallery_id` int( 11 ) unsigned NOT NULL DEFAULT '0',
PRIMARY KEY ( `photo_id` ) ) ENGINE = MyISAM DEFAULT CHARSET = utf8 COLLATE = utf8_bin AUTO_INCREMENT =1

"No Extensions within this forum should be used within a live environment!"
cit.

maxwellqc13
Registered User
Posts: 145
Joined: Fri Mar 10, 2017 9:51 pm
Location: Iowa
Name: Max

Re: [ALPHA] [3.2] PG Social Network

Post by maxwellqc13 » Sun Jan 13, 2019 12:35 am

PGreca wrote: ↑
Fri Jan 11, 2019 12:42 pm
I hope you have a backup database before to tryed install ext..
This is a test site I am building not my live. I also do have BU for the test site I do every day so there is not any issues on data loss.

User avatar
mrgoldy
Jr. Extension Validator
Posts: 1098
Joined: Tue Oct 06, 2009 7:34 pm
Location: The Netherlands
Name: Gijs
Contact:

Re: [ALPHA] [3.2] PG Social Network

Post by mrgoldy » Sun Jan 13, 2019 3:06 pm

It's better to not run the SQL query directly from your migration file: https://github.com/PGreca/pgsocial/blob ... 03.php#L23
Altering SQL queries may differ per driver class.

Instead, use the migration tool for altering an existing column: https://area51.phpbb.com/docs/dev/3.2.x ... l#examples

Code: Select all

        'change_columns'    => array(
            $this->table_prefix . 'groups'        => array(
                'group_legend'        => array('UINT', 0),
            ),
        ),
However, you are trying to 'alter' a column to UINT:11 (here) which is already set up to be so (see here). And then you create another column with the same name here.

Post Reply

Return to β€œExtensions in Development”