Attachment not allowed despite permissions ok

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning

Attachment not allowed despite permissions ok

Postby mike-nolan » Thu Jun 26, 2008 9:43 pm

I have been using PHPBB3 version 3.0.1 with my team and is well - except for the inability to include attachments in posts.

I have perused the web and boards for clues or bugs - no joy
Group Extensions are defined and valid - enabled
Extensions for the documnts, download and archives are correct
File sizes for posts/attachments are fine

For some strange reasons zip files in archives are allowed but doc, ppt, xls etc are not....despite the "documents" and "archives" having the same "allowe settings. Also check the write permission of tmp directory and IIS....all seems well.

However any post with an attachment of doc or ppt etc gets the error messgae "extension not allowed"

Where am I going wrong ?
Last edited by stevemaury on Wed Nov 26, 2008 3:28 pm, edited 1 time in total.
Reason: Topic icon changed to solved.
User avatar
mike-nolan
Registered User
 
Posts: 30
Joined: Thu Jun 26, 2008 9:29 pm

Re: Attachment not allowed despite permissions ok

Postby jannissen » Fri Jun 27, 2008 7:36 pm

I assume you have administration permission. Go into the administration control, choose post and attachments. Here you can set your permissions. It seem like you haven't done this. It works fine with me. Just remember to adjust the downloaded size allowed.

PS. I have a Danish version of phpBB 3.0.0 and I hope the translation into eEnglish is corect
jannissen
Registered User
 
Posts: 1
Joined: Tue Dec 18, 2007 11:06 pm

Re: Attachment not allowed despite permissions ok

Postby Erica Gage » Mon Jul 14, 2008 2:37 pm

I, too, am having the same issue. I have followed all of the messages that I have found thus far, and still cannot get attachments to process.
Erica Gage
Registered User
 
Posts: 6
Joined: Mon Jul 14, 2008 2:28 pm

Re: Attachment not allowed despite permissions ok

Postby stevemaury » Mon Jul 14, 2008 3:17 pm

3 things.

1. You must allow attachments and configure allowable extensions.

2. The Registered Users group must have a group permission to attach files.

3. The forum must allow posting attachments in Groups' Forum Permissions.
For REALLY good and VERY inexpensive hosting CLICK HERE

http://www.stevesstocks.com

All unsolicited PMs will be ignored.
User avatar
stevemaury
Support Team Member
Support Team Member
 
Posts: 44096
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve

Re: Attachment not allowed despite permissions ok

Postby Erica Gage » Mon Jul 14, 2008 6:48 pm

Thank you for your assistance, but I've gone over these items for the last few days. I've even re-checked the write permissions on the /files/ folder, restarted the web service, purged the cache on phpBB, purged the cache on the internet browser, and tested in a few other web browsers. Whew! Still, I get the "The extenison *** is not allowed" regardless of what I attempt to attach. Is there something else that I am just not seeing?

- Erica

P.S.
I have allowed extenisons for: doc, docx, ppt, pdf, rtf, csv, xls, xlsx, txt (primarily)
Erica Gage
Registered User
 
Posts: 6
Joined: Mon Jul 14, 2008 2:28 pm

Re: Attachment not allowed despite permissions ok

Postby mike-nolan » Mon Jul 14, 2008 10:01 pm

All suggestions have been tried already - permissions, groups, extensions are all perfectly valid and correct.

I've checked and rechecked this should work - ppt, xls, txt just simply get stopped.

Even tried this as Adminstrator level, as level as multiple users - no joy same symptoms - permissions look right - but I can only post a bmp or zip file...."images", yet I have tripled checked the settings of "documents" vs "images" and they are identical ( extensions apart of course).

Check error logs -nothing shows up - forum is great and active -just no-one can post doc's , powerpoints or other useful info.....very frustating.

At least I am not alone with this problem...........is there a php mod or script to run and diagnose this error ?
User avatar
mike-nolan
Registered User
 
Posts: 30
Joined: Thu Jun 26, 2008 9:29 pm

Re: Attachment not allowed despite permissions ok

Postby stevemaury » Tue Jul 15, 2008 12:08 am

4th thing. The extensions must be allowed in the Attachment extensions settings.
For REALLY good and VERY inexpensive hosting CLICK HERE

http://www.stevesstocks.com

All unsolicited PMs will be ignored.
User avatar
stevemaury
Support Team Member
Support Team Member
 
Posts: 44096
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve

Re: Attachment not allowed despite permissions ok

Postby mike-nolan » Tue Jul 15, 2008 9:12 am

Attachment extensions are correct too - and include ppt, doc, xls etc.

For anyone who can spare 5 mins to peruse I have attached screenshots here in a short 3 page Word document.....in case I'm making some fundamental error - but I cannot see it......here's hoping :-)

Interesting.............

Just got the same problem with this board - "The extension doc is not allowed"

Are we not allowed to post "Word docs to this forum ?"....or is the same bug I'm seeing on my PHBB3 ?
User avatar
mike-nolan
Registered User
 
Posts: 30
Joined: Thu Jun 26, 2008 9:29 pm

Re: Attachment not allowed despite permissions ok

Postby Pit$Bull » Tue Jul 15, 2008 9:39 am

Have you checked ACP->posting->Manage extension groups
Edit with 'green cog'
Pit$Bull
Former Team Member
 
Posts: 23099
Joined: Sat Dec 02, 2006 4:08 pm
Name: Can't Remember

Re: Attachment not allowed despite permissions ok

Postby mike-nolan » Tue Jul 15, 2008 9:46 am

Yes - already checked as one of the first settings before I posted query - I honestly do not believe its a setting issue anymore....as I have check backwards and forwards multiple times. Seen the green cogs so many times makes my head spin.....
User avatar
mike-nolan
Registered User
 
Posts: 30
Joined: Thu Jun 26, 2008 9:29 pm

Re: Attachment not allowed despite permissions ok

Postby mike-nolan » Tue Jul 15, 2008 9:53 am

Okay so this is now really weird - this Support Forum exhibits the same problems as I have on my own forum.

Unable to post a small word document (262K) to this forum

Able to post it as a ZIP - see attachment

Is there a buried permisison or inbuilt filter or "bug" stopping documents being posted ?
Attachments
Inability to post attachments docs-xls-ppt etc.zip
ZIP of word doc of screen checks
(209.25 KiB) Downloaded 43 times
User avatar
mike-nolan
Registered User
 
Posts: 30
Joined: Thu Jun 26, 2008 9:29 pm

Re: Attachment not allowed despite permissions ok

Postby Erica Gage » Tue Jul 15, 2008 3:50 pm

I think I may have found a solution -- albeit a temporary one. I modified the data_extensions document to inlcude one of my allowed extensions that was NOT working; it seems to work now. I haven't tried with all of my other allowed extensions as yet, but it kind of concerns me to have to modify this file when it apppears as though the modifications in the admin control panel should be modifying it.
Erica Gage
Registered User
 
Posts: 6
Joined: Mon Jul 14, 2008 2:28 pm

Re: Attachment not allowed despite permissions ok

Postby Brf » Tue Jul 15, 2008 3:53 pm

mike-nolan wrote:Okay so this is now really weird - this Support Forum exhibits the same problems as I have on my own forum.

Unable to post a small word document (262K) to this forum

Able to post it as a ZIP - see attachment

Is there a buried permisison or inbuilt filter or "bug" stopping documents being posted ?


I assume this forum has document extensions disabled on the Manage Extension Groups page.
User avatar
Brf
Support Team Member
Support Team Member
 
Posts: 46839
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}

Re: Attachment not allowed despite permissions ok

Postby mike-nolan » Tue Jul 15, 2008 4:28 pm

I'm not assuming anything anymore -hence why I asked the question......if this actual forum has permssions set to allow "document posts" with extension of .doc - then we have a common bug/issue

Hence why it got weird....can the forum administrator clarify the permission for registered users posts - are docs allowed ?????

I' like Erica's workaround - but adding all document extensions into Archives type say - is painful and as she points out - not the way to use ACP & permissions....becomes non-granular and confusing. Glad its not just me with the problem though.
User avatar
mike-nolan
Registered User
 
Posts: 30
Joined: Thu Jun 26, 2008 9:29 pm

Re: Attachment not allowed despite permissions ok

Postby Cuisinart » Tue Jul 15, 2008 9:20 pm

I just found out I have the same problem and started looking for help here only to find this thread. I have also checked over all the settings and according to them I should be able to attach a .wav file but it comes up with the message "The extension wav is not allowed"
Cuisinart
Registered User
 
Posts: 7
Joined: Sun Apr 24, 2005 1:35 am

Next

Return to 3.0.x Support Forum

Who is online

Users browsing this forum: bcrider, MSNbot Media, Oyabun1, Yandex [Bot] and 75 guests