"e-mail address is already in use"

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
buddyl
Registered User
Posts: 34
Joined: Sun Aug 10, 2008 11:32 pm

"e-mail address is already in use"

Post by buddyl » Sat Aug 16, 2008 3:39 pm

I tried to do another test registration and recieved error:
"e-mail address is already in use"

I looked in my MySQL database and could not find where the list of users is stored.

In the ACP there are two members....me and a test member (and not using e-mail referred to)

The "e-mail address already in use" is one I used earlier in the testing phase but have already deleted in the ACP. I thought I could go to MySQL database and edit - delete - manage users.

Do I have to edit code:

http://code.phpbb.com/svn/phpbb/trunk/p ... en/ucp.php

172 7524 acydburn 'EMAIL_TAKEN_EMAIL' => 'The entered e-mail address is already in use.',

http://code.phpbb.com/repositories/diff/5?rev=7524


Thx

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50507
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: "e-mail address is already in use"

Post by stevemaury » Sat Aug 16, 2008 3:41 pm

If you go to Manage users and click the Find a Member link, you can search by email address and figure out where the conflict is.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

buddyl
Registered User
Posts: 34
Joined: Sun Aug 10, 2008 11:32 pm

Re: "e-mail address is already in use"

Post by buddyl » Sat Aug 16, 2008 3:50 pm

thx

I'll try later...gotta go to work now.

Isaac001
Registered User
Posts: 3
Joined: Mon Aug 11, 2008 2:21 pm
Location: Nowhere, Maine
Contact:

Re: "e-mail address is already in use"

Post by Isaac001 » Sat Aug 16, 2008 5:47 pm

Also in the ACP you can change settings to allow multiple uses of the same Email Address.

buddyl
Registered User
Posts: 34
Joined: Sun Aug 10, 2008 11:32 pm

Re: "e-mail address is already in use"

Post by buddyl » Sun Aug 17, 2008 2:50 am

I tried looking up a member by e-mail but got no results. There's only me (the admin) and one test registered user, and both use one of my domain accounts.

What first got me to this issue was, my neighbor tried signing up using a hotmail account and got an error message saying something like "e-mail not reconized"

I thought maybe it was a Hotmail issue. Then I remembered that I also used my hotmail account to test register before and it worked for me. So I tried to sign up using my own Hotmail account again to test this. That's when I got the error "E-mail already used..."

There is only 2 accounts, and neither use a hotmail address! I deleted my hotmail user from my ACP.

And another thing that's odd is, when I first installed phpBB, it asked for an e-mail address. So I put forum@MYDOMAIN.com, thinking....later I'll go back and add that account to my domain account because it didn't yet exist (and still doesn't). But later I forgot to do this. Yet when I registeres myself to test, I recieve e-mail from that address! Weird!

I looked in all the php files looking for default email settings and couldn't find anything.


Oh, and I checked in the ACP you can change settings to allow multiple uses of the same Email Address. It's checked NO.

User avatar
ric323
Former Team Member
Posts: 22909
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: "e-mail address is already in use"

Post by ric323 » Sun Aug 17, 2008 5:45 am

buddyl wrote:...
And another thing that's odd is, when I first installed phpBB, it asked for an e-mail address. So I put forum@MYDOMAIN.com, thinking....later I'll go back and add that account to my domain account because it didn't yet exist (and still doesn't). But later I forgot to do this. Yet when I registeres myself to test, I recieve e-mail from that address! Weird!
How is your web server configured to handle email to unknown email usernames on your domain?
Most have a "catch-all" address, which passes on all unknown addresses to you anyway.
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

buddyl
Registered User
Posts: 34
Joined: Sun Aug 10, 2008 11:32 pm

Re: "e-mail address is already in use"

Post by buddyl » Sun Aug 17, 2008 5:55 am

When you Manage Users, you have to check the box "delete user", not just "deactivate account" on the drop down menu. When you deactivate the acount, their profile (and their e-mail address) disappear into limbo. I tried "I FORGOT MY PASSWORD" and just entered the e-mail address to see if a new passwrd would be e-mailed to me, so I could see what username it was sent to, but you need both the username and the e-mail address for this. So I had to remember all the usernames I used to do a look up in Manage Users to find their profiles. It wasn't listed in the Users list.

I had test123,123test,test,testing, thetest, etc...a bunch to remember, look-up, and delete. Bottom line is...

Don't just "deactivate account", check the box "delete user"

buddyl
Registered User
Posts: 34
Joined: Sun Aug 10, 2008 11:32 pm

Re: "e-mail address is already in use"

Post by buddyl » Sun Aug 17, 2008 6:04 am

buddyl wrote:When you Manage Users, you have to check the box "delete user", not just "deactivate account" on the drop down menu. When you deactivate the acount, their profile (and their e-mail address) disappear into limbo. I tried "I FORGOT MY PASSWORD" and just entered the e-mail address to see if a new passwrd would be e-mailed to me, so I could see what username it was sent to, but you need both the username and the e-mail address for this. So I had to remember all the usernames I used to do a look up in Manage Users to find their profiles. It wasn't listed in the Users list.

I had test123,123test,test,testing, thetest, etc...a bunch to remember, look-up, and delete. Bottom line is...

Don't just "deactivate account", check the box "delete user"

I have my catch-all address assigned to the default webmaster@mydomain.com that auto-generates an e-mail saying they were to contact me via my Contact page on the web site. It was a SPAM thing.

But how is forum@mydomain.com getting through to me? Under properties the the return path is

httpd@mydomain.com

I also use a self-registration form for the members Area that I got from Deadlock http://www.phpdeadlock.org/demo.php and that auto generates htaccess and htpasswd files with httpd permissions. Never saw that. All my other ones have my username/group for permisssions. Whats httpd?

neps
Registered User
Posts: 66
Joined: Thu Nov 21, 2002 12:38 pm

Re: "e-mail address is already in use"

Post by neps » Wed Aug 27, 2008 11:18 am

This seems similar to an issue I am having.

I keep getting emails from users trying to sign on - but it says their email is already in use. This is most likely a user who signed up and forgot his information.

I've went to the members page in the ACP and searched by email - and it says no results found. Then I've gone into phpmyadmin and searched the database, and have SUCCESSFULLY found the user that is attached to that email.

It seems to me that the members table needs to be rebuilt or something like that?

Is there any tips to recreate the member search so that I can find these emails without phpmyadmin?

thanks,

neil

User avatar
ric323
Former Team Member
Posts: 22909
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: "e-mail address is already in use"

Post by ric323 » Wed Aug 27, 2008 11:35 am

neps wrote:I've went to the members page in the ACP and searched by email - and it says no results found.
There is no "search by email" feature in the ACP, only by username.

You can use the Admin Toolkit (link in my sig), to sort members by email address.
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

SamG
Former Team Member
Posts: 3221
Joined: Fri Aug 31, 2001 6:35 pm
Location: Beautiful Northwest Lower Michigan
Name: Sam Graf

Re: "e-mail address is already in use"

Post by SamG » Wed Aug 27, 2008 1:24 pm

ric323 wrote:There is no "search by email" feature in the ACP, only by username.
In ACP, Users and Groups, User administration, if you use "Find a member," you can search on a variety of user details, including e-mail address.
member_search.jpg
member_search.jpg (37.45 KiB) Viewed 5506 times
Or am I misunderstanding?
We should talk less, and say more.

User avatar
ric323
Former Team Member
Posts: 22909
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: "e-mail address is already in use"

Post by ric323 » Wed Aug 27, 2008 1:43 pm

Oops, was following an email notification link back to this topic, and thought I was still in the phpBB2 Support forum.
Please ignore my comment above! :oops:
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

neps
Registered User
Posts: 66
Joined: Thu Nov 21, 2002 12:38 pm

Re: "e-mail address is already in use"

Post by neps » Fri Aug 29, 2008 8:29 pm

so no way to rebuild the members table? I did a mysql check on the database and everything came out fine.

wisconsinnafa
Registered User
Posts: 4
Joined: Tue Jan 13, 2009 11:06 pm

Re: "e-mail address is already in use"

Post by wisconsinnafa » Tue Jan 13, 2009 11:18 pm

I keep getting emails from users trying to sign on - but it says their email is already in use. This is most likely a user who signed up and forgot his information.

I've went to the members page in the ACP and searched by email - and it says no results found. Then I've gone into phpmyadmin and searched the database, and have SUCCESSFULLY found the user that is attached to that email.

It seems to me that the members table needs to be rebuilt or something like that?
This sounds exactly like the problem I've having. Anyone have a solution for this yet?
Thanks!

wisconsinnafa
Registered User
Posts: 4
Joined: Tue Jan 13, 2009 11:06 pm

Re: "e-mail address is already in use"

Post by wisconsinnafa » Thu Jan 15, 2009 7:01 pm

Okay, I figured this out. In the ACP there is an inactive users list (I never noticed this before). This is where users that registered but never clicked the activation link are listed (as well as deactivated users that were not deleted), along with their email address and other info. Anyone that has not activated their account will not show up in a search, but the username and email address will still be considered to be already in use. You can then delete the inactive users from the inactive users list, or activate them, whichever you choose. I just deleted all mine, and then my problem was resolved.

Locked

Return to “[3.0.x] Support Forum”