Internal Server Error - upgrade 2.0.21 > 3.0.2

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Ideas Centre
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
davidm999
Registered User
Posts: 12
Joined: Sat Aug 14, 2004 3:14 am

Internal Server Error - upgrade 2.0.21 > 3.0.2

Post by davidm999 »

I'm trying to upgrade my 2.0.21 board to 3.0.2. I've done a clean install of phpBB3 with a new database etc and everything works fine.

However when I ran the Install Convertor I got an 'Internal Server Error' - The server encountered an internal error or misconfiguration and was unable to complete your request.

I contacted my hosting provider (GoDaddy) and they replied:
'An internal server error is a 500 error which is most commonly related to some sort of scripting issue. When the script attempts to execute but is not written correctly or is missing some syntax it will throw this type of error.'

In the conversion guide:
http://www.phpbb.com/support/documents. ... =3#convert
it says "Note that the conversion requires CREATE and DROP privileges for the phpBB3's database user account."

Can anyone advise how I check the rights for the database user acount?

I'd also appreciate any suggestions on what else to try before I go to an offline solution.

My board is not that big - about 4000 posts and 500 users.

Thanks in advance
David M
wired076
Registered User
Posts: 1441
Joined: Mon May 21, 2007 10:19 am

Re: Internal Server Error - upgrade 2.0.21 > 3.0.2

Post by wired076 »

You should contact your host and check what the timeout on scripts are.

It seems like they are not long enough.

This would definitely result in a 500 internal server error.

Are you with the free Godaddy service or the paid?? As free hosting may cause major issues when trying to do this as they add in ad's on sites and there are major restrictions limiting you on what you can do.
davidm999
Registered User
Posts: 12
Joined: Sat Aug 14, 2004 3:14 am

Re: Internal Server Error - upgrade 2.0.21 > 3.0.2

Post by davidm999 »

wired076 wrote:You should contact your host and check what the timeout on scripts are.

Are you with the free Godaddy service or the paid?? .
I'm with the paid Godaddy hosting plan - I didn't know there was a free one!

Thanks for the advice - I'll contact tech support again and ask about the timeouts.

Regards
David
wired076
Registered User
Posts: 1441
Joined: Mon May 21, 2007 10:19 am

Re: Internal Server Error - upgrade 2.0.21 > 3.0.2

Post by wired076 »

No problems.

Let us know how you go.
davidm999
Registered User
Posts: 12
Joined: Sat Aug 14, 2004 3:14 am

Re: Internal Server Error - upgrade 2.0.21 > 3.0.2

Post by davidm999 »

wired076 wrote:No problems.

Let us know how you go.
Unfortunately GoDaddy won't modify the timeouts. This is the response I got:
"Unfortuantley we would not be able to modify the timeouts or modify your account to exceed the limits as you are on a shared hosting account and it would jeopardize the other users on the server."

I'm sure plenty of people have upgraded their boards ok. Does anyone have a recommendation for a hosting provider that lets the upgrade script run ok ?

David M
Pit$Bull
Former Team Member
Posts: 23099
Joined: Sat Dec 02, 2006 4:08 pm
Name: Can't Remember

Re: Internal Server Error - upgrade 2.0.21 > 3.0.2

Post by Pit$Bull »

Sorry, it's against forum rules to recommend hosting but I can refer you to http://www.webhostingtalk.com/
wired076
Registered User
Posts: 1441
Joined: Mon May 21, 2007 10:19 am

Re: Internal Server Error - upgrade 2.0.21 > 3.0.2

Post by wired076 »

Due to not being able to recommend a host here as against the rules. Is that you have a search on google for hosts if you are thinking about changing and do some research.

I have never had any issues thus far upgrading any forums with this problem but have heard many have had this issue.

You could upgrade the site offline on your own machine and then upload it back to your webhost.

This should definitely resolve this issue and allow you to upgrade without an issue.

A setup on your local machine to do this can be achieved using easyphp, WAMP or XAMP.

Easyphp is probably the best choice as it is quickest to setup and use off the blocks.

Not much of a learning curve on how to set it up is required.

Let us know how you go.
Locked

Return to “[3.0.x] Support Forum”