Disable phpBB debug

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Ideas Centre
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
Kalani
Registered User
Posts: 7
Joined: Mon Dec 22, 2003 12:22 am

Disable phpBB debug

Post by Kalani » Sun Oct 12, 2008 10:17 am

Is there any way to completely disable the [phpBB Debug] notices?

I integrate phpBB with my main site. Sometimes, PHP errors will show up in phpBB debug notices even though I've disabled viewable PHP error notices on my site via .htaccess. The phpBB debug notices are a blatant security hole in my website.

(Yeah, yeah, you'll tell me to "fix the errors", but I'd rather do a blanket fix.)
Last edited by karlsemple on Sun Oct 12, 2008 9:44 pm, edited 1 time in total.
Reason: Topic icon changed

User avatar
karlsemple
Former Team Member
Posts: 39802
Joined: Mon Nov 01, 2004 8:54 am
Location: Hereford, UK
Contact:

Re: Disable phpBB debug

Post by karlsemple » Sun Oct 12, 2008 10:19 am

Have you uncommented the debug lines in the config.php? You should have

Code: Select all

// @define('DEBUG', true);
// @define('DEBUG_EXTRA', true);  
if one of these lines is uncommented, re-comment it and then save the file :)

EDIT: You might also want to change the error reporting level in the common.php on line 22

Code: Select all

// Report all errors, except notices
error_reporting(E_ALL ^ E_NOTICE); 
Image

Kalani
Registered User
Posts: 7
Joined: Mon Dec 22, 2003 12:22 am

Re: Disable phpBB debug

Post by Kalani » Sun Oct 12, 2008 6:51 pm

The second method appears to have worked. Thanks! :)

zoltanthemage
Registered User
Posts: 8
Joined: Mon Dec 24, 2007 7:28 am

Re: Disable phpBB debug

Post by zoltanthemage » Thu Oct 30, 2008 9:18 am

I've tried to change the
error_reporting(E_ALL ^ E_NOTICE);
to
error_reporting(0);

The result is a blank page after posting/deleting/etc., when you should get the "return to your message" page.
That's strange.

Deleting the error_reporting line works correctly.
// error_reporting(E_ALL ^ E_NOTICE);

dannyman1234
Registered User
Posts: 9
Joined: Mon May 19, 2008 7:57 am

Re: Disable phpBB debug

Post by dannyman1234 » Wed Jun 16, 2010 8:03 am

I tried it all still doesnt work, this damn, debugger makes me sick.
I also get a blank screen when i uncomment de defines in config.php
when i remove the line in common.php it doesnt go away.

Neubivljiv
Registered User
Posts: 76
Joined: Mon Jan 11, 2010 11:05 pm

Re: Disable phpBB debug

Post by Neubivljiv » Thu Oct 14, 2010 4:51 pm

This is working for me:
error_reporting(0);
but not:
//error_reporting(E_ALL ^ E_NOTICE);

tvcasualty
Registered User
Posts: 2
Joined: Sat Jun 02, 2007 9:27 pm

Re: Disable phpBB debug

Post by tvcasualty » Sat Feb 05, 2011 7:43 pm

me too

Tombc1234
Registered User
Posts: 48
Joined: Thu Mar 03, 2011 10:09 pm

Re: Disable phpBB debug

Post by Tombc1234 » Fri Apr 15, 2011 5:00 pm

I did the

Code: Select all

error_reporting(0);
fix, but then it made my delete post function go to a blank page. I undid the changes to common.php but it still goes to a blank page when I try and delete a post.

How can I fix this?

Please help, this is my baby :(

berniewest
Registered User
Posts: 24
Joined: Thu Aug 02, 2012 4:11 am

Re: Disable phpBB debug

Post by berniewest » Mon Dec 10, 2012 3:16 pm

Hi. I have this problem too. My page is showing debug warnings. The @debug lines are commented out, but my common.php file doesn't contain any line with "error_reporting", particularly not at line 22. How can I fix this problem?

User avatar
HGN
Former Team Member
Posts: 4706
Joined: Wed Dec 03, 2008 1:53 pm
Location: The Netherlands
Name: Alfred
Contact:

Re: Disable phpBB debug

Post by HGN » Mon Dec 10, 2012 3:22 pm

Then please start a new support topic. This one is allready marked solved Image.

When starting a new support topic, please fill out the Support Request Template Generator and post it in your support topic to enable us to assist you best.

Locked

Return to “[3.0.x] Support Forum”