Updating Question to 3.0.3

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
User avatar
Funk Theory
Registered User
Posts: 736
Joined: Mon Sep 25, 2006 3:33 pm
Location: UK
Contact:

Updating Question to 3.0.3

Post by Funk Theory »

When I updated from 3.0.1 to 3.0.2 i lost all my mods, I may of done this incorrectly. I am on 3.0.2 and at some point shortly will update to 3.0.3, do i just use the changed files because i do not want to lose any of the mods I have installed? Its not a heavily modded board but I dont want to have to re do all the mods again.
Kim_Possible
Registered User
Posts: 1343
Joined: Sun Sep 21, 2008 3:57 pm

Re: Updating Question to 3.0.3

Post by Kim_Possible »

No, you want to use the autoupdater instead. If you use the "changed files" method and if any of your mods affect the changed files, you will overwrite your mods.
User avatar
Funk Theory
Registered User
Posts: 736
Joined: Mon Sep 25, 2006 3:33 pm
Location: UK
Contact:

Re: Updating Question to 3.0.3

Post by Funk Theory »

Kim_Possible wrote:No, you want to use the autoupdater instead. If you use the "changed files" method and if any of your mods affect the changed files, you will overwrite your mods.

Marvellus, thanks ;)
User avatar
noth
Registered User
Posts: 2487
Joined: Fri Jan 07, 2005 7:10 pm
Location: North Surrey
Contact:

Re: Updating Question to 3.0.3

Post by noth »

3.0.3 uploads a new functions.php that was not compatible with any of my mods, it conflicted

as did acp_board and many others

I have spent all day trying to rebuild my mods since upgrading

it's doable but very time consuming

it's enough to put you off bothering to have mods TBH :evil:
User avatar
Funk Theory
Registered User
Posts: 736
Joined: Mon Sep 25, 2006 3:33 pm
Location: UK
Contact:

Re: Updating Question to 3.0.3

Post by Funk Theory »

did you use the updater as well?
User avatar
noth
Registered User
Posts: 2487
Joined: Fri Jan 07, 2005 7:10 pm
Location: North Surrey
Contact:

Re: Updating Question to 3.0.3

Post by noth »

the updater?

where does that come in please?
User avatar
karlsemple
Former Team Member
Posts: 39802
Joined: Mon Nov 01, 2004 8:54 am
Location: Hereford, UK
Contact:

Re: Updating Question to 3.0.3

Post by karlsemple »

noth wrote:3.0.3 uploads a new functions.php that was not compatible with any of my mods, it conflicted

as did acp_board and many others

I have spent all day trying to rebuild my mods since upgrading

it's doable but very time consuming

it's enough to put you off bothering to have mods TBH :evil:

It does not upload a new functions.php it is likely the auto-updater detected conflicts in your functions.php which you did not handle correctly and thus breaking the mods code in the file. So how did you handle your conflicts during the update process?
Image
Locked

Return to “[3.0.x] Support Forum”