Installing Error

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Get Involved
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Crits
Registered User
Posts: 5
Joined: Tue Dec 09, 2008 11:58 pm

Installing Error

Post by Crits »

Getting a odd error I have never had before 3.03 when installing.

Code: Select all

Warning: Cannot load module 'SQLite' because required module 'pdo' is not loaded in Unknown on line 0
[phpBB Debug] PHP Notice: in file /install/index.php on line 440: Cannot modify header information - headers already sent by (output started at /includes/functions_install.php:24)
[phpBB Debug] PHP Notice: in file /install/index.php on line 441: Cannot modify header information - headers already sent by (output started at /includes/functions_install.php:24)
[phpBB Debug] PHP Notice: in file /install/index.php on line 442: Cannot modify header information - headers already sent by (output started at /includes/functions_install.php:24)
[phpBB Debug] PHP Notice: in file /install/index.php on line 443: Cannot modify header information - headers already sent by (output started at /includes/functions_install.php:24)
I checked the code it looks fine. Anybody have an idea?

Crits
Registered User
Posts: 5
Joined: Tue Dec 09, 2008 11:58 pm

Re: Installing Error

Post by Crits »

Bump

Crits
Registered User
Posts: 5
Joined: Tue Dec 09, 2008 11:58 pm

Re: Installing Error

Post by Crits »

Could I get some help?

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51347
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Installing Error

Post by stevemaury »

Please fill out the Support Request Template.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

User avatar
Ladysarajane
Registered User
Posts: 441
Joined: Sat Feb 18, 2006 10:05 pm

Re: Installing Error

Post by Ladysarajane »

stevemaury - in defense of Crits you cannot get phpBB3.0.3 to install on some servers.
YOu cannot get past the Requirements, therefore there is no database or config.php written so it would be impossible to fill out a support template.

I know Hostmonster says they support PDO, but after adding

Code: Select all

extension = pdo.so
extension=pdo_mysql.so
to the php.ini I cannot get the script to install on a test forum.
If this is new to phpBB 3.0.3 it really should be added to requirements so people can ask their hosts beforehand about PDO.
This seems to be a new requirement that servers have PDO modules active and it will be then a Hosting problem then.
My suggestion to Crits is to ask his hosting company if they support PDO.
When all else fails, read the instructions

User avatar
MasterZ
Registered User
Posts: 712
Joined: Wed Sep 24, 2003 5:33 am
Contact:

Re: Installing Error

Post by MasterZ »

Can you select MySQL without selecting the SQLite option?

julianqm2
Registered User
Posts: 13
Joined: Sun Nov 02, 2008 7:13 am

Re: Installing Error

Post by julianqm2 »

im going through the same issue. i have bluehost and they told me the same thing. if you have blue host just use simple scripts. otherwise good luck!

User avatar
Ladysarajane
Registered User
Posts: 441
Joined: Sat Feb 18, 2006 10:05 pm

Re: Installing Error

Post by Ladysarajane »

MasterZ wrote:Can you select MySQL without selecting the SQLite option?
Never get that far. It pops up the first time you hit "Proceed to next step".

@ julianqm2 - I don't think simple scripts uses the latest version.
When all else fails, read the instructions

julianqm2
Registered User
Posts: 13
Joined: Sun Nov 02, 2008 7:13 am

Re: Installing Error

Post by julianqm2 »

i just installed using it they have 3.0.3.

User avatar
Ladysarajane
Registered User
Posts: 441
Joined: Sat Feb 18, 2006 10:05 pm

Re: Installing Error

Post by Ladysarajane »

Hostmonster did not have PDO on my server. They did install PDO for me and now PhpBB3 installs without problmes. Just fill out a support ticket explaining the problem of installing Phpbb3 without PDO.
When all else fails, read the instructions

User avatar
stickerboy
Former Team Member
Posts: 7349
Joined: Mon Mar 29, 2004 2:27 pm
Location: Airdrie, UK (127.0.0.1)
Name: Kenny Cameron
Contact:

Re: Installing Error

Post by stickerboy »

Ladysarajane wrote:YOu cannot get past the Requirements, therefore there is no database or config.php written so it would be impossible to fill out a support template.
You don't need to have phpBB installed to fill out the details in the template.
I'm a web-designing code-decrypting tech-support musician
|| Twitter || Flickr || phpBB Snippets ||
Formerly known as cherokee red

User avatar
Ladysarajane
Registered User
Posts: 441
Joined: Sat Feb 18, 2006 10:05 pm

Re: Installing Error

Post by Ladysarajane »

9/10 of that template would be N/A:
Your board's URL: not installed yet
Version of phpBB3:attempting 3.0.3
Was this a fresh install or a(n) update/upgrade/conversion (please be specific)? attempting fresh install
If update, what package(s) did you use? Attempting full
Did you use an automated wizard provided by your host to install phpBB? Not yet
MODs you have installed: N/A
When the problem started: First page of installation right after clicking proceed.
Your level of expertise (be honest):5

Additionally, you may wish to provide the following (where applicable)
Template(s) used:N/a...
Language(s) used:N/a
Version of PHP used: 5.2.6
Database and version used: Mysql 5.067

The best thing for people dealing with this is to find out from their hosts if PDO is installed and if they will install it for them. Hostmonster did for me on my server, so I am sure they will on other servers that need it.

I think this needs to be added to Requirement documentations, since it seems that there are hosts out there that do not have this module enabled.
PS: My problem has been resolved...but I just wanted you to show that people trying to install if for the first time might not see the need to use the support template, since they can't even get past the first screen. I was very frustrated at first even though I knew how to get around this problem (install it on a localhost and upload that to my hosting server). So I followed it through to try to find a solution for other people new to phpbb3 that might get frustrated with it.
When all else fails, read the instructions

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51347
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Installing Error

Post by stevemaury »

Excuse me, Ladysarajane, but I asked the OP to fill out the Support Request Template. I will determine what information in it may be applicable to this user's issue, thank you.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

User avatar
Ladysarajane
Registered User
Posts: 441
Joined: Sat Feb 18, 2006 10:05 pm

Re: Installing Error

Post by Ladysarajane »

Didn't mean to offend you stevemaury . That wasn't my intention. There are several threads like this with people posting the exact same error and problem and a lot of them may not see the need to fill out a support template since they cannot get past the first screen.
And I thought I would help with a suggestion for resolution, since I encountered the same exact error.
When all else fails, read the instructions

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51347
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Installing Error

Post by stevemaury »

You did not offend me.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

Locked

Return to “[3.0.x] Support Forum”