not allowed as quickmod problem

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Get Involved
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
User avatar
1234homie
Registered User
Posts: 439
Joined: Fri Sep 26, 2008 3:17 pm

not allowed as quickmod problem

Post by 1234homie »

Hi, when i moderate my forum after redirect I have massage:
not allowed as quickmod
how I can fix it?

User avatar
darcie
Community Team Member
Community Team Member
Posts: 5541
Joined: Thu Jul 27, 2006 9:52 am
Location: Davis, California
Name: Darcie Griffin
Contact:

Re: not allowed as quickmod problem

Post by darcie »

Moved to Support from MOD Requests, as it concerns moderation not modification.

Please provide us with the information necessary to assist you by filling out the Support Request Template.
phpBB on Facebook | Site Rules | Former Community Team leader

getdev
Registered User
Posts: 1
Joined: Tue Mar 10, 2009 3:39 pm

Re: not allowed as quickmod problem

Post by getdev »

Here it is a quick workaround to your problem: open the mcp.php file and, before line 57, add this:

Code: Select all

$_REQUEST['action'] = $_POST['action'];
i don't know why (no time to study the problem) the "action" parameter is not set when you submit the quickmod form, in a topic.

The above should solve your problem. It's not the most elegant solution but it works.

Also, in my case i had to modify the viewtopic.php file because i was getting a "Not Acceptable" HTTP Error. My modification is at line 455:

From

Code: Select all

$viewtopic_url = append_sid("{$phpbb_root_path}viewtopic.$phpEx", "f=$forum_id&t=$topic_id&start=$start" . ((strlen($u_sort_param)) ? "&$u_sort_param" : '') . (($highlight_match) ? "&hilit=$highlight" : ''));
modify to

Code: Select all

$viewtopic_url = append_sid(str_replace("./", "", $phpbb_root_path)."viewtopic.$phpEx", "f=$forum_id&t=$topic_id&start=$start" . ((strlen($u_sort_param)) ? "&$u_sort_param" : '') . (($highlight_match) ? "&hilit=$highlight" : ''));
The issues are on the latest version of phpBB - 3.0.4
The board has no third-party mods installed

Hope it helps.

User avatar
1234homie
Registered User
Posts: 439
Joined: Fri Sep 26, 2008 3:17 pm

Re: not allowed as quickmod problem

Post by 1234homie »

thats not working. Example when I close topic using quickmod options that not redirect me to this topic and i see:

not allowed as quickmod

how repair it?

User avatar
darcie
Community Team Member
Community Team Member
Posts: 5541
Joined: Thu Jul 27, 2006 9:52 am
Location: Davis, California
Name: Darcie Griffin
Contact:

Re: not allowed as quickmod problem

Post by darcie »

darcie wrote:Please provide us with the information necessary to assist you by filling out the Support Request Template.
phpBB on Facebook | Site Rules | Former Community Team leader

User avatar
1234homie
Registered User
Posts: 439
Joined: Fri Sep 26, 2008 3:17 pm

Re: not allowed as quickmod problem

Post by 1234homie »

darcie wrote:
darcie wrote:Please provide us with the information necessary to assist you by filling out the Support Request Template.
its not solves my problem :(

User avatar
darcie
Community Team Member
Community Team Member
Posts: 5541
Joined: Thu Jul 27, 2006 9:52 am
Location: Davis, California
Name: Darcie Griffin
Contact:

Re: not allowed as quickmod problem

Post by darcie »

I am asking for you to go to that topic, follow the directions, and paste the information about your board here in this topic. We need more information about your board if you wish for us to help you.
phpBB on Facebook | Site Rules | Former Community Team leader

User avatar
fazaljatoi
I've Been Banned!
Posts: 503
Joined: Wed Aug 31, 2005 8:02 pm

Re: not allowed as quickmod problem

Post by fazaljatoi »

Image

please help me how i fix

User avatar
1234homie
Registered User
Posts: 439
Joined: Fri Sep 26, 2008 3:17 pm

Re: not allowed as quickmod problem

Post by 1234homie »

I have that same problem fazaljatoi

User avatar
ric323
Former Team Member
Posts: 22910
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: not allowed as quickmod problem

Post by ric323 »

1234homie wrote:I have that same problem fazaljatoi
You have been asked twice to fill out the Support Request Template to tell us about your board.
Why haven't you done that yet?
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

Locked

Return to “[3.0.x] Support Forum”