Page 1 of 1

[Solved] Board do not start after upgrade.

Posted: Mon Feb 16, 2009 4:19 pm
by mag00_br
I have a forum that was in version 3.0.1 and when I try to upgrade it, I do not find an directly upgrade from 3.0.1 to 3.0.4.

So I tried to make it in two chances.

First I should make the upgrade from 3.0.1 to 3.0.2 and then from to 3.0.2 to 3.0.4.

When I started the first procedure, it verified that I should replace 3 files:
- includes/acp/acp_board.php
- includes/constants.php
- includes/functions_jabber.php

After this changes my board does not came up again. :(

I got always this message:

Code: Select all

Fatal error: Not able to open ./cache/data_global.php in /home/barba/public_html/epm/includes/acm/acm_file.php on line 106
What I made wrong? I just have uploaded the 3 files that the upgrade procedure tell me.

Extra information: I don´t use any extra modules or plugins.

[]´s

Re: Board do not start after upgrade.

Posted: Mon Feb 16, 2009 4:31 pm
by mag00_br
Reading a post from a similar problem of other user, I cleaned the cache folder, just maintaining the .htaccess and the index.htm files, and now I have a different message:

Code: Select all

Warning: _tpl_include(./cache/tpl_prosilver_overall_header.html.php) [function.-tpl-include]: failed to open stream: Permission denied in /home/barba/public_html/epm/includes/template.php on line 611

Warning: _tpl_include() [function.include]: Failed opening './cache/tpl_prosilver_overall_header.html.php' for inclusion (include_path='.:/usr/php4/lib/php:/usr/local/php4/lib/php') in /home/barba/public_html/epm/includes/template.php on line 611

Hoje é Seg Fev 16, 2009 2:21 pm

    * Ver mensagens sem resposta • Ver tópicos ativos


Warning: _tpl_include(./cache/tpl_prosilver_forumlist_body.html.php) [function.-tpl-include]: failed to open stream: Permission denied in /home/barba/public_html/epm/includes/template.php on line 611

Warning: _tpl_include() [function.include]: Failed opening './cache/tpl_prosilver_forumlist_body.html.php' for inclusion (include_path='.:/usr/php4/lib/php:/usr/local/php4/lib/php') in /home/barba/public_html/epm/includes/template.php on line 611
Entrar  •  Registrar
Nome de Usuário:  Senha:  | Entrar automaticamente em cada visita
Quem está online

No total, temos 1 usuário online :: 0 registrados, 0 ocultos e 1 visitante (baseado em usuários ativos nos últimos 5 minutos)
O recorde de usuários online foi de 7 em Seg Set 29, 2008 11:50 am

Usuários Registrados: Nenhum usuário registrado online
Legenda: Alunos, Moderadores Globais, Professores, Representantes
Estatísticas

Mensagens no Total: 66 • Tópicos no Total: 45 • Membros no Total: 26 • O mais novo usuário registrado: Davi de Almeida
It can help the error analysis?

[]´s

Re: Board do not start after upgrade.

Posted: Mon Feb 16, 2009 4:59 pm
by stevemaury
Upload a complete set of the version 3.0.4 phpbb files EXCEPT config.php. Then delete every file in the cache folder except .htaccess and index.htm. Then browse to install/database_update.php. Then delete the install folder. Done.

Re: Board do not start after upgrade.

Posted: Tue Feb 17, 2009 12:22 am
by mag00_br
You mean that I need to upload manually all board files from a fresh 3.0.4 board version just maintaining my original config.php and then run the database update procedure?

Why my original plan fail? The upgrade to 3.0.2 does not seems to be so difficult.

[]'s

Re: Board do not start after upgrade.

Posted: Tue Feb 17, 2009 4:30 am
by mag00_br
OK, I did it and now the board is working again.

Thanks.

[]´s