Can not use Postgre databse .. how to convert to mysql?

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Get Involved
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
Txphp
Registered User
Posts: 5
Joined: Sat Feb 28, 2009 8:52 pm

Can not use Postgre databse .. how to convert to mysql?

Post by Txphp » Sat Feb 28, 2009 8:56 pm

Hi There,

I am in need for serious help ... am not a database expert at all...

I used to have my board running under 2.x under a server that was shutdown. I got a database dump and a copy of the forum directory. the BIG problem is that the databse dump is in postgre and my new host (bluehost) only has postgre 5 (they say) but phpBB needs 7.x. If I try to install phpbb it complains the databse is not in UTF8.

I need help to move my forum. Can the database be converted from postgre to mysql? I beleive I can then set it up but am not sure ..

Please help

cheers

Tx

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21676
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: Can not use Postgre databse .. how to convert to mysql?

Post by Mick » Sat Feb 28, 2009 9:48 pm

I have no knowledge on the subject but I Googled "free convert postgre to mysql" and there were a few hits, maybe one of them can help you?
"The more connected we get the more alone we become" - Kyle Broflovski

Txphp
Registered User
Posts: 5
Joined: Sat Feb 28, 2009 8:52 pm

Re: Can not use Postgre databse .. how to convert to mysql?

Post by Txphp » Sat Feb 28, 2009 9:54 pm

tried that but the stuff went right over my head :(

User avatar
D¡cky
Former Team Member
Posts: 11812
Joined: Tue Jan 25, 2005 8:38 pm
Location: New Hampshire, USA
Name: Richard Foote
Contact:

Re: Can not use Postgre databse .. how to convert to mysql?

Post by D¡cky » Sat Feb 28, 2009 10:15 pm

PostgreSQL to MySQL Converter is free. You only need to create a dump (backup) file of the postgresql database and paste it into the text box.

DBConvert will probably do a better job, but you will have to purchase the full version. There is a trial version which will let try before you buy so you can see how it will work for you.
Have you hugged someone today?

Txphp
Registered User
Posts: 5
Joined: Sat Feb 28, 2009 8:52 pm

Re: Can not use Postgre databse .. how to convert to mysql?

Post by Txphp » Sun Mar 01, 2009 4:15 am

I am getting this error message. The provider runs postgre 7.4,1


Warning: pg_connect() [function.pg-connect]: Unable to connect to PostgreSQL server: FATAL: IDENT authentication failed for user "natimico_m" in /home1/natimico/public_html/myboatforum/f1/db/postgres7.php on line 79
phpBB : Critical Error

Could not connect to the database

User avatar
D¡cky
Former Team Member
Posts: 11812
Joined: Tue Jan 25, 2005 8:38 pm
Location: New Hampshire, USA
Name: Richard Foote
Contact:

Re: Can not use Postgre databse .. how to convert to mysql?

Post by D¡cky » Sun Mar 01, 2009 4:59 am

I know nothing about PostgreSQL. Hopefully, someone will come by that does. The only thing I can find is that there may be something wrong with the pg_connect() function of php. Anything further than that, I don't know.
Have you hugged someone today?

User avatar
pentapenguin
Former Team Member
Posts: 11030
Joined: Thu Jul 01, 2004 4:15 am
Location: GA, USA

Re: Can not use Postgre databse .. how to convert to mysql?

Post by pentapenguin » Sun Mar 01, 2009 5:03 am

When are you getting that error message? Before installing? While installing? After? It looks like it's probably the result of an invalid username/password combo. If you just restored your old phpBB files to your new host make sure that you changed the database info in config.php to your new host's info.
Support Resources: Support Request Template
If you need professional assistance with your board, please contact me for my reasonable rates.

Txphp
Registered User
Posts: 5
Joined: Sat Feb 28, 2009 8:52 pm

Re: Can not use Postgre databse .. how to convert to mysql?

Post by Txphp » Sun Mar 01, 2009 5:34 pm

the error comes up when I install the new phpbb.

I think the way to restore the BB is:

- install a new phpbb 2.x ( I think the board ran on 2.0.18) I have a 2.0.16 (is this maybe the issue?)
- use phpmyadmin and import the databsedump from the old database into the new database

however i cant get postgre to work with the new install (will not get past the install with error above) and also I can not import the postgre databse with phpmyadmin.

i think the issue must be withpostgre and I am trying to convert the database dump to mysql. but the link given above does not convert the databse. I hesitate to purchase the converter software because i think the main issue is with postgre itselsf.

need serious help .. my board has been down for 6 weeks :(

Tx

Locked

Return to “[3.0.x] Support Forum”