Spam guide

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Ideas Centre
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
COOLORANGEFREEZE
Registered User
Posts: 72
Joined: Wed Apr 22, 2009 6:06 pm

Spam guide

Post by COOLORANGEFREEZE »

Hi,

I am setting up a PHBB forum.

1.) I set up the two step spam prevention for registration of my forum by following these instructions -

http://www.phpbb.com/kb/article/custom- ... mmer-tool/

The problem is that there is a php code at the bottom in the instructions. Do I need to add that as well? And if so where? Because the first two steps (antispam and counting creation) are not appearing as options for new registrations to my forum in order to keep spammers at bay.

Please advise as to how I can make this work
User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51597
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Spam guide

Post by stevemaury »

You need to do the php file edits to prevent the answer from being given away, but that will not keep the fields from appearing. You need to check the various visibility and load settings for custom profile fields.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)
COOLORANGEFREEZE
Registered User
Posts: 72
Joined: Wed Apr 22, 2009 6:06 pm

Re: Spam guide

Post by COOLORANGEFREEZE »

To check visibility and load settings for this anti-spam function discussed do I go to Custom Profile Fields for that or the overall Group User settings? I've already established my Group/Individual settings for the forum itself. Would these settings be different for the anti-spam tools I am trying to initiate?

Thanks
COOLORANGEFREEZE
Registered User
Posts: 72
Joined: Wed Apr 22, 2009 6:06 pm

Re: Spam guide

Post by COOLORANGEFREEZE »

SteveMaury, can you please respond since you don't accept pm's.

Much appreciated
COOLORANGEFREEZE
Registered User
Posts: 72
Joined: Wed Apr 22, 2009 6:06 pm

Re: Spam guide

Post by COOLORANGEFREEZE »

SteveMaury... please elaborate about where and what to look for in settings per your advice -

You need to do the php file edits to prevent the answer from being given away, but that will not keep the fields from appearing. You need to check the various visibility and load settings for custom profile fields.

Thanks
COOLORANGEFREEZE
Registered User
Posts: 72
Joined: Wed Apr 22, 2009 6:06 pm

Re: Spam guide

Post by COOLORANGEFREEZE »

Bump for SteveMaury or anyone who can answer the captcha question.

Where in load and visual settings do I check to make the captcha question and answer part show up for everyone to see?
some blind fool
Registered User
Posts: 409
Joined: Sat Aug 19, 2006 5:28 pm

Re: Spam guide

Post by some blind fool »

SteveMaury wrote:You need to do the php file edits to prevent the answer from being given away
see this post for which file to edit and what to change, http://www.phpbb.com/community/viewtopi ... 5#p6656595
and this post for how to set the visibility of the profile field, http://www.phpbb.com/community/viewtopi ... 5#p9778455
please do not PM me to ask for help. thanks.
COOLORANGEFREEZE
Registered User
Posts: 72
Joined: Wed Apr 22, 2009 6:06 pm

Re: Spam guide

Post by COOLORANGEFREEZE »

1.) Okay so for the "count" method (using 1,2,3 and 2 is right number) I went into the file and edited to look like this -

'FIELD_TOO_SMALL' => 'The value of “%1$s” is incorrect, a minimum value of %2$d is required.',
'FIELD_TOO_LARGE' => 'The value of “%1$s” is incorrect, a maximum value of %2$d is allowed.',

Is this correct from utilizing the following example -

'FIELD_TOO_SMALL' => 'The value of “%1$s” is incorrect',
'FIELD_TOO_LARGE' => 'The value of “%1$s” is incorrect.',

viewtopic.php?f=64&t=1101105#p6656595

2.) Also I am updated to 3.0.5 but my custom profile fields doesn't look like this - viewtopic.php?f=46&t=1437125&start=375#p9778455 Mine still has the old wording but I changed the options anyways. What is going on with that?

3.) Also with example cited above (to follow) it's not even in a language that I understand after "The value of". Is that weird writing some code that I should know?

Thanks for your help
COOLORANGEFREEZE
Registered User
Posts: 72
Joined: Wed Apr 22, 2009 6:06 pm

Re: Spam guide

Post by COOLORANGEFREEZE »

Any takers?
some blind fool
Registered User
Posts: 409
Joined: Sat Aug 19, 2006 5:28 pm

Re: Spam guide

Post by some blind fool »

3: that is a variable that refers back to what the user entered in the registration forum.

1:
COOLORANGEFREEZE wrote:'FIELD_TOO_SMALL' => 'The value of “%1$s” is incorrect, a minimum value of %2$d is required.',
'FIELD_TOO_LARGE' => 'The value of “%1$s” is incorrect, a maximum value of %2$d is allowed.',
that is not correct. by leaving the text after "incorrect", which also has a variable in it, you give away your answer.

2: how did you update?
please do not PM me to ask for help. thanks.
COOLORANGEFREEZE
Registered User
Posts: 72
Joined: Wed Apr 22, 2009 6:06 pm

Re: Spam guide

Post by COOLORANGEFREEZE »

1.) I had a feeling the "incorrect" wouldn't be correct so I didn't save the changes.

2.) Here is how I updated my board per the following instructions-

You have no MOD's. A custom style is not a MOD, it's just a custom style. ;) You do not use the automatic update method for boards like yours.

With no MOD's the best way to update is to download the full 3.0.5 package, extract and upload everything except config.php, /files & /images to your server overwriting what is there. Run the /install/database_update.php and then delete the install folder as well as everything in the /cache folder except index.htm & .htaccess.

**If you have customized the default style prosilver or subsilver2, do not upload the /styles folder either, manually update those styles with the code changes package. If you have customized the defaults then uploading the /styles folder will overwrite all your style edits.

Always make a backup of your database as well as the folder you have phpbb installed in before upgrading or making any changes.

After updating you download the code changes package which lists the manual steps necessary to update a style to version 3.0.5. In your case as I mentioned much earlier in the topic, your custom style is prosilver based so you just use that file's instructions for manually updating your style.
some blind fool
Registered User
Posts: 409
Joined: Sat Aug 19, 2006 5:28 pm

Re: Spam guide

Post by some blind fool »

1: just use the code change that is in that post, as it's posted.

2: did you upload the styles folder? what style are you currently using? if it's not prosilver or subsilver2, can you switch to one of those styles and check the profile fields page again?
COOLORANGEFREEZE wrote:**If you have customized the default style prosilver or subsilver2, do not upload the /styles folder either, manually update those styles with the code changes package. If you have customized the defaults then uploading the /styles folder will overwrite all your style edits.
please do not PM me to ask for help. thanks.
COOLORANGEFREEZE
Registered User
Posts: 72
Joined: Wed Apr 22, 2009 6:06 pm

Re: Spam guide

Post by COOLORANGEFREEZE »

1.) I did the code change as directed. Do I test for this by having someone register?

2.) I have the prosilver but had the style of reGreen added so I didn't upload the styles folder as I was told not to during the upgrade to 3.0.5

So do I switch back to prosilver under styles manager? It says that my installed styles is prosilver and reGreen but my uninstalled style is subsilver2. Do I "deactivate" the reGreen?
COOLORANGEFREEZE
Registered User
Posts: 72
Joined: Wed Apr 22, 2009 6:06 pm

Re: Spam guide

Post by COOLORANGEFREEZE »

I checked my registration page to register a new user and there aren't any antispam questions or the count method... just the typical captcha.

I guess I'm still supposed to "deactivate" reGreen style to get the proper page to make it all public and then switch back to reGreen to see if it's available as public again?

You know I don't think I should have updated to 3.0.5 It seems like this is a experiment until all bugs are worked out. Yet I got a major website, blog, and forum to go live by July. The site and blog are easy to wargame and work with. I am having nothing but frustration with PHPBB and the "functionality". I want a forum that is simple... not some complicated thing that needs lots of building blocks to get it going and tons of troubleshooting. Can anyone recommend something simpler? It's amazing I've learned a lot here yet something as simple as a antispam question or making an "Announcement" aspect of my forum has got me completely stumped.
some blind fool
Registered User
Posts: 409
Joined: Sat Aug 19, 2006 5:28 pm

Re: Spam guide

Post by some blind fool »

COOLORANGEFREEZE wrote:2.) I have the prosilver but had the style of reGreen added so I didn't upload the styles folder as I was told not to during the upgrade to 3.0.5
okay. it sounds like you are running a 3.0.5 board with 3.0.4 styles. the only reason you should not have uploaded the styles folder was if you customized either of the two basic styles at all -- open file, change something, save file. you should update the two basic styles by uploading the styles folder if you have not made changes. uploading the styles folder would not affect your reGreen style. however, you will also need to update reGreen to 3.0.5 to be able to see and use the style changes. you should try contacting the author through their "release" topic about getting an updated version of the style, or getting help updating it yourself.
if you have made changes to prosilver, there are manual update instructions available.
please do not PM me to ask for help. thanks.
Locked

Return to “[3.0.x] Support Forum”