Custom BBCode Problem

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Anti-Spam Guide
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
Matrinix
Registered User
Posts: 5
Joined: Sun May 31, 2009 4:22 pm

Custom BBCode Problem

Post by Matrinix »

Support Request Template
What version of phpBB are you using? phpBB 3.0.5
What is your board's URL? http://matrinix.mzzt.net/rja/forums/
Who do you host your board with? Dedicated Linux Server
How did you install your board? I used the download package from phpBB.com
Is your board a fresh install or a conversion? Fresh Install
Do you have any MODs installed? No
Please describe your problem.
I added a custom BBCode to my forum to allow embedding YouTube videos:
BBCode usage:

Code: Select all

[YouTube]http://www.youtube.com/watch?v={SIMPLETEXT}[/YouTube]
HTML replacement:

Code: Select all

<object width="560" height="340" type="application/x-shockwave-flash" data="http://www.youtube-nocookie.com/v/{SIMPLETEXT}&hl=en&fs=1&rel=0"><param name="movie" value="http://www.youtube-nocookie.com/v/{SIMPLETEXT}&hl=en&fs=1&rel=0"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param></object>
And then I made a post to test it using:

Code: Select all

[youtube]http://www.youtube.com/watch?v=13xO12Up2UQ[/youtube]
It works fine for the first five minutes, but when I come back an hour later, it's no longer replaces the BBCode with the HTML, it just leaves the BBCode there as if it doesn't know how to handle it. Is there something that I did wrong? How can I fix this?[/i]
What styles do you currently have installed? prosilver
What language(s) is your board currently using? British English
Which database type/version are you using? MySQL 5
What is your level of experience? New to phpBB but not PHP
Generated by SRT Generator ($Rev: 2968 $)
Last edited by Matrinix on Mon Jun 01, 2009 1:09 am, edited 3 times in total.

User avatar
Erik Frèrejean
Former Team Member
Posts: 9899
Joined: Tue Oct 09, 2007 9:09 am
Location: The Netherlands, 3.0.x Support Forum
Name: Erik Frèrejean
Contact:

Re: Custom BBCode Problem

Post by Erik Frèrejean »

Please provide us with the information necessary to assist you by filling out the Support Request Template.
Support Toolkit | Support Request Template | Knowledge Base | phpBB 3.0.x documentation
I don't give support via PM or IM! (all unsolicited pms will be trashed!)

shontrix
Registered User
Posts: 27
Joined: Sun Sep 16, 2007 7:41 am

Re: Custom BBCode Problem

Post by shontrix »

You can try to clear your cache.. it should work fine, since it work once. Does the same problem persist with the default clean Prosilver/Subsilver theme?
Image
Mazecity- BD Anime Community
Visit now to see how superior SEO and Scripts were integrated implemented with perfection :P
Spread Firefox

Matrinix
Registered User
Posts: 5
Joined: Sun May 31, 2009 4:22 pm

Re: Custom BBCode Problem

Post by Matrinix »

I tried purging the cache, same problem. I am using the default prosilver theme as of right now.

narqelion
I've Been Banned!
Posts: 7235
Joined: Sat Dec 13, 2008 5:00 pm
Contact:

Re: Custom BBCode Problem

Post by narqelion »

Can you provide a test account? :)

Matrinix
Registered User
Posts: 5
Joined: Sun May 31, 2009 4:22 pm

Re: Custom BBCode Problem

Post by Matrinix »

It appears to be doing it again. The only way I can get it to work again is by going into the BBCode section of the ACP and re-saving it. By testing account, do you mean a regular account you can post with? If so, you can register and then post a reply to the existing topics.

narqelion
I've Been Banned!
Posts: 7235
Joined: Sat Dec 13, 2008 5:00 pm
Contact:

Re: Custom BBCode Problem

Post by narqelion »

Matrinix wrote:By testing account, do you mean a regular account you can post with? If so, you can register and then post a reply to the existing topics.
Yes I mean a regular account with standard permissions, but no I do not wish to register. If you provide a test account anyone who has time can try and help isolate the problem without multiple people having to register and then request their accounts be deleted. :)

Matrinix
Registered User
Posts: 5
Joined: Sun May 31, 2009 4:22 pm

Re: Custom BBCode Problem

Post by Matrinix »

Test account:

Code: Select all

Username: DevTest
Password: d3vt3stz
Purging the cache appears to be a temporary fix, but it still stops working about an hour later.

Locked

Return to “[3.0.x] Support Forum”