Backup version 3.0.4 to 3.0.5 - compatible???

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
User avatar
Farmer Dusty
Registered User
Posts: 221
Joined: Thu Jun 28, 2007 1:40 am

Backup version 3.0.4 to 3.0.5 - compatible???

Post by Farmer Dusty » Mon Jun 08, 2009 8:38 pm

I've moved to a new ISP and my phpbb backup was done from my board running version 3.0.4. When I install the board new on the new server I intend to install the 3.0.5 version. Will this still be compatible or do I have to install 3.0.4 and then update it?

In the past I killed I my board and lost a fair amount of data so I am a wee bit concerned.

Thanks.

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21586
Joined: Fri Aug 29, 2008 9:49 am
Location: Caerdydd

Re: Backup version 3.0.4 to 3.0.5 - compatible???

Post by Mick » Mon Jun 08, 2009 8:41 pm

For one thing you don't have a problem, you have full backups. I would be inclined to move your board, and import your 3.0.4 board to the new host, make sure it is working as it should and then update.
"The more connected we get the more alone we become" - Kyle Broflovski

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69363
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Backup version 3.0.4 to 3.0.5 - compatible???

Post by KevC » Mon Jun 08, 2009 8:42 pm

It'll be fine.

Just upload the install folder from 3.0.5, go to
yoursite.com/forumfolder/install/database_update.php

Let it run
It will then update the database to 3.0.5
Delete the install folder
Done
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
Manhattan
Registered User
Posts: 211
Joined: Fri Nov 28, 2008 7:55 pm

Re: Backup version 3.0.4 to 3.0.5 - compatible???

Post by Manhattan » Tue Jun 09, 2009 10:44 am

I'm a bit confused!
I have a 3.0.4 database, now I install a fresh 3.0.5 forum and then trying to import my previous database (3.0.4)to my new forum (3.0.5) via phpMyAdmin, so what will the result be? what's the version of database now? :?:
Thanks

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69363
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Backup version 3.0.4 to 3.0.5 - compatible???

Post by KevC » Tue Jun 09, 2009 11:11 am

The files and the database are completely separate.
You will have 3.0.5 files and a 3.0.4 (restored) database.

Just run the database_update.php file as explained and all will be well again.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
Manhattan
Registered User
Posts: 211
Joined: Fri Nov 28, 2008 7:55 pm

Re: Backup version 3.0.4 to 3.0.5 - compatible???

Post by Manhattan » Tue Jun 09, 2009 1:51 pm

Thank you Kevin, would you enlighten me which file or files determine(s) the version of forum that we see in ACP > System > Check for updates, for example if I have 3.0.5 file and 3.0.4 database, what version should be shown there?

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69363
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Backup version 3.0.4 to 3.0.5 - compatible???

Post by KevC » Tue Jun 09, 2009 1:55 pm

That page will show the database version.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
Manhattan
Registered User
Posts: 211
Joined: Fri Nov 28, 2008 7:55 pm

Re: Backup version 3.0.4 to 3.0.5 - compatible???

Post by Manhattan » Tue Jun 09, 2009 2:06 pm

Yup, My problem is just here, Before updating my database (1.Install phpbb 305 2. Import my 3.0.4 database to new forum) the version check page showed my forum is up to date?! why?

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69363
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Backup version 3.0.4 to 3.0.5 - compatible???

Post by KevC » Tue Jun 09, 2009 2:08 pm

Slightly odd way to do the update.
You could have just uploaded the new files and run the database_update.php file.

The version number might have been cached.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
Manhattan
Registered User
Posts: 211
Joined: Fri Nov 28, 2008 7:55 pm

Re: Backup version 3.0.4 to 3.0.5 - compatible???

Post by Manhattan » Tue Jun 09, 2009 2:21 pm

Thank you Kevin :D

User avatar
Farmer Dusty
Registered User
Posts: 221
Joined: Thu Jun 28, 2007 1:40 am

Re: Backup version 3.0.4 to 3.0.5 - compatible???

Post by Farmer Dusty » Tue Jun 09, 2009 3:20 pm

I no longer have access to the old board. I made a back up before moving to a new server.

I misunderstand the suggestions posted. I created a new board with the latest version 3.0.5, however, the back up I made is unavailable from the "maintenance" cpanel.

So, if I have it correct, what one needs to do in this kind of instance is upload the old/original version (phpBB3.0.4) and restore the database - then do the update.

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50812
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Backup version 3.0.4 to 3.0.5 - compatible???

Post by stevemaury » Tue Jun 09, 2009 3:41 pm

How large is the database backup file, uncompressed?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

User avatar
Farmer Dusty
Registered User
Posts: 221
Joined: Thu Jun 28, 2007 1:40 am

Re: Backup version 3.0.4 to 3.0.5 - compatible???

Post by Farmer Dusty » Tue Jun 09, 2009 4:27 pm

stevemaury wrote:How large is the database backup file, uncompressed?
8.8 megabytes

User avatar
Farmer Dusty
Registered User
Posts: 221
Joined: Thu Jun 28, 2007 1:40 am

Re: Backup version 3.0.4 to 3.0.5 - compatible???

Post by Farmer Dusty » Wed Jun 10, 2009 3:42 am

I'm not sure I appreciate this topic being twisted into something that evaded my question so let me try again:

1. Can a saved php/BB 3.0.4 database be uploaded to php/BB 3.0.5?

2. I do not have access to the old board. It has been lost with a change of server.

3. Problem: I am unable to find a stand alone version of 3.0.4. All downloads are for updates. If there is a standalone version available I would appreciate a link as I am beginning to think that is the only way to use the 3.0.4 database save.

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69363
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Backup version 3.0.4 to 3.0.5 - compatible???

Post by KevC » Wed Jun 10, 2009 8:14 am

Farmer Dusty wrote: 1. Can a saved php/BB 3.0.4 database be uploaded to php/BB 3.0.5?
Yes
You just need to run the install/database_update.php file to correct that.
Farmer Dusty wrote: 3. Problem: I am unable to find a stand alone version of 3.0.4. All downloads are for updates. If there is a standalone version available I would appreciate a link as I am beginning to think that is the only way to use the 3.0.4 database save.
Although this doesn't really apply given the above answer, on the downloads page there is a link on the right to previous releases of phpBB3. 3.0.4 is in there.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

Locked

Return to “[3.0.x] Support Forum”