Localhost Cookies

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Get Involved
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
User avatar
Tripp
Former Team Member
Posts: 1358
Joined: Sun May 20, 2007 5:14 am
Location: G'boro, North Carolina
Name: Tripp
Contact:

Localhost Cookies

Post by Tripp »

I have my site online but I wanted to redo it so I backed up the files and database and put it in WAMP and it loads and all. But for some reason, I can't get the cookies to work as I can't stay logged in. I've installed a vanilla phpBB on WAMP before and the cookies worked fine but I can't seem to get it work now. I've changed the settings, I even found a post where Pitbull showed his localhost server and cookie settings and I still can't figure it out:
cookie.JPG
cookie.JPG (30.7 KiB) Viewed 2869 times
server.JPG
server.JPG (32.34 KiB) Viewed 2869 times
I really hope I can figure this out because it's a hassle to keep getting logged out while I'm trying to work on it.
The box said 'You need Windows XP or better' .... so I installed linux.

Formerly Drugs
User avatar
John P
Registered User
Posts: 1237
Joined: Mon Jan 21, 2008 3:55 pm
Location: Netherlands
Name: John
Contact:

Re: Localhost Cookies

Post by John P »

My cookiedomain is empty and servername is the name of the server the site is on when i'm testing in localhost.
Image
Webhosting, Custom MODs, Technical management, MOD installation and Webdesign
User avatar
Tripp
Former Team Member
Posts: 1358
Joined: Sun May 20, 2007 5:14 am
Location: G'boro, North Carolina
Name: Tripp
Contact:

Re: Localhost Cookies

Post by Tripp »

Tried that but it's still not working. I've tried my domain name, no domain name, localhost, change the cookie name, the path, everything, I'm just banging my head against a wall. :(
The box said 'You need Windows XP or better' .... so I installed linux.

Formerly Drugs
User avatar
John P
Registered User
Posts: 1237
Joined: Mon Jan 21, 2008 3:55 pm
Location: Netherlands
Name: John
Contact:

Re: Localhost Cookies

Post by John P »

Did you enter your hostname in the hostfile in windows?
Image
Webhosting, Custom MODs, Technical management, MOD installation and Webdesign
User avatar
ric323
Former Team Member
Posts: 22910
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Localhost Cookies

Post by ric323 »

Try changing "Force server URL settings" to "Yes".
Otherwise phpBB ignores what you set and tries to determine what values to use by itself.
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions
Doowbert
Registered User
Posts: 11
Joined: Sun Jun 29, 2008 4:15 am

Re: Localhost Cookies

Post by Doowbert »

Necrothread!

I'm wondering if this was ever solved as I am having similar issues. The fix provided does not seem to be working.
User avatar
ric323
Former Team Member
Posts: 22910
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Localhost Cookies

Post by ric323 »

Doowbert wrote:Necrothread!

I'm wondering if this was ever solved as I am having similar issues. The fix provided does not seem to be working.
What exactly did you try?
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions
Doowbert
Registered User
Posts: 11
Joined: Sun Jun 29, 2008 4:15 am

Re: Localhost Cookies

Post by Doowbert »

I tried your suggestion of forcing URLs. I also tried using localhost and .localhost as domain names. I can't seem to figure it out. Everything works fine when the SID is in the url.
User avatar
ric323
Former Team Member
Posts: 22910
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Localhost Cookies

Post by ric323 »

Set the domain name to blank, the path to just "/", and "Force server vars" to "Yes".
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions
Doowbert
Registered User
Posts: 11
Joined: Sun Jun 29, 2008 4:15 am

Re: Localhost Cookies

Post by Doowbert »

That also did not work.
User avatar
ric323
Former Team Member
Posts: 22910
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Localhost Cookies

Post by ric323 »

What address are you browsing to to access your board?
Have you tried clicking the "Delete all board cookies" link at the foot of the page?
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions
Doowbert
Registered User
Posts: 11
Joined: Sun Jun 29, 2008 4:15 am

Re: Localhost Cookies

Post by Doowbert »

The URL to access the phpbb3 index page is http://localhost/xanho/interact/
The URL for the site's index page is http://localhost/xanho/
User avatar
_Vinny_
Style Customisations
Style Customisations
Posts: 8677
Joined: Tue Aug 11, 2009 12:45 am
Location: Brazil
Name: Marcus Vinicius
Contact:

Re: Localhost Cookies

Post by _Vinny_ »

Read: Fixing incorrect cookie settings

In cookie settings change Cookie path to /xanho/interact/
Doowbert
Registered User
Posts: 11
Joined: Sun Jun 29, 2008 4:15 am

Re: Localhost Cookies

Post by Doowbert »

Those two posts say different things. The Cookie Fix thread says to leave the cookie path as / while you say to set it to /xanho/interact/.

Regardless, neither one worked.

A bit more information:

This problem started when I copied my website to my local machine (to do testing and such). The websites original domain is xanho.com, and I'm trying to copy it to localhost.
Doowbert
Registered User
Posts: 11
Joined: Sun Jun 29, 2008 4:15 am

Re: Localhost Cookies

Post by Doowbert »

6 hour bump.
Locked

Return to “[3.0.x] Support Forum”