Page 1 of 2

Localhost Cookies

Posted: Fri Aug 07, 2009 7:26 am
by Tripp
I have my site online but I wanted to redo it so I backed up the files and database and put it in WAMP and it loads and all. But for some reason, I can't get the cookies to work as I can't stay logged in. I've installed a vanilla phpBB on WAMP before and the cookies worked fine but I can't seem to get it work now. I've changed the settings, I even found a post where Pitbull showed his localhost server and cookie settings and I still can't figure it out:
cookie.JPG
cookie.JPG (30.7 KiB) Viewed 2698 times
server.JPG
server.JPG (32.34 KiB) Viewed 2698 times
I really hope I can figure this out because it's a hassle to keep getting logged out while I'm trying to work on it.

Re: Localhost Cookies

Posted: Fri Aug 07, 2009 7:51 am
by John P
My cookiedomain is empty and servername is the name of the server the site is on when i'm testing in localhost.

Re: Localhost Cookies

Posted: Fri Aug 07, 2009 8:21 am
by Tripp
Tried that but it's still not working. I've tried my domain name, no domain name, localhost, change the cookie name, the path, everything, I'm just banging my head against a wall. :(

Re: Localhost Cookies

Posted: Sat Aug 08, 2009 6:25 am
by John P
Did you enter your hostname in the hostfile in windows?

Re: Localhost Cookies

Posted: Sat Aug 08, 2009 8:14 am
by ric323
Try changing "Force server URL settings" to "Yes".
Otherwise phpBB ignores what you set and tries to determine what values to use by itself.

Re: Localhost Cookies

Posted: Tue Feb 09, 2010 11:32 pm
by Doowbert
Necrothread!

I'm wondering if this was ever solved as I am having similar issues. The fix provided does not seem to be working.

Re: Localhost Cookies

Posted: Tue Feb 09, 2010 11:35 pm
by ric323
Doowbert wrote:Necrothread!

I'm wondering if this was ever solved as I am having similar issues. The fix provided does not seem to be working.
What exactly did you try?

Re: Localhost Cookies

Posted: Tue Feb 09, 2010 11:57 pm
by Doowbert
I tried your suggestion of forcing URLs. I also tried using localhost and .localhost as domain names. I can't seem to figure it out. Everything works fine when the SID is in the url.

Re: Localhost Cookies

Posted: Wed Feb 10, 2010 12:05 am
by ric323
Set the domain name to blank, the path to just "/", and "Force server vars" to "Yes".

Re: Localhost Cookies

Posted: Wed Feb 10, 2010 12:12 am
by Doowbert
That also did not work.

Re: Localhost Cookies

Posted: Wed Feb 10, 2010 12:13 am
by ric323
What address are you browsing to to access your board?
Have you tried clicking the "Delete all board cookies" link at the foot of the page?

Re: Localhost Cookies

Posted: Wed Feb 10, 2010 12:17 am
by Doowbert
The URL to access the phpbb3 index page is http://localhost/xanho/interact/
The URL for the site's index page is http://localhost/xanho/

Re: Localhost Cookies

Posted: Wed Feb 10, 2010 12:21 am
by _Vinny_
Read: Fixing incorrect cookie settings

In cookie settings change Cookie path to /xanho/interact/

Re: Localhost Cookies

Posted: Wed Feb 10, 2010 12:26 am
by Doowbert
Those two posts say different things. The Cookie Fix thread says to leave the cookie path as / while you say to set it to /xanho/interact/.

Regardless, neither one worked.

A bit more information:

This problem started when I copied my website to my local machine (to do testing and such). The websites original domain is xanho.com, and I'm trying to copy it to localhost.

Re: Localhost Cookies

Posted: Wed Feb 10, 2010 9:48 pm
by Doowbert
6 hour bump.