Account Activation - Admin not sent email

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
moonslice
Registered User
Posts: 24
Joined: Wed Feb 23, 2005 5:56 pm
Contact:

Account Activation - Admin not sent email

Post by moonslice » Fri Sep 11, 2009 9:47 pm

When anyone signs up as a new user, with Account Activation set to 'Admin', only the new user receives a 'welcome' email (saying the account is not active yet).

I as the moderator don't receive any email.

I made sure that under 'email settings' i enabled board-wide emails
I made sure the Contact email address was a legit one.

Why can I get an email as the user but not as the admin?
Jim
moonSlice - web hosting/ecommerce/design

narqelion
I've Been Banned!
Posts: 7235
Joined: Sat Dec 13, 2008 5:00 pm
Contact:

Re: Account Activation - Admin not sent email

Post by narqelion » Sat Sep 12, 2009 12:47 am

moonslice wrote:I as the moderator don't receive any email.
Are you just a moderator or the board administrator? You need the admin permission 'Manage users' in order to receive the email at the admin account you are logged in with. If you do have the appropriate permission are you sure the emails are not getting filtered as spam in your email client? :)

moonslice
Registered User
Posts: 24
Joined: Wed Feb 23, 2005 5:56 pm
Contact:

Re: Account Activation - Admin not sent email

Post by moonslice » Sat Sep 12, 2009 12:51 am

Thanks for answering me!

i get so confused - it seems like there are about 3 or 4 different places where you have to change permissions for the forums & users & groups. where would i go to be sure i'm the board administrator?

PS: Under admin permissions i have 'full permissions' - is this right?

Thanks!
Jim
moonSlice - web hosting/ecommerce/design

narqelion
I've Been Banned!
Posts: 7235
Joined: Sat Dec 13, 2008 5:00 pm
Contact:

Re: Account Activation - Admin not sent email

Post by narqelion » Sat Sep 12, 2009 1:18 am

So you have the ability to manage users, you can activate them, deactivate them, etc? I'm not sure what you mean by 'full permissions', there is Full admin, is that what you meant? If you can activate users and deactivate users then you have the correct permissions. Do you receive other board emails at the email address associated with your account? PM notifications, topic notifications?

moonslice
Registered User
Posts: 24
Joined: Wed Feb 23, 2005 5:56 pm
Contact:

Re: Account Activation - Admin not sent email

Post by moonslice » Sat Sep 12, 2009 1:48 am

Thanks so much for all the time you are taking to help me.

Yes i can admin users. Yes i did mean i have 'Full Admin'

I just sent an email from one admin user to another (which is also me with a different email address). I got both the one as the receiver, and one as the 'copy' sent to the sender.

When an email is sent when someone signs up, what determines where it goes to? Should it go to all admin users? (and therefore should I be receiving 2 of them since i have 2 admin users set up?)

Or does it get sent to the email address under E-mail settings in the Admin CP? Or?
Jim
moonSlice - web hosting/ecommerce/design

narqelion
I've Been Banned!
Posts: 7235
Joined: Sat Dec 13, 2008 5:00 pm
Contact:

Re: Account Activation - Admin not sent email

Post by narqelion » Sat Sep 12, 2009 1:53 am

The notification email of a new registered user requiring activation gets sent to any user with the admin permission of "Manage users", so if you have two admin accounts with this permission you should receive the notification to both accounts' email addresses. The mail gets sent to the user email, the board email defined in the ACP is the email address used to send outgoing emails. :) In your ACP -> E-mail settings what is the package size set to?

moonslice
Registered User
Posts: 24
Joined: Wed Feb 23, 2005 5:56 pm
Contact:

Re: Account Activation - Admin not sent email

Post by moonslice » Sat Sep 12, 2009 2:11 am

package size was set to 50. I changed it to 0 and tried again, but still no luck.

the only spam filter is the hosting server itself does a filter of extreme spam (thru spam assassin). But since i get the email as the new user i doubt that's much different than the one that gets sent to the admin. Plus, like i mentioned, it's only if spam assassin score is higher than 15.
Jim
moonSlice - web hosting/ecommerce/design

narqelion
I've Been Banned!
Posts: 7235
Joined: Sat Dec 13, 2008 5:00 pm
Contact:

Re: Account Activation - Admin not sent email

Post by narqelion » Sat Sep 12, 2009 2:16 am

Any errors in the ACP -> Maintenance -> Error log?

Can you post the URL of your board? I'd like to try registering a test account myself. :)

moonslice
Registered User
Posts: 24
Joined: Wed Feb 23, 2005 5:56 pm
Contact:

Re: Account Activation - Admin not sent email

Post by moonslice » Sat Sep 12, 2009 2:23 am

No errors in maintenance.

Board is at: http://moonslice.com/forum

Thanks!
Jim
moonSlice - web hosting/ecommerce/design

narqelion
I've Been Banned!
Posts: 7235
Joined: Sat Dec 13, 2008 5:00 pm
Contact:

Re: Account Activation - Admin not sent email

Post by narqelion » Sat Sep 12, 2009 2:32 am

Ok I was able to register, just barely though with that CAPTCHA :P and received the email immediately. Did you get anything at all? The board email address used to send was s****@moonslice.com, is that correct? That is not the email address you have setup for your admin user account is it?

moonslice
Registered User
Posts: 24
Joined: Wed Feb 23, 2005 5:56 pm
Contact:

Re: Account Activation - Admin not sent email

Post by moonslice » Sat Sep 12, 2009 2:45 am

No i didn't get any email when you registered.

But... yes, s******@moonslice.com is the email address of one of my admin users. Is that bad?
Jim
moonSlice - web hosting/ecommerce/design

narqelion
I've Been Banned!
Posts: 7235
Joined: Sat Dec 13, 2008 5:00 pm
Contact:

Re: Account Activation - Admin not sent email

Post by narqelion » Sat Sep 12, 2009 2:50 am

Can you tell me the user names of both of your admin accounts and then activate the account I registered? I'd like to try and send you email directly from your board to both accounts and see what happens. If you are getting all other emails except the admin notification then something is wrong with your permissions setup.

moonslice
Registered User
Posts: 24
Joined: Wed Feb 23, 2005 5:56 pm
Contact:

Re: Account Activation - Admin not sent email

Post by moonslice » Sat Sep 12, 2009 2:56 am

i've activated you. the admins are 'admin' and 'jim'.
Jim
moonSlice - web hosting/ecommerce/design

moonslice
Registered User
Posts: 24
Joined: Wed Feb 23, 2005 5:56 pm
Contact:

Re: Account Activation - Admin not sent email

Post by moonslice » Sat Sep 12, 2009 2:58 am

PS: when i look at the advanced settings for my user Jim it shows everything green for every tab.
Jim
moonSlice - web hosting/ecommerce/design

narqelion
I've Been Banned!
Posts: 7235
Joined: Sat Dec 13, 2008 5:00 pm
Contact:

Re: Account Activation - Admin not sent email

Post by narqelion » Sat Sep 12, 2009 3:02 am

Ok I got the activation email and logged in but you do not have your board setup to allow user emails, can you go into the ACP and set E-mail settings -> Users send e-mail via board: to Yes?

Locked

Return to “[3.0.x] Support Forum”