Problem when moved to Nginx webserver

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Get Involved
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
frede
Registered User
Posts: 8
Joined: Thu Feb 09, 2006 3:58 pm

Problem when moved to Nginx webserver

Post by frede »

Support Request Template
What version of phpBB are you using? phpBB 3.0.5
What is your board's URL? http://aiondanmark.dk/forum
Who do you host your board with? Own VPS with Nginx webserver
How did you install your board? I used the download package from phpBB.com
Is your board a fresh install or a conversion? Fresh Install
Do you have any MODs installed? Yes
What MODs do you have installed? I have a mod, that resizes images in posts.
Then I made a custom theme to the board.
When did your problem begin? When moving to our new server with Nginx
Please describe your problem. The problem occurs when users try to register - the server gives a 504 Gateway timeout.
What styles do you currently have installed? Custom-made theme.
What language(s) is your board currently using? Danish
Which database type/version are you using? MySQL 5
What is your level of experience? Experienced with PHP and phpBB
Generated by SRT Generator ($Rev: 3036 $)

I hope that someone are able to help me out of this, as its pretty annoying.

It also has to be said, that the user get created, the user just wont get notified about it, and just get a 504 error.

User avatar
AdamR
Former Team Member
Posts: 9731
Joined: Tue Mar 02, 2004 5:40 pm
Location: Tampa, Florida
Name: Adam Reyher
Contact:

Re: Problem when moved to Nginx webserver

Post by AdamR »

If you can view the server's error logs (usually accessible through your hosting control panel), it likely will give more details about what's causing the error. If so, be sure to post that back here. :)

- Adam
phpBB Support: Welcome | Userguide | Knowledge Base | Search
Honored supporter of the phpBB Group!
"If I have seen a little further it is by standing on the shoulders of Giants." - Isaac Newton

frede
Registered User
Posts: 8
Joined: Thu Feb 09, 2006 3:58 pm

Re: Problem when moved to Nginx webserver

Post by frede »

This is the error generated in the Nginx log:
2009/09/13 10:10:50 [error] 1793#0: *12521 upstream timed out (110: Connection timed out) while reading response header from upstream, client: xxx.xxx.xxx.xxx, server: main.aiondanmark.dk, request: "POST /forum/ucp.php?mode=register HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "www.aiondanmark.dk", referrer: "http://www.aiondanmark.dk/forum/ucp.php?mode=register"

User avatar
AdamR
Former Team Member
Posts: 9731
Joined: Tue Mar 02, 2004 5:40 pm
Location: Tampa, Florida
Name: Adam Reyher
Contact:

Re: Problem when moved to Nginx webserver

Post by AdamR »

To be honest, this error is likely an issue caused by an configuration issue between PHP and nginx. I personally do not have much experience with nginx, so I can't offer any beneficial support in regards to this. You may want to check with the nginx folks about this.

It is unlikely anything on the side of phpBB that's causing the problem.

- Adam
phpBB Support: Welcome | Userguide | Knowledge Base | Search
Honored supporter of the phpBB Group!
"If I have seen a little further it is by standing on the shoulders of Giants." - Isaac Newton

frede
Registered User
Posts: 8
Joined: Thu Feb 09, 2006 3:58 pm

Re: Problem when moved to Nginx webserver

Post by frede »

Yes im sure thats where the problem is - its just funny that its only upon registration (and actually also the last step in the installation) where theres problems.

I hope that someone have a bit more experience with Nginx, as there doesnt seem to be that much activity at their forums.

Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 25798
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: Problem when moved to Nginx webserver

Post by Paul »

Your best try would be asking at the nginx site or something, they are having probarly alot more experience with such errors as we have.
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development

ToonArmy
Former Team Member
Posts: 4608
Joined: Sat Mar 06, 2004 5:29 pm
Location: Worcestershire, UK
Name: Chris Smith
Contact:

Re: Problem when moved to Nginx webserver

Post by ToonArmy »

You need to increase the FCGI timeout parameter. You might have the check DNSRBL option on in the ACP which is causing really long registration times.
Chris SmithGitHub

frede
Registered User
Posts: 8
Joined: Thu Feb 09, 2006 3:58 pm

Re: Problem when moved to Nginx webserver

Post by frede »

ToonArmy wrote:You need to increase the FCGI timeout parameter. You might have the check DNSRBL option on in the ACP which is causing really long registration times.
I added this to my Nginx config:
fastcgi_param READ_TIMEOUT_TIME 120;
But I dont know if the syntax is 100% okay ?

When you say DNSRBL, what do you then exactly mean?

ACP -> General -> Security -> Check e-mail domain

Or where is the checkbox?

ToonArmy
Former Team Member
Posts: 4608
Joined: Sat Mar 06, 2004 5:29 pm
Location: Worcestershire, UK
Name: Chris Smith
Contact:

Re: Problem when moved to Nginx webserver

Post by ToonArmy »

frede wrote:I added this to my Nginx config:
fastcgi_param READ_TIMEOUT_TIME 120;
For a timeout of 2 minutes.

Code: Select all

fastcgi_read_timeout 120;
Chris SmithGitHub

frede
Registered User
Posts: 8
Joined: Thu Feb 09, 2006 3:58 pm

Re: Problem when moved to Nginx webserver

Post by frede »

ToonArmy wrote:
frede wrote:I added this to my Nginx config:
fastcgi_param READ_TIMEOUT_TIME 120;
For a timeout of 2 minutes.

Code: Select all

fastcgi_read_timeout 120;
Thanks .

Set it to 120, and it actually works.

But user registration takes 1 minut and 1 second, which is a bit too much :/

Where was the DNSRBL-checkbox talked about earlier?

Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 25798
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: Problem when moved to Nginx webserver

Post by Paul »

you can disable it in admin -> security settings -> Check IP against DNS Blackhole List:
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development

frede
Registered User
Posts: 8
Joined: Thu Feb 09, 2006 3:58 pm

Re: Problem when moved to Nginx webserver

Post by frede »

Paul wrote:you can disable it in admin -> security settings -> Check IP against DNS Blackhole List:
Thanks .

But didnt work..

User registration still takes 1 minut and 1 second.

frede
Registered User
Posts: 8
Joined: Thu Feb 09, 2006 3:58 pm

Re: Problem when moved to Nginx webserver

Post by frede »

Nobody got any ideas?

Its kinda annoying that user registration is taking so long, when the rest of the site just runs smooth

ToonArmy
Former Team Member
Posts: 4608
Joined: Sat Mar 06, 2004 5:29 pm
Location: Worcestershire, UK
Name: Chris Smith
Contact:

Re: Problem when moved to Nginx webserver

Post by ToonArmy »

Disabled? ACP -> General -> Security -> Check e-mail domain?
Chris SmithGitHub

frede
Registered User
Posts: 8
Joined: Thu Feb 09, 2006 3:58 pm

Re: Problem when moved to Nginx webserver

Post by frede »

Yes. And also the stuff with the DNS Blackhole list.

Locked

Return to “[3.0.x] Support Forum”