Page 1 of 1

Cookie problems on localhost?

Posted: Sun Oct 18, 2009 2:19 pm
by drixie
I like to test any new thing such as edits and mod installations on my local server before I push it to the live server.

But since installtion, I have noticed that anytime I log in on one tab and I access the board from another tab, I am not logged into the board at the new tab.

If I log in on the new tab, it gives me a session id that is entirely different from that of the old tab. I notice that if I remove the session id from the url, I get logged out. Naturally, I thought the session id would be regenerated. Consequently, when I click on links that are append with session id (like mod specific step-by-step installers), I get logged out of the board

I checked the cookie settings and server settings which look quite OK. They are provided below:
Cookie Domain: localhost
Cookie path: /

Server Protocol: http://
Domain Name: localhost
script path: /phpbb3

I need help on this as it is preventing me from test-installing some modifications.

Re: Cookie problems on localhost?

Posted: Sun Oct 18, 2009 2:25 pm
by Mick
Try changing "Force server URL settings" to "Yes"

Re: Cookie problems on localhost?

Posted: Sun Oct 18, 2009 2:31 pm
by Brf
drixie wrote:But since installtion, I have noticed that anytime I log in on one tab and I access the board from another tab, I am not logged into the board at the new tab.

If I log in on the new tab, it gives me a session id that is entirely different from that of the old tab.
When you are using two different tabs, those are two different webbrowser sessions. If you want to be automatically logged in on the second tab, you have to be using "log me in automatically" with persistant sessions enabled.

Re: Cookie problems on localhost?

Posted: Sun Oct 18, 2009 6:33 pm
by drixie
@mixstar

I tried that previously. It still gives me problems.

@brf

What about links without SIDs that makes me get logged out when I click them? Thats the most important aspect.

Thanks in advance.

Re: Cookie problems on localhost?

Posted: Tue Oct 20, 2009 8:26 am
by drixie
...)

I really need help on this one.

Re: Cookie problems on localhost?

Posted: Tue Oct 20, 2009 1:14 pm
by T0ny
Try leaving Cookie Domain blank