[3.0.6] Enable Quick Reply in all forums

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
enkigur
Registered User
Posts: 74
Joined: Sun Mar 25, 2007 9:49 pm

Re: [3.0.6] Enable Quick Reply in all forums

Post by enkigur » Thu Dec 03, 2009 2:57 pm

enkigur wrote:Hello,

how can I disable this again?
Can anyone help me please?

User avatar
Lumpy Burgertushie
Registered User
Posts: 66488
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: [3.0.6] Enable Quick Reply in all forums

Post by Lumpy Burgertushie » Thu Dec 03, 2009 11:46 pm

enkigur wrote:Hello,

how can I disable this again?
undo whatever you did to enable it.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

KlownPosse45
Registered User
Posts: 18
Joined: Wed Nov 25, 2009 3:57 am

Re: [3.0.6] Enable Quick Reply in all forums

Post by KlownPosse45 » Sun Dec 13, 2009 12:59 am

enkigur wrote: Can anyone help me please?

Code: Select all

UPDATE phpbb_forums SET forum_flags = forum_flags &~64 WHERE forum_type = 1
Note the tilde before 64.

User avatar
ravikum
Registered User
Posts: 82
Joined: Tue Dec 02, 2008 5:13 pm
Location: Internet 24X7

Re: [3.0.6] Enable Quick Reply in all forums

Post by ravikum » Mon Aug 29, 2011 4:07 pm

JimA wrote:If you're using MySQL, this SQL query should enable Quick Reply in all forums. :)

Code: Select all

UPDATE phpbb_forums SET forum_flags = forum_flags + 64 WHERE forum_type = 1 AND forum_flags & 64 <> 1
Hi,
thank you for your reply.
Can you please tell me why you are using 64 and not any other number ?

Thank you.

User avatar
Neuropass
Registered User
Posts: 1158
Joined: Fri Apr 17, 2009 2:02 pm
Location: SciTE4AutoIt3

Re: [3.0.6] Enable Quick Reply in all forums

Post by Neuropass » Tue Jun 19, 2012 7:29 pm

cYbercOsmOnauT wrote:The better way to do it (mySQL) is

Code: Select all

UPDATE phpbb_forums SET forum_flags = (forum_flags | 64) WHERE forum_type = 1
Regards,
Tekin

does this work for phpbb 3.010?

Thanks in advance.

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69239
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: [3.0.6] Enable Quick Reply in all forums

Post by KevC » Tue Jun 19, 2012 7:51 pm

3.0.10 has a button in the post settings for 'enable on all forums'.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
Noxwizard
Support Team Leader
Support Team Leader
Posts: 10341
Joined: Mon Jun 27, 2005 8:41 pm
Location: Texas, USA
Name: Patrick Webster
Contact:

Re: [3.0.6] Enable Quick Reply in all forums

Post by Noxwizard » Tue Jun 19, 2012 7:51 pm

You should use the "Submit and enable quick reply in all forums" button under Board Features in the ACP for that.
[Support Template] - [Read Before Posting] - [phpBB Knowledge Base]
Do not contact me for private support, please share the question in our forums.

User avatar
Kampfbiene
Registered User
Posts: 26
Joined: Sun May 05, 2002 5:52 pm
Location: Germany

Re: [3.0.6] Enable Quick Reply in all forums

Post by Kampfbiene » Wed Nov 14, 2012 11:52 pm

The button doesn't work for me somehow. I click it, I get a success notification, but quick reply still is disabled in all the forums.

Most of my forums have a forum_flags value of 32 or 48. One I set manually to enabled quick replies, it now shows 112.

Will the provided SQL query

Code: Select all

UPDATE phpbb_forums SET forum_flags = (forum_flags | 64) WHERE forum_type = 1
still do the trick?

I am on version 3.0.11, standard setup (no mods, no themes). Could it be the corresponding code got lost in one of the preceding automatic updates?

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: [3.0.6] Enable Quick Reply in all forums

Post by Oyabun1 » Thu Nov 15, 2012 1:04 am

Kampfbiene wrote:Could it be the corresponding code got lost in one of the preceding automatic updates?
Could be, but more likely the style you are using is not up to date. Please fill out the Support Request Template and post it back here to enable us to assist you better.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

User avatar
Kampfbiene
Registered User
Posts: 26
Joined: Sun May 05, 2002 5:52 pm
Location: Germany

Re: [3.0.6] Enable Quick Reply in all forums

Post by Kampfbiene » Thu Nov 15, 2012 3:00 am

Sure, no problem:

Support Request Template
What version of phpBB are you using? phpBB 3.0.11
What is your board's URL? private
Who do you host your board with? my own server (Ubuntu 12.04 LTS standard LAMP setup)
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
What version of phpBB3 did you update from? phpBB 3.0.10
What styles do you currently have installed? subsilver2,prosilver
What language(s) is your board currently using? english,german
Which database type/version are you using? MySQL 5
What is your level of experience? Comfortable with PHP and phpBB
When did your problem begin? Tried to enable quick reply just recently, maybe it has been this way since the button was introduced.
Please describe your problem. Enabling quick reply for all forums in the postings settings in ACP has no effect, the database is not altered. Quick reply feature stays deactivated in all forums.
Generated by SRT Generator

I compared a freshly downloaded set of 3.0.11 files to the ones on my server (using BeyondCompare), and they are identical. Only odd thing: sometimes there is a request for the directory adm/styles (instead of style).

Here's what happens when I hit the "enable quick reply in all forums button":

Code: Select all

		 1391 Query	UPDATE phpbb_config
		SET config_value = '1'
		WHERE config_name = 'allow_quick_reply'
		 1391 Query	UPDATE phpbb_forums
		SET forum_flags = forum_flags | 32

User avatar
Kampfbiene
Registered User
Posts: 26
Joined: Sun May 05, 2002 5:52 pm
Location: Germany

Re: [3.0.6] Enable Quick Reply in all forums

Post by Kampfbiene » Thu Nov 15, 2012 10:19 pm

Well, the error in the query itself is obvious , so I just went ahead and executed it with the correct bitset of 64. Worked flawlessly. I just don't see where the script gets the 32. I checked all the constants/functions/variables involved an can't see the error. Then again, I'm not a PHP professional… :lol:

User avatar
HGN
Former Team Member
Posts: 4706
Joined: Wed Dec 03, 2008 1:53 pm
Location: The Netherlands
Name: Alfred
Contact:

Re: [3.0.6] Enable Quick Reply in all forums

Post by HGN » Thu Nov 15, 2012 10:27 pm

Kampfbiene wrote:I just don't see where the script gets the 32. I checked all the constants/functions/variables involved an can't see the error.
In /includes/constants.php check for the line

Code: Select all

define('FORUM_FLAG_QUICK_REPLY', 64);
If you can't find it, search for FORUM_FLAG_QUICK_REPLY.

User avatar
Kampfbiene
Registered User
Posts: 26
Joined: Sun May 05, 2002 5:52 pm
Location: Germany

Re: [3.0.6] Enable Quick Reply in all forums

Post by Kampfbiene » Thu Nov 15, 2012 10:38 pm

Hi, thanks for your reply. It's there and it's definded correctly, set to 64. Also no missing semicolons anywhere :) I checked against the files in the current 3.0.11-release and they were identical.

Master_Cylinder
Registered User
Posts: 761
Joined: Wed Jun 26, 2013 10:14 pm

Re: [3.0.6] Enable Quick Reply in all forums

Post by Master_Cylinder » Tue Dec 10, 2013 11:20 pm

JimA wrote:If you're using MySQL, this SQL query should enable Quick Reply in all forums. :)

Code: Select all

UPDATE phpbb_forums SET forum_flags = forum_flags + 64 WHERE forum_type = 1 AND forum_flags & 64 <> 1
Still works on .12 servers, thanks. ;)

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69239
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: [3.0.6] Enable Quick Reply in all forums

Post by KevC » Wed Dec 11, 2013 9:44 am

Master_Cylinder wrote:
JimA wrote:If you're using MySQL, this SQL query should enable Quick Reply in all forums. :)

Code: Select all

UPDATE phpbb_forums SET forum_flags = forum_flags + 64 WHERE forum_type = 1 AND forum_flags & 64 <> 1
Still works on .12 servers, thanks. ;)
Or just click the 'apply to all forums' button in post settings.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

Locked

Return to “[3.0.x] Support Forum”