Internal Server Error when updating to 3.0.6

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Suggested Hosts
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
go99live
Registered User
Posts: 206
Joined: Mon May 01, 2006 7:18 pm
Contact:

Internal Server Error when updating to 3.0.6

Post by go99live » Sat Nov 21, 2009 5:54 pm

Im trying to update my forum to 3.0.6 form 3.0.5.Im using the automatic installation package..
after the following message

Code: Select all

Updating database to latest stable release

Database type :: mysql4
Previous version :: 3.0.5
Updated version :: 3.0.6


Updating database schema

Progress :: . . . . . . . . . . . . . Done
Result :: No errors


Updating data

Progress :: . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done
Result :: No errors


Updating version and optimising tables

Progress :: . . Done
Result :: No errors

Update completed

The database update was successful. Now you need to continue the update process.
when i click Continue the update process, i get the below error

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, support@supportwebsite.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
can some one please help me??


thanks

narqelion
I've Been Banned!
Posts: 7235
Joined: Sat Dec 13, 2008 5:00 pm
Contact:

Re: Internal Server Error when updating to 3.0.6

Post by narqelion » Sat Nov 21, 2009 6:37 pm

First thing to do is follow the advice of the error message, look in your web server error log.
More information about this error may be available in the server error log.
If you do not know where to locate the log then contact your web hosting support, tell them about the error and they should be able to help you locate it or provide the information you need. Assuming logging is even enabled ...

Secondly, check the file (CHMOD) permissions on your /cache & /store folder, what are they?

Thirdly, in your ACP -> PHP Information settings under the PHP Core section what is the value for memory_limit showing?

go99live
Registered User
Posts: 206
Joined: Mon May 01, 2006 7:18 pm
Contact:

Re: Internal Server Error when updating to 3.0.6

Post by go99live » Sat Nov 21, 2009 7:09 pm

Hi,

i contacted the host, but they said there is a problem with uploaded files and i will have to check it.

cache 777 and store 755

i dont see a memory_limit in my file :cry:

narqelion
I've Been Banned!
Posts: 7235
Joined: Sat Dec 13, 2008 5:00 pm
Contact:

Re: Internal Server Error when updating to 3.0.6

Post by narqelion » Sat Nov 21, 2009 9:21 pm

go99live wrote:i contacted the host, but they said there is a problem with uploaded files and i will have to check it.
Did you tell you where you can find your server error logs or look themselves? Push back on them to provide the specific information.
go99live wrote:cache 777 and store 755
You haven't even gotten to the download part yet but go ahead and change /store to 777
go99live wrote:i dont see a memory_limit in my file
You go to your ACP -> PHP Information and in the PHP Core you do not see the memory_limit field? :? Can you post a screen cap of what you do see? Btw, the variables are listed alphabetically if that helps.

go99live
Registered User
Posts: 206
Joined: Mon May 01, 2006 7:18 pm
Contact:

Re: Internal Server Error when updating to 3.0.6

Post by go99live » Sun Nov 22, 2009 2:21 pm

can someone please help me?? :(

narqelion
I've Been Banned!
Posts: 7235
Joined: Sat Dec 13, 2008 5:00 pm
Contact:

Re: Internal Server Error when updating to 3.0.6

Post by narqelion » Mon Nov 23, 2009 12:59 am

narqelion wrote:
go99live wrote:i contacted the host, but they said there is a problem with uploaded files and i will have to check it.
Did they tell you where you can find your server error logs or look themselves? Push back on them to provide the specific information.
go99live wrote:cache 777 and store 755
You haven't even gotten to the download part yet but go ahead and change /store to 777
go99live wrote:i dont see a memory_limit in my file
You go to your ACP -> PHP Information and in the PHP Core you do not see the memory_limit field? :? Can you post a screen cap of what you do see? Btw, the variables are listed alphabetically if that helps.
Did you do any of the those?

kaadeg
Registered User
Posts: 2
Joined: Sun Sep 30, 2007 6:17 pm

Re: Internal Server Error when updating to 3.0.6

Post by kaadeg » Mon Nov 23, 2009 4:06 am

Hi, I'm getting the same internal server error message. Same symptoms. DB upgrade step goes fine, but when going through the check file process it gets to "72 of 281" and then gives me the following error:

"Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, support@supportwebsite.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log."


The server error logs gives the following:

[Sun Nov 22 20:53:05 2009] [error] [client 173.48.124.29] (104)Connection reset by peer: FastCGI: comm with server "/home/content/d/g/r/dgrunbaum/html-x-httpd-php5" aborted: read failed
[Sun Nov 22 20:53:05 2009] [error] [client 173.48.124.29] FastCGI: incomplete headers (0 bytes) received from server "/home/content/d/g/r/dgrunbaum/html-x-httpd-php5"


cache permissions = 705
store permissions = 705
memory_limit = 64M

Any suggestions?

narqelion
I've Been Banned!
Posts: 7235
Joined: Sat Dec 13, 2008 5:00 pm
Contact:

Re: Internal Server Error when updating to 3.0.6

Post by narqelion » Mon Nov 23, 2009 5:49 am

@kaadeg, looks like your server is running PHP as fcgi so in your case your error log entries do not give the actual error message from the main server error log which is likely one of two things, the memory_limit was exhausted or the cgi process was killed due to a timeout. In a lot of shared/virtual hosting environments the VHOST error log does not get the critical information logged to it, i.e. the fatal PHP error that is the root cause. Past experience tells me it's memory limit. Unfortunately for you, unless you have control of your server configuration or have a hosting company that will bend over backwards for you, I do not think you will be able to use automatic update for 3.0.6 on your server. My first question to you would be, do you have any MOD's installed on your board?

Locked

Return to “[3.0.x] Support Forum”