Update Installation makes trouble

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Suggested Hosts
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
i10179
Registered User
Posts: 31
Joined: Tue Sep 15, 2009 10:18 pm

Update Installation makes trouble

Post by i10179 »

I uploaded the Automatic Update Package and then just klicked on "Now start the update process ...". This is what comes out.

Code: Select all

Warning: include(./../language/de/common.php) [function.include]: failed to open stream: No such file or directory in /is/htdocs/wp1121944_FR9CFXW6W0/www/phpbb3/install/index.php on line 227

Warning: include(./../language/de/common.php) [function.include]: failed to open stream: No such file or directory in /is/htdocs/wp1121944_FR9CFXW6W0/www/phpbb3/install/index.php on line 227

Warning: include() [function.include]: Failed opening './../language/de/common.php' for inclusion (include_path='.:/usr/share/pear/php5') in /is/htdocs/wp1121944_FR9CFXW6W0/www/phpbb3/install/index.php on line 227

Warning: include(./../language/de/acp/common.php) [function.include]: failed to open stream: No such file or directory in /is/htdocs/wp1121944_FR9CFXW6W0/www/phpbb3/install/index.php on line 228

Warning: include(./../language/de/acp/common.php) [function.include]: failed to open stream: No such file or directory in /is/htdocs/wp1121944_FR9CFXW6W0/www/phpbb3/install/index.php on line 228

Warning: include() [function.include]: Failed opening './../language/de/acp/common.php' for inclusion (include_path='.:/usr/share/pear/php5') in /is/htdocs/wp1121944_FR9CFXW6W0/www/phpbb3/install/index.php on line 228

Warning: include(./../language/de/acp/board.php) [function.include]: failed to open stream: No such file or directory in /is/htdocs/wp1121944_FR9CFXW6W0/www/phpbb3/install/index.php on line 229

Warning: include(./../language/de/acp/board.php) [function.include]: failed to open stream: No such file or directory in /is/htdocs/wp1121944_FR9CFXW6W0/www/phpbb3/install/index.php on line 229

Warning: include() [function.include]: Failed opening './../language/de/acp/board.php' for inclusion (include_path='.:/usr/share/pear/php5') in /is/htdocs/wp1121944_FR9CFXW6W0/www/phpbb3/install/index.php on line 229

Warning: include(./../language/de/install.php) [function.include]: failed to open stream: No such file or directory in /is/htdocs/wp1121944_FR9CFXW6W0/www/phpbb3/install/index.php on line 230

Warning: include(./../language/de/install.php) [function.include]: failed to open stream: No such file or directory in /is/htdocs/wp1121944_FR9CFXW6W0/www/phpbb3/install/index.php on line 230

Warning: include() [function.include]: Failed opening './../language/de/install.php' for inclusion (include_path='.:/usr/share/pear/php5') in /is/htdocs/wp1121944_FR9CFXW6W0/www/phpbb3/install/index.php on line 230

Warning: include(./../language/de/posting.php) [function.include]: failed to open stream: No such file or directory in /is/htdocs/wp1121944_FR9CFXW6W0/www/phpbb3/install/index.php on line 231

Warning: include(./../language/de/posting.php) [function.include]: failed to open stream: No such file or directory in /is/htdocs/wp1121944_FR9CFXW6W0/www/phpbb3/install/index.php on line 231

Warning: include() [function.include]: Failed opening './../language/de/posting.php' for inclusion (include_path='.:/usr/share/pear/php5') in /is/htdocs/wp1121944_FR9CFXW6W0/www/phpbb3/install/index.php on line 231
[phpBB Debug] PHP Notice: in file /install/index.php on line 440: Cannot modify header information - headers already sent by (output started at /install/index.php:227)
[phpBB Debug] PHP Notice: in file /install/index.php on line 441: Cannot modify header information - headers already sent by (output started at /install/index.php:227)
[phpBB Debug] PHP Notice: in file /install/index.php on line 442: Cannot modify header information - headers already sent by (output started at /install/index.php:227)
[phpBB Debug] PHP Notice: in file /install/index.php on line 443: Cannot modify header information - headers already sent by (output started at /install/index.php:227)
Any advice on what I have done wrong?
Cheers
User avatar
KevC
Support Team Member
Support Team Member
Posts: 70184
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Update Installation makes trouble

Post by KevC »

It's looking for a German language pack you don't have.

Simple fix.

Open the language folder and copy the /en folder
Rename the copy to /de
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"
i10179
Registered User
Posts: 31
Joined: Tue Sep 15, 2009 10:18 pm

Re: Update Installation makes trouble

Post by i10179 »

Thanks. Helped me a lot. But now this Error message keeps coming when I try to download the modified files:

Code: Select all

{ ADMIN_PANEL }

{ ADMIN_INDEX } • Board index

Skip to content

{ LOGGED_IN_AS }
[ Logout ][ { ADM_LOGOUT } ]     

Information

Unable to open file ./../store/update_3.0.5_to_3.0.6_1260283393_7d48dff22e6fb3a1.tar.gz [gzopen - wb]
User avatar
KevC
Support Team Member
Support Team Member
Posts: 70184
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Update Installation makes trouble

Post by KevC »

Make sure the store folder is writable.
Knowledge Base - phpBB3 Chmod Permissions


Do you have any MODs by the way?
There's a much simpler update if you don't.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"
i10179
Registered User
Posts: 31
Joined: Tue Sep 15, 2009 10:18 pm

Re: Update Installation makes trouble

Post by i10179 »

It worked. It was the store folder. Thanks again Kevin Clark.

Yes I do have MODs. AJAX Chat and the PHPBBGallery. :/
tom_b
Registered User
Posts: 1
Joined: Wed Dec 23, 2009 10:03 am

Re: Update Installation makes trouble

Post by tom_b »

Sorry to "re-open" this topic again, but I have exactly the same issue.

Tried to upgrade from 3.0.5 German to 3.0.6 German using the "automatic updater". Inside the language folder I do have German and English folders (so that should not be an issue).

Furthermore the "store" folder is set to 777, meaning that the access requirements should be met.

I would really appreciate any other idea how to solve this. From the board notification in the admin, I was under the impression that it´s plug & play also for modified boards, but it´s obviously a bit trickier than expected ;)

Thanks a lot in advance!
Tom
Locked

Return to “[3.0.x] Support Forum”