my search blank and advanced search not working

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
codi
Registered User
Posts: 71
Joined: Thu Dec 20, 2007 2:44 pm
Location: Orange Park, Fl
Name: James O'Brian
Contact:

my search blank and advanced search not working

Post by codi »

When I perform a search or advanced search, I get this:


The following words in your search query were ignored because they are too common words: worms.
You must specify at least one word to search for. Each word must consist of at least 3 characters and must not contain more than 14 characters excluding wildcards.

I've replaced that section of the code numerous times with code directly from the downloaded file but nothing seems to make it work


Codi
http://diyaquaponics.com/forum
User avatar
HGN
Former Team Member
Posts: 4706
Joined: Wed Dec 03, 2008 1:53 pm
Location: The Netherlands
Name: Alfred
Contact:

Re: my search blank and advanced search not working

Post by HGN »

In ACP - search Settings (down at Server Configuration) you can increase the number at "Common word threshold" or set to 0 to completely disable the common word threshold.

Note the remark for this parameter: "If you want words that are currently regarded as common to be reconsidered you have to recreate the index." In case you change the parameter value, you will have to go to ACP - Maintenance - Search Index, to recreate the search index.
davejo90
Registered User
Posts: 36
Joined: Sun Jul 31, 2005 8:07 pm
Contact:

Re: my search blank and advanced search not working

Post by davejo90 »

Hi All,

Ok I started with the same problem as above...now I've moved on to this...

Ok I have set the 'Common word threshold' to '0'
I know that I have to rebuild the database, so I go to Maintenance and deleted the search index and start again.

After running the 'Create Index' after 30 seconds I get the error below and the function does not complete, even if I stop it and restart again.

Code: Select all

Fatal error: Maximum execution time of 30 seconds exceeded in /home/rszoneor/public_html/includes/search/fulltext_native.php on line 1582
The error is not identical for every run of the create index, I have so far had 3 different line errors.
Here's another one.

Code: Select all

Fatal error: Maximum execution time of 30 seconds exceeded in /home/rszoneor/public_html/includes/db/mysql.php on line 317
The search index is looking at 78k words and stops at 16k

This was a fresh install 3.0.6 and there are a few mods added but none of then link in any way to the search function.

Mods installed.

Radio
Who Was Here
MChat
Ajax Chat

I need to solve this as my site relies fairly heavily on searching, so any help would be great.

Thanks
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52062
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: my search blank and advanced search not working

Post by Brf »

As the error message says, the rebuild is taking too long, and the script is timing out. Contact your host and ask if you can bump up that timeout quota until you get it rebuilt.
davejo90
Registered User
Posts: 36
Joined: Sun Jul 31, 2005 8:07 pm
Contact:

Re: my search blank and advanced search not working

Post by davejo90 »

Brf wrote:As the error message says, the rebuild is taking too long, and the script is timing out. Contact your host and ask if you can bump up that timeout quota until you get it rebuilt.
Thanks for the reply...this is the reply from the Webhost
Hello Dave,

I'm sorry to hear that you are having problems with your site. Unfortunately we do not help with site customization, but a quick search of google.com brought me up with the following link:

http://stackoverflow.com/questions/1111 ... -sql-query

If this does not help, I would suggest checking more results for google.com or consulting a website designer.

Thank you for your cooperation.
And I don't understand a word of it.

Now I can remember doing this in phpBB2 and didn't have any problems at all with the same Webhost...so is there a php file somewhere that could cause this?

Thanks
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52062
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: my search blank and advanced search not working

Post by Brf »

This is not the timeout of a SQL query.
It is the timeout of the PHP "Maximum execution time", which is set in PHP.ini.
davejo90
Registered User
Posts: 36
Joined: Sun Jul 31, 2005 8:07 pm
Contact:

Re: my search blank and advanced search not working

Post by davejo90 »

Brf wrote:This is not the timeout of a SQL query.
It is the timeout of the PHP "Maximum execution time", which is set in PHP.ini.

Thanks for the reply...I'll work on that
User avatar
HGN
Former Team Member
Posts: 4706
Joined: Wed Dec 03, 2008 1:53 pm
Location: The Netherlands
Name: Alfred
Contact:

Re: my search blank and advanced search not working

Post by HGN »

Usual that setting has to be modified by the webhost.
Locked

Return to “[3.0.x] Support Forum”