Loss of user posts text after migration to new host

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Suggested Hosts
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
colinb
Registered User
Posts: 101
Joined: Sat Jun 29, 2002 10:50 am
Location: UK
Contact:

Loss of user posts text after migration to new host

Post by colinb »

I've been running phpBB for several years with hosting on 1&1 Internet (UK). However, 1&1 drives me nuts so I've moved to Hostgator in the US which has been fantastic. I recently changed the DNS of the domain name to point to a specified home directory in my Hostgator space and then copied over all the phpBB files etc. A new database was created to accomodate the backend.

Although I didn't do a full database backup via the "old" phpBB 3.0.4 install (I changed the DNS settings a bit too early!) I did do a dump of "all" using phpMyAdmin on 1&1 via my admin panel.

BTW I still have access to the database on the old server (MySQL version 5.1.*)

However, having installed everything on the new server - using Bigdump to overcome timeout issues, etc - I found that although everything at first seemed to be OK, I noticed that whilst I could make new posts, all the posts prior to the move were not available. Everything else is there - forums, structure, member list, admin, etc etc - just no posts. Even post topic titles are there!

I've created various dumps from within phpMyAdmin on the old server, but as I'm not adept at using this I'm not sure how to check contents of the user posts.

How can I check for sure that the posts are still there and - just as important - is there an idiot's guide to migrating the database properly using phpMyAdmin from an old install to a new install?

It's weird that everything but posts is there on the new setup.

Thanks - Colin

PS: Hostgator's MySQL is 5.1.3
User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51878
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Loss of user posts text after migration to new host

Post by stevemaury »

Post the last 50 lines of your backup file.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)
colinb
Registered User
Posts: 101
Joined: Sat Jun 29, 2002 10:50 am
Location: UK
Contact:

Re: Loss of user posts text after migration to new host

Post by colinb »

Here goes (50-ish lines):

INSERT INTO `phpbb_words` VALUES (84, 0x2a4f72616c205365782a, 0x77616c6b696e67);
INSERT INTO `phpbb_words` VALUES (85, 0x2a416e616c205365782a, 0x746869732069732061207269702d6f6666);
INSERT INTO `phpbb_words` VALUES (86, 0x2a4d792066697273742053657820546561636865722a, 0x746869732069732061207269702d6f6666);
INSERT INTO `phpbb_words` VALUES (87, 0x2a7375706572313073697465732e696e666f2a, 0x7777772e6262632e636f2e756b2f6362656562696573);
INSERT INTO `phpbb_words` VALUES (88, 0x2a74686532616c6c2e696e666f2f2a, 0x7777772e6262632e636f2e756b2f6362656562696573);
INSERT INTO `phpbb_words` VALUES (89, 0x2a67656e657269632d76616c69756d2a, 0x746869732069732061207269702d6f6666);
INSERT INTO `phpbb_words` VALUES (90, 0x2a67656e657269632d7669636f64696e2a, 0x746869732069732061207269702d6f6666);
INSERT INTO `phpbb_words` VALUES (91, 0x2a687474703a2f2f616c6c6173686c65796a7564642e696e666f2a, 0x687474703a2f2f7777772e6262632e636f2e756b2f6362656562696573);
INSERT INTO `phpbb_words` VALUES (92, 0x2a7068656e7465726d696e6520696e666f726d6174696f6e2a, 0x4920616d2061206d6f726f6e6963207370616d6d6572);
INSERT INTO `phpbb_words` VALUES (93, 0x2a7472616d61646f6c206d656469636174696f6e2a, 0x746869732069732061207269702d6f6666);
INSERT INTO `phpbb_words` VALUES (94, 0x2a6c6170746f7020626174746572792063686561702a, 0x616e6f74686572207363616d206c696e6b);
INSERT INTO `phpbb_words` VALUES (95, 0x2a77686f6c6573616c65206469616d6f6e642a, 0x7468697320697320612077686f6c6573616c652073616c65207269702d6f666621);
INSERT INTO `phpbb_words` VALUES (96, 0x6f6e6c696e6520636173696e6f20706f6b6572, 0x746869732069732061207363616d21);
INSERT INTO `phpbb_words` VALUES (97, 0x2a737175697272656c736f66742a, 0x7269702d6f666620736f667477617265);
INSERT INTO `phpbb_words` VALUES (98, 0x2a5b75726c3d687474703a2f2f6369616c697367656e657269632e626c6f6773686f742e6e6c5d2a, 0x546869732069732061207269706f66662055524c);
INSERT INTO `phpbb_words` VALUES (99, 0x627579207068656e7465726d696e65207461626c657473, 0x616e6f7468657220776562207269706f6666);
INSERT INTO `phpbb_words` VALUES (100, 0x687474703a2f2f7777772e64616e63696e676c7573682e636f6d2f2a, 0x687474703a2f2f7777772e6262632e636f2e756b2f63626565626965732f);
INSERT INTO `phpbb_words` VALUES (101, 0x2a687474703a2f2f7368616b6972616e756465776f726c642e696e666f2f6d6f766965732f35323838322a, 0x687474703a2f2f7777772e6262632e636f2e756b2f6362656562696573);

-- --------------------------------------------------------

--
-- Table structure for table `phpbb_zebra`
--

CREATE TABLE `phpbb_zebra` (
`user_id` mediumint(8) unsigned NOT NULL default '0',
`zebra_id` mediumint(8) unsigned NOT NULL default '0',
`friend` tinyint(1) unsigned NOT NULL default '0',
`foe` tinyint(1) unsigned NOT NULL default '0',
PRIMARY KEY (`user_id`,`zebra_id`)
) TYPE=MyISAM;

--
-- Dumping data for table `phpbb_zebra`
--

INSERT INTO `phpbb_zebra` VALUES (6753, 5530, 1, 0);
INSERT INTO `phpbb_zebra` VALUES (6822, 6691, 1, 0);
INSERT INTO `phpbb_zebra` VALUES (6867, 2007, 1, 0);
INSERT INTO `phpbb_zebra` VALUES (603, 6691, 1, 0);
INSERT INTO `phpbb_zebra` VALUES (7144, 3322, 1, 0);
INSERT INTO `phpbb_zebra` VALUES (7144, 63, 1, 0);
INSERT INTO `phpbb_zebra` VALUES (7417, 6766, 1, 0);
INSERT INTO `phpbb_zebra` VALUES (6766, 7417, 1, 0);
INSERT INTO `phpbb_zebra` VALUES (7894, 3, 1, 0);
INSERT INTO `phpbb_zebra` VALUES (5530, 6766, 1, 0);
INSERT INTO `phpbb_zebra` VALUES (8091, 1129, 1, 0);
INSERT INTO `phpbb_zebra` VALUES (8091, 94, 1, 0);
INSERT INTO `phpbb_zebra` VALUES (7498, 6691, 1, 0);

(end)
User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51878
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Loss of user posts text after migration to new host

Post by stevemaury »

Well, the posts are in the backup file. Have you tried Resynching in the ACP?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)
colinb
Registered User
Posts: 101
Joined: Sat Jun 29, 2002 10:50 am
Location: UK
Contact:

Re: Loss of user posts text after migration to new host

Post by colinb »

Steve - yes, I've resynched everything that can be synched and I've purged the db cache as well. Still no joy. What's interesting is the ACP is telling me that my database size is about half (approx 47MB) what I think it should be - at least the last time it was running on the old server.

I'm going to have a go at uploading and restoring the DB from scratch on the new server and see where it takes me.

Thanks for your help so far. I'll be back, by the looks of it!

Colin
colinb
Registered User
Posts: 101
Joined: Sat Jun 29, 2002 10:50 am
Location: UK
Contact:

Re: Loss of user posts text after migration to new host

Post by colinb »

Steve - update: Resynching does appear to have restored things. The bulk of the posts and topics are now there - although ones where I clicked Resynch within actual forums have emptied out the topics and posts for some silly reason.

Still, I can always go a few steps back and source the original backup so there's hope yet.

Colin
colinb
Registered User
Posts: 101
Joined: Sat Jun 29, 2002 10:50 am
Location: UK
Contact:

Re: Loss of user posts text after migration to new host

Post by colinb »

This is driving me nuts!

I've created a "test" database into which I've uploaded the database from my old server (1&1) as an uncompressed .sql file using bigdump.php, which has done so successfully. I've modded the database config details in my phpBB's config.php file to reflect the use of an alternative db, and then I check how the board displays.

Each time, I get the full structure, all the category headings, threads, post titles, author details, dates etc etc, but when I click a topic to read it all I get is "The requested topic does not exist." which is daft because it clearly does.

I've purged the cache in the ACP and click the three resynch options. No difference.

When I use "Manage Forums" in the ACP and select the "resynch" icon in a forum in the index, I get the popup progress bar which then confirms that sync has been successful. Alternatively, I select an individual sub-category and do the same, and when I do I get the posts text in each case. However, what invariably happens is that I lose a lot of posts, usually from recent months. Why?

Under one category, I lose all the topics and posts after resynching.

The database dump is of the last use of the board before I chose to switch hosts (this was several weeks ago and the board's been offline since), so it's not like it's an older backup file or anything.

I'm stumped on this one. Any advice?

Colin
User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51878
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Loss of user posts text after migration to new host

Post by stevemaury »

You need to start looking in the database to see if the post_id in the topics table is present and properly associated with the topic_id in the posts table.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)
colinb
Registered User
Posts: 101
Joined: Sat Jun 29, 2002 10:50 am
Location: UK
Contact:

Re: Loss of user posts text after migration to new host

Post by colinb »

stevemaury wrote:You need to start looking in the database to see if the post_id in the topics table is present and properly associated with the topic_id in the posts table.
Trouble is I wouldn't know what, specifically, to look for Steve! I'm approaching the limit of my competence in this respect.

Colin
User avatar
Lumpy Burgertushie
Registered User
Posts: 68549
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Loss of user posts text after migration to new host

Post by Lumpy Burgertushie »

how big is the database backup file?

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

I am pleased to announce that I have completed the first item on my bucket list. I have the bucket.
colinb
Registered User
Posts: 101
Joined: Sat Jun 29, 2002 10:50 am
Location: UK
Contact:

Re: Loss of user posts text after migration to new host

Post by colinb »

When I dump from 1&1 as an uncompressed SQL file using phpMyAdmin it's 113MB, but when it installs into my Hostgator database (using bigdump) it's about 44MB (can't figure that one out!).

I've got another problem now in that I can't access the board at all - I get a "General Error
Could not get style data" error message. Gawd knows why.

Time to give up soon, methinks.
User avatar
Lumpy Burgertushie
Registered User
Posts: 68549
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Loss of user posts text after migration to new host

Post by Lumpy Burgertushie »

colinb wrote:When I dump from 1&1 as an uncompressed SQL file using phpMyAdmin it's 113MB, but when it installs into my Hostgator database (using bigdump) it's about 44MB (can't figure that one out!).

I've got another problem now in that I can't access the board at all - I get a "General Error
Could not get style data" error message. Gawd knows why.

Time to give up soon, methinks.
the reason the database is so much smaller is because it is missing all the posts etc.

zip up the 113mb database and upload it to your server somewhere.
then PM me a link to it and I will see what the problem is with it.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

I am pleased to announce that I have completed the first item on my bucket list. I have the bucket.
colinb
Registered User
Posts: 101
Joined: Sat Jun 29, 2002 10:50 am
Location: UK
Contact:

Re: Loss of user posts text after migration to new host

Post by colinb »

Thanks for the offer Robert. See your PMs.

Colin
Locked

Return to “[3.0.x] Support Forum”