Using HTTPS instead of HTTP

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Get Involved
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
cptpicard
Registered User
Posts: 17
Joined: Wed Apr 04, 2007 12:54 pm

Using HTTPS instead of HTTP

Post by cptpicard »

Hi,

I'm pretty new to PHPBB, but, I have a forum which may have quite a bit of sensitive information on. So I think it would be best to setup the forum using the more secure https protocol. My hosting provider "HEART INTERNET" allows SSL.

Could anyone give me some advice as to how I could set this up in the simplist of ways?

Many thanks,

Cpt

User avatar
Lumpy Burgertushie
Registered User
Posts: 67212
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Using HTTPS instead of HTTP

Post by Lumpy Burgertushie »

cptpicard wrote:Hi,

I'm pretty new to PHPBB, but, I have a forum which may have quite a bit of sensitive information on. So I think it would be best to setup the forum using the more secure https protocol. My hosting provider "HEART INTERNET" allows SSL.

Could anyone give me some advice as to how I could set this up in the simplist of ways?

Many thanks,

Cpt
talk to your host , get a SSL certificate. have them install it for you.
change all links to your site to https

set secure to yes in the cookie settings in the admin panel. ( edited this to say cookie instead of email )

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?

User avatar
Ripper®
Registered User
Posts: 830
Joined: Sun Feb 20, 2005 2:54 am

Re: Using HTTPS instead of HTTP

Post by Ripper® »

Should also add an htaccess in the forum folder to redirect all traffic to the https version of the forum, once everything else is done.....

User avatar
d1m0
Registered User
Posts: 127
Joined: Wed Nov 25, 2009 9:20 am

Re: Using HTTPS instead of HTTP

Post by d1m0 »

In order to redirect your website to be opened through HTTPS once you have your SSL installed, you should add the following rewrite rule in your .htaccess file:

Code: Select all

RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule .* https://www.domain.com/%{REQUEST_URI} [R,L]
This will redirect your domain to https://www.yourdomain.com. If you wish the redirect to work without www, you should remove it from the rewrite rule:

Code: Select all

RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule .* https://domain.com/%{REQUEST_URI} [R,L]
Of course, you should replace yourdomain.com with your actual domain.
SiteGround Technical Support Team Member
Check out our special phpBB hosting package

User avatar
Blackwolf_Oz
Registered User
Posts: 264
Joined: Sat Jan 02, 2010 5:15 am
Location: Melbourne Australia
Name: Nick
Contact:

Re: Using HTTPS instead of HTTP

Post by Blackwolf_Oz »

Great information. Have just enabled it myself. Can you please confirm the settings re cookies in the screen shot are correct. ? Please :D
Screenshot-1.png
Screenshot-1.png (32.25 KiB) Viewed 15299 times
We are Anonymous. We are Legion. We do not forgive. We do not forget. Expect us.

Ultimate Edition, Ultimate Edition Oz, Oz Unity

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Using HTTPS instead of HTTP

Post by Oyabun1 »

Bit hard to say unless you tell us the URL of your board.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

User avatar
Blackwolf_Oz
Registered User
Posts: 264
Joined: Sat Jan 02, 2010 5:15 am
Location: Melbourne Australia
Name: Nick
Contact:

Re: Using HTTPS instead of HTTP

Post by Blackwolf_Oz »

Oyabun1 wrote:Bit hard to say unless you tell us the URL of your board.
In the profile on the right Bill....picture of the globe ;)

https://www.ultimateeditionoz.com/
We are Anonymous. We are Legion. We do not forgive. We do not forget. Expect us.

Ultimate Edition, Ultimate Edition Oz, Oz Unity

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Using HTTPS instead of HTTP

Post by Oyabun1 »

The URL of you board is actually, https://www.ultimateeditionoz.com/forum/index.php, which is setting cookies correctly, so it should all be good.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

garden of green
Registered User
Posts: 108
Joined: Mon Sep 16, 2013 2:41 pm
Name: Tony
Contact:

Re: Using HTTPS instead of HTTP

Post by garden of green »

d1m0 wrote:In order to redirect your website to be opened through HTTPS once you have your SSL installed, you should add the following rewrite rule in your .htaccess file:

Code: Select all

RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule .* https://www.domain.com/%{REQUEST_URI} [R,L]
This will redirect your domain to https://www.yourdomain.com. If you wish the redirect to work without www, you should remove it from the rewrite rule:

Code: Select all

RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule .* https://domain.com/%{REQUEST_URI} [R,L]
Of course, you should replace yourdomain.com with your actual domain.
Thank you so much for that

Locked

Return to “[3.0.x] Support Forum”