Successful 3.0.5-3.0.6 update, yet old features still there.

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Anti-Spam Guide
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
User avatar
shaykana
Registered User
Posts: 108
Joined: Mon Sep 04, 2006 12:11 am
Location: Canada
Contact:

Successful 3.0.5-3.0.6 update, yet old features still there.

Post by shaykana » Mon Feb 22, 2010 5:08 am

Support Request Template
What version of phpBB are you using? phpBB 3.0.6
What is your board's URL? http://www.yeoldeinn.com/hqforum/
Who do you host your board with? Startlogic
How did you install your board? I used the download package from phpBB.com
Is your board a fresh install or a conversion? Update from a previous version of phpBB3
Do you have any MODs installed? Yes
Is registration required to reproduce this issue? No
What version of phpBB3 did you update from? phpBB 3.0.5
What MODs do you have installed? Clickable Rows
Colored link when new post
MOD Version Check
Memberlist posts
Milestone Congratulations
Soft Delete
Welcome PM on first Login (WPM)
What styles do you currently have installed? Prosilver, subSilver, custom style based on Prosilver (only colours, fonts and icons changed, no code changes)
What language(s) is your board currently using? English UK
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP but not phpBB
When did your problem begin? After update from phpBB 3.0.5
Please describe your problem. Board updated from 3.0.5 to 3.0.6 using automatic update. Everything appeared successful with no indication of a failed or incomplete update, yet various sections of the control panel have features that should have been removed and do not show new features that should have been added. Example: ACP -> General -> Post Settings -> Posting; shows ENABLE_QUEUE_TRIGGER: Yes No, and QUEUE_TRIGGER_POSTS:, but doesn't have any setting for Quick Reply.
Generated by SRT Generator ($Rev: 3603 $)

I get the impression, that even though everything seems to have updated properly, not everything actually updated properly. I'm curious about what I should do at this point. My board still works just as well as before the update, there just seems to be a few missing features and a few that should have been removed still available.

Will an update to 3.0.7 find these problems and fix them when it's available?
Am I able to reinstall the 3.0.6 update?
Do I need comb through every file to find, delete and add features (is there a code change list other than for Languages and Styles for this)?
Should I install a vanilla 3.0.6 and reinstall any MODS and restore a database backup?

Any and all assistance is appreciated.
Last edited by Pit$Bull on Tue Feb 23, 2010 9:25 pm, edited 1 time in total.
Reason: Topic icon changed

User avatar
ric323
Former Team Member
Posts: 22909
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Successful 3.0.5-3.0.6 update, yet old features still th

Post by ric323 » Mon Feb 22, 2010 5:13 am

How does it look if you switch to standard prosilver?
The auto update doesn't update your other styles.
You need to either download 3.0.6 versions of those styles, and re-do your MOD edits, or update your styles yourself as described at http://www.phpbb.com/community/viewtopi ... 4&t=880735
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

User avatar
shaykana
Registered User
Posts: 108
Joined: Mon Sep 04, 2006 12:11 am
Location: Canada
Contact:

Re: Successful 3.0.5-3.0.6 update, yet old features still th

Post by shaykana » Mon Feb 22, 2010 5:12 pm

It appears the same with Prosilver as well. I think I'm just going to have to overwrite the forum files from a vanilla 3.0.6 and reapply the MOD edits. I had already updated my custom style manually right after updating to 3.0.6.

Thanks for the help.

Pit$Bull
Former Team Member
Posts: 23099
Joined: Sat Dec 02, 2006 4:08 pm
Name: Can't Remember

Re: Successful 3.0.5-3.0.6 update, yet old features still th

Post by Pit$Bull » Mon Feb 22, 2010 5:21 pm

*NOTE: Before proceeding backup all files and the database.*
  • Upload all new files from a download of the full version, except for config.php, the /images and /files folders.
  • Go to yoursite.com/forumfolder/install/database_update.php
  • Let that run and then delete the install folder.
  • You now have a new up to date board containing all your users and posts but without any MODs that you might have had installed.

User avatar
shaykana
Registered User
Posts: 108
Joined: Mon Sep 04, 2006 12:11 am
Location: Canada
Contact:

Re: Successful 3.0.5-3.0.6 update, yet old features still th

Post by shaykana » Tue Feb 23, 2010 4:32 pm

Oh, I'm all about the backups. I back everything up once a week and prior to any updates and/or file changes.

Thanks for the reminder though.

User avatar
shaykana
Registered User
Posts: 108
Joined: Mon Sep 04, 2006 12:11 am
Location: Canada
Contact:

Re: Successful 3.0.5-3.0.6 update, yet old features still th

Post by shaykana » Tue Feb 23, 2010 9:10 pm

All is fixed up and running perfectly. AutoMOD is a dream, especially since you can apply MOD changes on prosilver to styles based on prosilver. The only real time spent was uploading all the 3.0.6 files.

You may now lock this topic. Thanks for all the help.

Locked

Return to “[3.0.x] Support Forum”