3.07 General Error: the update files are incomplete

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
romney
Registered User
Posts: 24
Joined: Sun Nov 16, 2008 1:38 pm

Re: 3.07 General Error: the update files are incomplete

Post by romney »

After update I got the "files are incomplete" message, downloaded a fresh update package and overwrote the install and docs files... ran install again to get the same message, and opened the "/forumfolder/install/database_update.php" page. It took just a second to complete and report success, and the system now reports the board is current a 3.07. Everything "seems" to work.

My question is whether the data base update actually tricks the system into thinking it's OK... If all is good it's a REALLY easy fix!
dylfin
Registered User
Posts: 4
Joined: Tue Sep 01, 2009 12:24 pm

Re: 3.07 General Error: the update files are incomplete

Post by dylfin »

I had this error too. Solution was simple - when I copied patch, my ftp client skipped .txt and .htaccess files.
davidm999
Registered User
Posts: 12
Joined: Sat Aug 14, 2004 3:14 am

Re: 3.07 General Error: the update files are incomplete

Post by davidm999 »

Hi
I've just tried updating from 3.06 to 3.07-PL1 and got the "General Error: the update files are incomplete" after the database update stage had completed.

However when I look in the ACP it reports that the Board version: is 3.0.7-PL1

I have one mod I'm using - 'newpost2mail'

The board seems to be runnng ok but I'm not sure what I should do ?

Regards
David M
User avatar
Lumpy Burgertushie
Registered User
Posts: 68490
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: 3.07 General Error: the update files are incomplete

Post by Lumpy Burgertushie »

davidm999 wrote:Hi
I've just tried updating from 3.06 to 3.07-PL1 and got the "General Error: the update files are incomplete" after the database update stage had completed.

However when I look in the ACP it reports that the Board version: is 3.0.7-PL1

I have one mod I'm using - 'newpost2mail'

The board seems to be runnng ok but I'm not sure what I should do ?

Regards
David M

  • Upload all new files from a download of the full 3.07-PL1 version, except for config.php, the /images and /files folders.
  • You now have a new up to date board containing all your users and posts but without any MODs that you might have had installed.
  • Now redo the file edits for the MOD you had installed and you are done.
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
User avatar
seanlancaster
Registered User
Posts: 87
Joined: Tue May 04, 2004 2:45 pm
Location: michigan

Re: 3.07 General Error: the update files are incomplete

Post by seanlancaster »

Pit$Bull wrote:
Live2Game wrote:Go to yoursite.com/forumfolder/install/database_update.php and run database_update.php and it should say your updated to 3.07
That isn't the issue, the OP is missing some files.
i had the same original error when doing the automatic update from 3.0.6 to 3.0.7x. i also have no MODs.

i did what Pit$Bull recommended and everything worked. if i am missing files, I am not sure how that happened as i don't fiddle with anything. then again, if i am missing files then would Pit's solution have even worked (because it did)?
-sean
BoBKiD
Registered User
Posts: 1
Joined: Wed Nov 14, 2012 1:57 pm

Re: 3.07 General Error: the update files are incomplete

Post by BoBKiD »

Hello everyone,

I had the same problem and couldn't find a simple solution until I read dylfin's reply:
dylfin wrote:I had this error too. Solution was simple - when I copied patch, my ftp client skipped .txt and .htaccess files.
I checked the files, and although they WHERE there, something in the uploading process got them wrong. So what I did, was change the file uploading method of my ftp client from "BINARY" to "AUTOMATIC". I reuploaded the automatic update package and viola, it worked!! No error!

I hope this will help.
Locked

Return to “[3.0.x] Support Forum”