Limited SSL Usage in phpBB3

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
yaashul
Registered User
Posts: 331
Joined: Mon Apr 17, 2006 3:21 pm
Location: India

Re: Limited SSL Usage in phpBB3

Post by yaashul »

Code: Select all

	$web_path = (defined('PHPBB_USE_BOARD_URL_PATH') && PHPBB_USE_BOARD_URL_PATH) ? $board_url : $phpbb_root_path;
	'T_THEME_PATH'			=> "{$web_path}styles/" . $user->theme['theme_path'] . '/theme',
	'T_TEMPLATE_PATH'		=> "{$web_path}styles/" . $user->theme['template_path'] . '/template',
	'T_STYLESHEET_LINK'		=> (!$user->theme['theme_storedb']) ? "{$web_path}styles/" . $user->theme['theme_path'] . '/theme/stylesheet.css' : append_sid("{$phpbb_root_path}style.$phpEx", 'id=' . $user->theme['style_id'] . '&lang=' . $user->data['user_lang']),

These are the thing at functions.php at this domain and in case I have set PHPBB_USE_BOARD_URL_PATH explicityly somewhere then it shud not convert https for T_STYLESHEET_LINK I think....

User avatar
Noxwizard
Support Team Leader
Support Team Leader
Posts: 10361
Joined: Mon Jun 27, 2005 8:41 pm
Location: Texas, USA
Name: Patrick Webster
Contact:

Re: Limited SSL Usage in phpBB3

Post by Noxwizard »

It could be that the SEO MOD you have installed is rewriting them.
[Support Template] - [Read Before Posting] - [phpBB Knowledge Base]
Do not contact me for private support, please share the question in our forums.

yaashul
Registered User
Posts: 331
Joined: Mon Apr 17, 2006 3:21 pm
Location: India

Re: Limited SSL Usage in phpBB3

Post by yaashul »

Ok I get it... I was forcing Server URL setting in ACP hence that error...


What shud I do with this error?

SEC7115: :visited and :link styles can only differ by color. Some styles were not applied to :visited.
ucp.php?mode=register

yaashul
Registered User
Posts: 331
Joined: Mon Apr 17, 2006 3:21 pm
Location: India

Re: Limited SSL Usage in phpBB3

Post by yaashul »

1 more thing...I'm not able to login from index page everytime I fill my login info there it always open ucp.php?mode=login page again and if i fill llogin info there it logged me in...

User avatar
Noxwizard
Support Team Leader
Support Team Leader
Posts: 10361
Joined: Mon Jun 27, 2005 8:41 pm
Location: Texas, USA
Name: Patrick Webster
Contact:

Re: Limited SSL Usage in phpBB3

Post by Noxwizard »

The CSS error shouldn't cause a problem. Your login form doesn't work because it's pointing to: https://www.fropki.com/http://www.fropk ... mode=login. Your login and register links are the same way.
[Support Template] - [Read Before Posting] - [phpBB Knowledge Base]
Do not contact me for private support, please share the question in our forums.

yaashul
Registered User
Posts: 331
Joined: Mon Apr 17, 2006 3:21 pm
Location: India

Re: Limited SSL Usage in phpBB3

Post by yaashul »

I'm using this as specified in phpbb....

<form method="post" action="{S_LOGIN_ACTION}" class="headerspace">

Should I change anything in function.php for this line?

Code: Select all

'S_LOGIN_ACTION'      => ((!defined('ADMIN_START')) ? append_sid("{$phpbb_root_path}ucp.$phpEx", 'mode=login') : append_sid("index.$phpEx", false, true, $user->session_id)),

User avatar
Noxwizard
Support Team Leader
Support Team Leader
Posts: 10361
Joined: Mon Jun 27, 2005 8:41 pm
Location: Texas, USA
Name: Patrick Webster
Contact:

Re: Limited SSL Usage in phpBB3

Post by Noxwizard »

The SEO MODs typically use hooks, so you don't really see what is being rewritten until it's sent to the screen.
[Support Template] - [Read Before Posting] - [phpBB Knowledge Base]
Do not contact me for private support, please share the question in our forums.

yaashul
Registered User
Posts: 331
Joined: Mon Apr 17, 2006 3:21 pm
Location: India

Re: Limited SSL Usage in phpBB3

Post by yaashul »

If I replace this

Code: Select all

'S_LOGIN_ACTION'      => ((!defined('ADMIN_START')) ? append_sid("{$phpbb_root_path}ucp.$phpEx", 'mode=login') : append_sid("index.$phpEx", false, true, $user->session_id)),
with this

Code: Select all

'S_LOGIN_ACTION'      => ((!defined('ADMIN_START')) ? append_sid("ucp.$phpEx", 'mode=login') : append_sid("index.$phpEx", false, true, $user->session_id)),
it works fine....but is it safe?

User avatar
Noxwizard
Support Team Leader
Support Team Leader
Posts: 10361
Joined: Mon Jun 27, 2005 8:41 pm
Location: Texas, USA
Name: Patrick Webster
Contact:

Re: Limited SSL Usage in phpBB3

Post by Noxwizard »

You should really take these issues up with the author of the SEO MOD that you're using.
[Support Template] - [Read Before Posting] - [phpBB Knowledge Base]
Do not contact me for private support, please share the question in our forums.

yaashul
Registered User
Posts: 331
Joined: Mon Apr 17, 2006 3:21 pm
Location: India

Re: Limited SSL Usage in phpBB3

Post by yaashul »

whats the solution for this error?

SCRIPT5009: 'apply_onkeypress_event' is undefined
ucp.php?mode=register, line 77 character 4

User avatar
Noxwizard
Support Team Leader
Support Team Leader
Posts: 10361
Joined: Mon Jun 27, 2005 8:41 pm
Location: Texas, USA
Name: Patrick Webster
Contact:

Re: Limited SSL Usage in phpBB3

Post by Noxwizard »

That's a JavaScript error, it doesn't have anything to do with this topic. You can see this list of errors yourself if you press F12 in IE to open the Developers Tools, then click the Scripts tab.
[Support Template] - [Read Before Posting] - [phpBB Knowledge Base]
Do not contact me for private support, please share the question in our forums.

User avatar
GoBieN
Registered User
Posts: 544
Joined: Fri Mar 05, 2004 5:22 pm
Location: Belgium
Contact:

Re: Limited SSL Usage in phpBB3

Post by GoBieN »

Does this hook still work with phpBB 3.1?

Locked

Return to “[3.0.x] Support Forum”