New registrations redirected back to T&C's page

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Suggested Hosts
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
User avatar
Socialoutcast
Registered User
Posts: 61
Joined: Fri Oct 20, 2006 2:43 am
Location: Scotland

New registrations redirected back to T&C's page

Post by Socialoutcast » Wed Mar 24, 2010 11:00 pm

I've just been made aware of the fact that people can't register on my forum any more. Every time someone enters their details and hits the submit button it redirects them to the T&C's page again. Also when you click on the link to register this appears at the top of the page

Code: Select all

[phpBB Debug] PHP Notice: in file /includes/ucp/ucp_register.php on line 97: array_merge() [function.array-merge]: Argument #2 is not an array
[phpBB Debug] PHP Notice: in file /includes/ucp/ucp_register.php on line 99: Invalid argument supplied for foreach()
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3104: Invalid argument supplied for foreach()
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4287: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4289: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4290: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4291: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
I have the latest version of phpBB. Any help would be appreciated :)

User avatar
D¡cky
Former Team Member
Posts: 11812
Joined: Tue Jan 25, 2005 8:38 pm
Location: New Hampshire, USA
Name: Richard Foote
Contact:

Re: New registrations redirected back to T&C's page

Post by D¡cky » Thu Mar 25, 2010 4:24 am

Do you have any MODs on the board? array_merge is actually on line 99 and there is no foreach at all in ucp/ucp_register.php.

To further assist you, would you please fill out the Support Request Template.
Have you hugged someone today?

User avatar
Socialoutcast
Registered User
Posts: 61
Joined: Fri Oct 20, 2006 2:43 am
Location: Scotland

Re: New registrations redirected back to T&C's page

Post by Socialoutcast » Thu Mar 25, 2010 10:10 am

I have the anti-spam ACP mod installed for some time now and it's also up to date. I deactivated it but the problem still happens. I've also tried using all three of the styles installed and it happens too. Here's the support template you asked for

Support Request Template
What version of phpBB are you using? phpBB 3.0.7-PL1
What is your board's URL? http://n/a
Who do you host your board with? servage
How did you install your board? I used the download package from phpBB.com
Is your board a fresh install or a conversion? Fresh Install
Do you have any MODs installed? Yes
Is registration required to reproduce this issue? No
What MODs do you have installed? anti-spam ACP
What styles do you currently have installed? prosilver, subsilver2, Blackbox_blue
What language(s) is your board currently using? English
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP but not phpBB
When did your problem begin? First brought to my attention on 23/03/10 but the problem could have been going on for longer.
Please describe your problem. when registering potential members are redirected to the terms and conditions page after filling out their details and clicking on the submit button at the bottom of the page. Also when you click on the registration link this appears at the top of the page

[phpBB Debug] PHP Notice: in file /includes/ucp/ucp_register.php on line 97: array_merge() [function.array-merge]: Argument #2 is not an array
[phpBB Debug] PHP Notice: in file /includes/ucp/ucp_register.php on line 99: Invalid argument supplied for foreach()
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3104: Invalid argument supplied for foreach()
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4287: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4289: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4290: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4291: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
Generated by SRT Generator ($Rev: 3777 $)

User avatar
ric323
Former Team Member
Posts: 22909
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: New registrations redirected back to T&C's page

Post by ric323 » Thu Mar 25, 2010 10:18 am

If that is the only MOD you have, you could easily try running a clean set of phpBB files, and see if the problem persists.
You can try uploading all the files (except the "install" folder) from the "full install" package into a different directory on your web server, and just copy the config.php file from your running board.
Browse to the new folder. If the problem goes away, it is the anti spam MOD causing the problem.
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

User avatar
Socialoutcast
Registered User
Posts: 61
Joined: Fri Oct 20, 2006 2:43 am
Location: Scotland

Re: New registrations redirected back to T&C's page

Post by Socialoutcast » Sun Mar 28, 2010 8:25 pm

I did as you suggested ric323 and was able to register just fine Also the writing was gone so I guess I'll be removing the anti-spam ACP mod. This presents another problem as before I installed it I was getting 10+ spam bots registering each day with sometimes up to a hundred spam posts and I really don't want to go back to cleaning up that mess again on a daily basis. I guess I'll do a search and look for any other kind of anti spam modifications I could try.

Thank you for your help Dicky and ric 323 :D

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69424
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: New registrations redirected back to T&C's page

Post by KevC » Sun Mar 28, 2010 8:34 pm

You don't need any. There are plenty of good new options built in since 3.0.6.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
Socialoutcast
Registered User
Posts: 61
Joined: Fri Oct 20, 2006 2:43 am
Location: Scotland

Re: New registrations redirected back to T&C's page

Post by Socialoutcast » Sun Mar 28, 2010 8:50 pm

I'm an idiot :oops: I was looking over the includes folder and found a .php file called authorized_url which led me to a mod with the same name. It doesn't show up on my admin panel at all. It included a php file to update the database so I'm not sure how to remove it? Do I just undo the modifications I made to the various files? Will the database need modifying again?

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69424
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: New registrations redirected back to T&C's page

Post by KevC » Sun Mar 28, 2010 8:56 pm

Just do this and you'll have a totally unmodded board that's up to date

*NOTE: Before proceeding backup all files and the database.*
  • Upload all new files from a download of the full version, except for config.php, the /images and /files folders.
  • Go to yoursite.com/forumfolder/install/database_update.php
  • Let that run and then delete the install folder.
  • You now have a new up to date board containing all your users and posts but without any MODs that you might have had installed.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
Socialoutcast
Registered User
Posts: 61
Joined: Fri Oct 20, 2006 2:43 am
Location: Scotland

Re: New registrations redirected back to T&C's page

Post by Socialoutcast » Wed Mar 31, 2010 2:32 pm

Thank you Kevin Clark. That's worked :)

Locked

Return to “[3.0.x] Support Forum”