Problem when updating from 3.0.6 to 3.0.7PL1 (diff.php)

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Ideas Centre
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
Proximer
Registered User
Posts: 18
Joined: Mon Feb 22, 2010 7:25 am

Problem when updating from 3.0.6 to 3.0.7PL1 (diff.php)

Post by Proximer »

Support Request Template
What version of phpBB are you using? phpBB 3.0.6
What is your board's URL? http://forum.civicclub.lt
Who do you host your board with? http://www.serveriai.lt
How did you install your board? I used the download package from phpBB.com
Is your board a fresh install or a conversion? Conversion from phpBB2
Do you have any MODs installed? No
Is registration required to reproduce this issue? No
What styles do you currently have installed? Bl@ck
What language(s) is your board currently using? British English; Lithuanian
Which database type/version are you using? I Don't Know
What is your level of experience? New to PHP and phpBB
When did your problem begin? I have found the problem after trying to update from 3.0.6 to 3.0.7PL1
Please describe your problem. When i upload intall folder to my root directory and point my browser to it everything goes fine. I see the licence agreement etc. and there is a tab (link) "update". When i press it, i get a blank screen with this error:
Parse error: syntax error, unexpected T_CLASS, expecting T_FUNCTION in /home/admin/domains/civicclub.lt/public_html/forum/includes/diff/diff.php on line 750

The problem is that i can not even begin the update.
Generated by SRT Generator ($Rev: 3777 $)


Any help is apreciated.
Thanks in advance!

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69711
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Problem when updating from 3.0.6 to 3.0.7PL1 (diff.php)

Post by KevC »

Proximer wrote:Do you have any MODs installed? No
You don't need to use the auto updater if you have no MODs.
Just do this (and get an up to date version of your style)
*NOTE: Before proceeding backup all files and the database.*
  • Upload all new files from a download of the full version, except for config.php, the /images and /files folders.
  • Go to yoursite.com/forumfolder/install/database_update.php
  • Let that run and then delete the install folder.
  • You now have a new up to date board containing all your users and posts but without any MODs that you might have had installed.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

Proximer
Registered User
Posts: 18
Joined: Mon Feb 22, 2010 7:25 am

Re: Problem when updating from 3.0.6 to 3.0.7PL1 (diff.php)

Post by Proximer »

Thanks Kevin! That worked! :)

Locked

Return to “[3.0.x] Support Forum”