Page 1 of 1

Lost my admin account

Posted: Wed Apr 28, 2010 11:23 pm
by apfan
Hello i recently installed phpbb olympus.
I registered an admin account but now i have lost my password :(
Is there any way to set admin permission withous logging in?

Please help

Re: Lost my admin account

Posted: Wed Apr 28, 2010 11:35 pm
by GreenAge
create a new account with a know password, and in phpMyAdmin(host/cpanel), copy him password to your Admin account.
And try to login again.

Re: Lost my admin account

Posted: Wed Apr 28, 2010 11:38 pm
by apfan
Thanks solved it now :)

Re: Lost my admin account

Posted: Thu Apr 29, 2010 12:42 am
by ric323
You could have just used the "lost password" facility to get a new one, the same as any other user.

Re: Lost my admin account

Posted: Wed May 19, 2010 3:47 pm
by amoun
Don't see a [lost password] option. Where could it be?

Re: Lost my admin account

Posted: Wed May 19, 2010 4:18 pm
by stevemaury
pw.png
pw.png (18.01 KiB) Viewed 1530 times

Re: Lost my admin account

Posted: Wed May 19, 2010 7:33 pm
by amoun
Thanks Steve

Makes sense to me, and on one of my boards it is just so. I hadn't noticed/remembered as it was never a problem.

However on another board, more recently installed on another site, same host,

1st EDIT I have this when I click on the login link. Maybe it's going to a different file to login?

2nd EDIT Nope!

The ok one ishttp://soapbox.rogerlovejoy.net/ucp.php?mode=login and
the other http://plymouthenvironmentcentre.org.uk ... mode=login

I wouldn't have thought a style change would do that??

3rd EDIT OK I can get to the [Send Password] option by suffixing the URL with 'sendpassword' instead of login but sadly to no avail as it's not recognising my user name and email combination.

Check the database via phpmyadmin and it seems a bit weird there,(not showing user names, just the variable type?) but that doesn't explain the different login screens.


Image

Re: Lost my admin account

Posted: Wed May 19, 2010 10:30 pm
by ric323
amoun wrote:...I wouldn't have thought a style change would do that??

3rd EDIT OK I can get to the [Send Password] option by suffixing the URL with 'sendpassword' instead of login but sadly to no avail as it's not recognising my user name and email combination.
...
The "style" has total control over what you see on the screen, so of course it can remove elements like the "Forgot password" link.
If that facility isn't working, you can use the Support Toolkit to promote any username to admin, or create a new admin account.

Re: Lost my admin account

Posted: Thu May 20, 2010 11:33 am
by amoun
HI. Ric

Will try the toolkit. Once I'm back in, I'll try setting the style to the default pro-silver, or whatever it's called and update here.

All the best