Page 1 of 2

Icon missing, � there insetad

Posted: Wed May 19, 2010 9:05 am
by sdmxc
Hey Guys,

I just installed a new forum on my site the other day and after making some changes (adding Ajax chat and removing some things like the search box and default header) I am seeing a problem with one of the icons on my page. Beside the Login and Username fields I am seeing a �, I think it should be a • or something.

Can anyone please advise.

Page is here http://www.glennlawrence.ie/forum/

Thanks,

Glenn.

Re: Icon missing, � there insetad

Posted: Wed May 19, 2010 9:09 am
by KevC
What application are you using to upload the files with?

Re: Icon missing, � there insetad

Posted: Wed May 19, 2010 9:11 am
by sdmxc
filezilla

Re: Icon missing, � there insetad

Posted: Wed May 19, 2010 9:13 am
by KevC
Mmm that's usually fine.
Try uploading the language folder again.

Re: Icon missing, � there insetad

Posted: Wed May 19, 2010 9:51 am
by sdmxc
no luck I'm afraid.

Re: Icon missing, � there insetad

Posted: Wed May 19, 2010 10:45 am
by KevC
Have you edited any of the language files before you've uploaded them or are they fresh from the phpBB download?

Re: Icon missing, � there insetad

Posted: Wed May 19, 2010 11:16 am
by Sierron
Your site output UTF-8, but Ansi Encoding. My forum put out UTF-8 with UTF-8 without BOM encoding.

Re: Icon missing, � there insetad

Posted: Wed May 19, 2010 11:33 am
by sdmxc
Kevin - I changed "language/en/common.php" as per install instructions from Handyman. See below changes.

Sierron - should I change site output to UTF-8 with UTF-8 without BOM encoding? And if so where do I change this?

Thanks,


Open: language/en/common.php
Find

Tip: This may be a partial find and not the whole line.
Code:Select all

'CHANGING_PROFILE' => 'Changing profile settings',

Add after

Tip: Add these lines on a new blank line after the preceding line(s) to find.
Code:Select all

//-- mod : AJAX Chat ----------------------------------------------------
//-- add
'CHAT' => 'Chat',
'CHAT_EXPLAIN' => 'Chat Center',
//-- fin mod : AJAX Chat ------------------------------------------------

<< Hide
Find

Tip: This may be a partial find and not the whole line.
Code:Select all

'VIEWED' => 'Viewed',

Add after

Tip: Add these lines on a new blank line after the preceding line(s) to find.
Code:Select all

//-- mod : AJAX Chat ----------------------------------------------------
//-- add
'VIEWING_CHAT' => 'Viewing Shoutbox',
//-- fin mod : AJAX Chat ------------------------------------------------

Re: Icon missing, � there insetad

Posted: Wed May 19, 2010 11:40 am
by Sierron
Which editor do you use? Check if your file has ANSI Encoding or UTF without BOM. If it is ANSI, then you need to convert to UTF without BOM.

edit:

If you used notepad from windows or something i can happen, that it change the encoding.

Re: Icon missing, � there insetad

Posted: Wed May 19, 2010 11:49 am
by Pit$Bull
When editing files you should use a good text editor like http://notepad-plus.sourceforge.net/uk/site.htm
Files should be saved using UTF-8 without BOM.

Re: Icon missing, � there insetad

Posted: Wed May 19, 2010 12:11 pm
by sdmxc
I have just been editing the files from my helm control panel, directly on the web. Am I going to have to start from the start again to get this icon issue sorted?

Re: Icon missing, � there insetad

Posted: Wed May 19, 2010 12:13 pm
by KevC
Yep that will be the problem. It's not a proper text editor.

You need to get a fresh copy of that file and reapply the edits using notepad++ which Pit$Bull linked to in his post. Then the funny ?'s will disappear.

Re: Icon missing, � there insetad

Posted: Wed May 19, 2010 1:37 pm
by sdmxc
ok so, I'll give that a try and post my results.

Thanks...

Re: Icon missing, � there insetad

Posted: Wed May 19, 2010 4:31 pm
by sdmxc
that didn't work guys. I used original common.php file from the downloaded .zip. Edited with notepad++ and made sure UTF-8 without BOM was enabled. No joy. I also uploaded the original common.php without any mods to see if this would work and still no joy.

Anything else?

Re: Icon missing, � there insetad

Posted: Wed May 19, 2010 4:37 pm
by stevemaury
Purge the cache from the ACP.