problem with apostrophe in name of attachment

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Ideas Centre
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
Trigger Happy
Registered User
Posts: 22
Joined: Thu Jan 07, 2010 12:43 pm
Location: CZE

problem with apostrophe in name of attachment

Post by Trigger Happy » Thu May 20, 2010 1:05 pm

Support Request Template
What version of phpBB are you using? phpBB 3.0.7-PL1
What is your board's URL? http://www.gene-rally.com/
Who do you host your board with? company
How did you install your board? I used the download package from phpBB.com
Is your board a fresh install or a conversion? Update from a previous version of phpBB3
Do you have any MODs installed? No
Is registration required to reproduce this issue? Yes
What version of phpBB3 did you update from? phpBB 3.0.6
What styles do you currently have installed? versions of serenity and default styles
What language(s) is your board currently using? British English
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP and phpBB
What username can be used to view this issue?
Please do not provide this information if the user requires more than "regular user" privilages.
testing
What password can be used to view this issue? testingaccount
When did your problem begin? unknown
Please describe your problem.
Hi,

When any user wants to attach a file with name like ''Mark's file'' or other using of combination of signs ''abc's file'', the final attachment's name showed in forum is only '' 's file'', the letters in front apostrophe are ignored.

For test, if necessary, use posting new reply in this topic, please. Thanks.

Can you help me, how to solve this problem, please?
Generated by SRT Generator ($Rev: 3988 $)

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69239
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: problem with apostrophe in name of attachment

Post by KevC » Thu May 20, 2010 2:12 pm

Ivo Porc wrote:Can you help me, how to solve this problem, please?
Don't use an apostrophe?
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

Oleg
Former Team Member
Posts: 1221
Joined: Sat Jan 30, 2010 4:42 pm
Location: NYC
Contact:

Re: problem with apostrophe in name of attachment

Post by Oleg » Thu May 20, 2010 2:21 pm

It's a bug in phpbb. Until it is fixed the workaround is to not use apostrophes or quotes in file names.

http://tracker.phpbb.com/browse/PHPBB3-9615
Participate in phpBB development: Get involved | Issue tracker | Report a bug | Development board | [url=irc://chat.freenode.net/phpbb-dev]Development IRC chat[/url]
My stuff: mindlinkgame.com

User avatar
bantu
3.0 Release Manager
3.0 Release Manager
Posts: 2523
Joined: Mon Jul 10, 2006 9:58 pm
Name: Andreas Fischer

Re: problem with apostrophe in name of attachment

Post by bantu » Thu May 20, 2010 2:31 pm

What PHP version are you using, what browser are you using?
Powered by Coffee

Trigger Happy
Registered User
Posts: 22
Joined: Thu Jan 07, 2010 12:43 pm
Location: CZE

Re: problem with apostrophe in name of attachment

Post by Trigger Happy » Thu May 20, 2010 3:47 pm

Kevin Clark wrote:Don't use an apostrophe?
Great idea. :lol: But not solves the reason. 8-)
bantu wrote:What PHP version are you using, what browser are you using?
I'm using Firefox 3.6.3. You can enter the board (under ''testing'' (login info above) and test to post attachments under browsers of your choice.

PHP Version 4.4.9
MySQL 5.0.81-log
phpbb3.0.7-PL1

if you need other details, tell me.

Locked

Return to “[3.0.x] Support Forum”