SQL Error (mysql4) Incorrect string value

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Anti-Spam Guide
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
ScottieDog
Registered User
Posts: 268
Joined: Fri Nov 20, 2009 8:26 pm

SQL Error (mysql4) Incorrect string value

Post by ScottieDog » Wed Jun 30, 2010 8:40 am

Hi, I am trying to make a post in my forum, but it keeps failing with a String Error... I have attached a screenshot but the top text line is as follows......

Incorrect string value: '\xE2\x80\xA8\xE2\x80\xA8...' for column 'post_text' at row 1 [1366]


It is a longer post than normal. When I cut it down to half size it posts OK.. So I am thinking maybe there is a post size limit ?

Anyone advise ?
Attachments
Screen shot 2010-06-30 at 10.37.49 AM.png
Screen shot 2010-06-30 at 10.37.49 AM.png (210.73 KiB) Viewed 1650 times

NathanFtw
Registered User
Posts: 247
Joined: Mon Jun 15, 2009 7:59 am

Re: SQL Error (mysql4) Incorrect string value

Post by NathanFtw » Wed Jun 30, 2010 9:51 am

Try following the following article - Doesn't have a default value errors

It should fix the error. Id have to say you used Fantastico to install your board, correct?

ScottieDog
Registered User
Posts: 268
Joined: Fri Nov 20, 2009 8:26 pm

Re: SQL Error (mysql4) Incorrect string value

Post by ScottieDog » Wed Jun 30, 2010 9:54 am

No I did not use Fantastico, I installed using full instructions by Steve Maury.

I don´t understand why it lets a certain amount be posted, but anymore and it fails with this line 1366 sqyl error...

This is the only forum where there is a problem too. Most strange. I even deleted the Forum and started again, as I was inserting the first post...

I´ll read your link now. thanks.

ScottieDog
Registered User
Posts: 268
Joined: Fri Nov 20, 2009 8:26 pm

Re: SQL Error (mysql4) Incorrect string value

Post by ScottieDog » Wed Jun 30, 2010 10:16 am

strangest thing... it seems to be something in the text at the end of the post. I have just re-written the end of the past directly into the post and it has submitted OK.

If i then try to copy and paste the same text from a text file, it errors again... wierd ? ?
there are a few characters, like () in there, but nothing which should cause a SQL error ?

Would like to know what the problem is, I had a feeling it was something to do with the end of the text I was putting in to the post, so i started adding it bit by bit... the text which caused the error was just normal text with some of it inside normal (brackets).

Ideas ?

User avatar
ric323
Former Team Member
Posts: 22909
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: SQL Error (mysql4) Incorrect string value

Post by ric323 » Wed Jun 30, 2010 11:39 am

The text you are pasting must contain some unicode characters. This includes fancy single and double quote characters.
The suggested solution should fix the problem, even if you didn't use Fantastico.
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

Locked

Return to “[3.0.x] Support Forum”