Why do my HTML codes show up on one board and not another?

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Anti-Spam Guide
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
fanzing
Registered User
Posts: 33
Joined: Mon Sep 12, 2005 5:36 am
Location: Rochester, MN
Contact:

Why do my HTML codes show up on one board and not another?

Post by fanzing »

Hello,

My message board has lain fallow for a few years, as visits to my blog had dropped. I recently decided to make use of it again and went back to look at it today. It's still in 3.0.RC7, but I'm going to be updating it tomorrow.

On my public board, everything looks okay. However, on the private boards, every line in every post ends with a BR HTML tag, and smileys and signatures are broken. For example:

Code: Select all

Was everyone else busy this weekend, too? <!--EZCODE EMOTICON START :) --><img src=http://www.ezboard.com/images/emoticons/smile.gif ALT=":)"><!--EZCODE EMOTICON END--> <br>
<br>
Let's try to post a LOT to Monitor Duty this week so that people don't think we've croaked! <p>Michael Hutchison, Fanzing Editor<br>
<a href="http://www.thehutch.com/comics/" target="_blank">http://www.thehutch.com/comics/</a><br>
<i>"There are knowns, known unknowns, and unknown unknowns." - Unknown</i></p><i></i>
Is there any way to fix this?
Michael Hutchison, Comic Book Writer
http://www.thehutch.com
User avatar
ric323
Former Team Member
Posts: 22910
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Why do my HTML codes show up on one board and not anothe

Post by ric323 »

What do you mean "public board" and "private boards" ?

In phpBB terminology, a "board" contains multiple "forums"/"categories", which contain "topics", which contain "posts".

So, are you talking about "boards", or "forums" ?
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions
fanzing
Registered User
Posts: 33
Joined: Mon Sep 12, 2005 5:36 am
Location: Rochester, MN
Contact:

Re: Why do my HTML codes show up on one board and not anothe

Post by fanzing »

Sorry!

I have one board, and several forums on that board, a few of which are private ones.

The private boards have this HTML oddity which I showed in the sample above, but the main public board does not.

Any ideas how I fix this?
Michael Hutchison, Comic Book Writer
http://www.thehutch.com
User avatar
ric323
Former Team Member
Posts: 22910
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Why do my HTML codes show up on one board and not anothe

Post by ric323 »

To tell us more about your board, please fill out the Support Request Template, and post the output back here.
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions
Locked

Return to “[3.0.x] Support Forum”