Error General - Out of range value adjusted column - Mysql5

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
construaprende
Registered User
Posts: 59
Joined: Tue May 18, 2004 7:40 pm
Location: Mexico
Contact:

Error General - Out of range value adjusted column - Mysql5

Post by construaprende » Sat Sep 11, 2010 4:42 pm

Hi
I recently changed my server, with MYSQL 5.077
My phpbb is 3.02

After several days, evething was fine, but my forums stop working, and A Message says:

I CHECKED THIS MESSAGE APPEARS WHEN I AM NOT LOGGED IN FORUM

Code: Select all

Error General
SQL ERROR [ mysqli ]
Out of range value adjusted for column 'wwh_id' at row 1 [1264]
I had backups of my database, and I had to restore it one day back, but in some minutes, my forum was down again, but now with a message that says:

I CHECKED THIS MESSAGE APPEARS AFTER I WAS LOGGED IN MY FORUM

Code: Select all

SQL ERROR [ mysqli ]
Out of range value adjusted for column 'wwh_id' at row 1 [1264]
SQL
INSERT INTO phpbb_wwh (user_id, user_ip, username, username_clean, user_colour, user_type, viewonline, wwh_lastpage)
VALUES ('2', 'xxx.xxx.233.246', 'xxxxusername', 'xxxxusername', 'AA0000', '3', '0', 1284222736)
BACKTRACE
FILE: includes/db/mysqli.php
LINE: 143
CALL: dbal->sql_error()
FILE: includes/functions_wwh2.php
LINE: 37
CALL: dbal_mysqli->sql_query()
FILE: includes/functions_wwh.php
LINE: 17
CALL: include_once('includes/functions_wwh2.php')
FILE: index.php
LINE: 133
CALL: include('includes/functions_wwh.php')
So I had to restore my database two days ago, but after 2 days, the problems happens again

I have not changed anything in my phpbb forum, I only changed to a new server with a newer version of mysql


This are my installed MODs:
full_syndication_suite-1.0.RC1
Similar Topic
Country-Flags
Top-Posters
Topic-Preview
SEO-Zero-No-Dupe-b
SEO_Optimal_titlesV1.0.2
gym_sitemaps_rss
No-Dupe
Last_Post_on_Index
mod_ads_0_2_0
NV_who_was_here_1_0_0-RC1
Manage_attachments
Watermark
Thanks-Post-0.2
Minimun Chars-Per-Post
Recapcha
But My forum were fine for several months with this MODs, before I Upgraded to mysql5


Any Idea how to solve this?

Thanks
Last edited by ric323 on Sun Sep 12, 2010 1:27 pm, edited 6 times in total.
Reason: Topic icon changed

blakebowling
Registered User
Posts: 775
Joined: Sun Apr 27, 2008 4:49 am
Location: 127.0.0.1

Re: Error General - Out of range value adjusted column - Mys

Post by blakebowling » Sat Sep 11, 2010 4:51 pm

I haven't personally seen this error before, so the solution I provide is a GENERAL SQL fix:
Repair all of your phpBB tables.

construaprende
Registered User
Posts: 59
Joined: Tue May 18, 2004 7:40 pm
Location: Mexico
Contact:

Re: Error General - Out of range value adjusted column - Mys

Post by construaprende » Sat Sep 11, 2010 5:03 pm

blakebowling wrote:I haven't personally seen this error before, so the solution I provide is a GENERAL SQL fix:
Repair all of your phpBB tables.
Hi
I did this too,
but it is not fixed

I searched in forums, and some says that it could be a problem with mysql 5
I don't know if this could be fixed with phpbbb 3.07 latest version, because in other forums, others says that it happens with 3.07 too

In my observation, I think this is happening when some limit is reached, not sure if at certains number of posts (I have 44080 posts now), or certain number of registered users (I have 73227 users)

Because, when I restore database more days back, it takes more long for the error to get back again
So, meanwhile, I have deleted some inactive users, and deleted some few old post, and wait to see if my forum will be more days without error

Any idea how to really solve this?

Thanks a lot

construaprende
Registered User
Posts: 59
Joined: Tue May 18, 2004 7:40 pm
Location: Mexico
Contact:

Re: Error General - Out of range value adjusted column - Mys

Post by construaprende » Sat Sep 11, 2010 5:48 pm

Error Again

I deleted some inactive users, and some old posts, but in some minutes, the Error came back again

So, I really don't know what to do

Thanks

construaprende
Registered User
Posts: 59
Joined: Tue May 18, 2004 7:40 pm
Location: Mexico
Contact:

Re: Error General - Out of range value adjusted column - Mys

Post by construaprende » Sat Sep 11, 2010 5:58 pm

I Enter to phpmyadmin, and make repair of all tables again without any luck

But I did run the CHECK TABLE option, and this is what it says:
Problems with indexes of table `phpbb_posts`
More than one INDEX key was created for column `topic_id`
More than one FULLTEXT key was created for column `post_subject`
Problems with indexes of table `phpbb_search_wordmatch`
UNIQUE and INDEX keys should not both be set for column `word_id`
Problems with indexes of table `phpbb_topics`
More than one INDEX key was created for column `forum_id`
Any idea?

Thanks

blakebowling
Registered User
Posts: 775
Joined: Sun Apr 27, 2008 4:49 am
Location: 127.0.0.1

Re: Error General - Out of range value adjusted column - Mys

Post by blakebowling » Sat Sep 11, 2010 6:05 pm

Download a fresh package from phpBB.com
Upload the /install/ folder
go to http://yourwebsite.com/path-to-forum/in ... pgrade.php

Again, speculation based on SQL errors. I think there is a KB article somewhere on upgrade to mysql5, but I can't seem to find it.

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Error General - Out of range value adjusted column - Mys

Post by RMcGirr83 » Sat Sep 11, 2010 6:06 pm

which table is this

Code: Select all

phpbb_wwh
because there is no such table in a default installation of phpBB.

If I had to guess I would say it is from this mod

NV_who_was_here_1_0_0-RC1

So you would need to seek help from that mod topic which is no longer a RC but a validated mod so it would probably behoove you to upgrade the mod to the new version.

FWIW, I believe the issue has to do with the fact that the mod limits the wwh to mediumint to a max of 8 characters. So you may be able to change that in your database to say, int with a max of 11 or whatever.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

construaprende
Registered User
Posts: 59
Joined: Tue May 18, 2004 7:40 pm
Location: Mexico
Contact:

Re: Error General - Out of range value adjusted column - Mys

Post by construaprende » Sat Sep 11, 2010 6:13 pm

RMcGirr83 wrote:which table is this

Code: Select all

phpbb_wwh
because there is no such table in a default installation of phpBB.

If I had to guess I would say it is from this mod

NV_who_was_here_1_0_0-RC1

So you would need to seek help from that mod topic which is no longer a RC but a validated mod so it would probably behoove you to upgrade the mod to the new version.

FWIW, I believe the issue has to do with the fact that the mod limits the wwh to mediumint to a max of 8 characters. So you may be able to change that in your database to say, int with a max of 11 or whatever.
Thanks a lot for your help
I did try to change this two values to 11, but id did not work

Meanwhile I will try to remove this MOD (NV_who_was_here_1_0_0-RC1)

Thanks
Attachments
phpbb_wwh.jpg
phpbb_wwh.jpg (114.97 KiB) Viewed 1213 times

construaprende
Registered User
Posts: 59
Joined: Tue May 18, 2004 7:40 pm
Location: Mexico
Contact:

Re: Error General - Out of range value adjusted column - Mys

Post by construaprende » Sat Sep 11, 2010 6:35 pm

wow
Thanks

I did Remove changes of MOD
who_was_here_1_0_0-RC1
(4 files edited)

And now everything is working fine

Thanks a lot for your help

Regards

br0w
Registered User
Posts: 1
Joined: Sat Feb 23, 2008 6:21 pm

Re: Error General - Out of range value adjusted column - Mys

Post by br0w » Fri Feb 25, 2011 1:42 pm

decided problem… changed column wwh_id of mediumint (8) for bigint (12)… and later made reset of the accountant of autoincrement...

:mrgreen:


problema resolvido... mudado coluna wwh_id de mediumint(8) para bigint(12)... e depois feito o reset do contador do autoincrement...

:mrgreen:

Locked

Return to “[3.0.x] Support Forum”