Vew New Posts not working

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Get Involved
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
Zzodhi
Registered User
Posts: 53
Joined: Mon Jun 21, 2010 12:43 am

Vew New Posts not working

Post by Zzodhi »

Running the latest version of PHP. View unread posts works but "View New Posts" does not work for members. I couldn't find anything in the archives.
User avatar
d1m0
Registered User
Posts: 127
Joined: Wed Nov 25, 2009 9:20 am

Re: Vew New Posts not working

Post by d1m0 »

Please fill in the support template to tell us about your forum and the exact error you get (if any). Then we might be able to help :)
SiteGround Technical Support Team Member
Check out our special phpBB hosting package
Zzodhi
Registered User
Posts: 53
Joined: Mon Jun 21, 2010 12:43 am

Re: Vew New Posts not working

Post by Zzodhi »

Support Request Template
What version of phpBB are you using? phpBB 3.0.7-PL1
What is your board's URL? http://www.freerangechameleons.com/forum
Who do you host your board with? GoDaddy
How did you install your board? I used the download package from phpBB.com
Is your board a fresh install or a conversion? Update from a previous version of phpBB3
Do you have any MODs installed? Yes
Is registration required to reproduce this issue? Yes
What version of phpBB3 did you update from? phpBB 3.0.7
What MODs do you have installed? mChat
What styles do you currently have installed? AreoGreen
What language(s) is your board currently using? English
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP and phpBB
What username can be used to view this issue? [removed]
What password can be used to view this issue? [removed]
When did your problem begin? Always been a problem
Please describe your problem. "View New Posts" does not work. It always returns no data even though there are many new posts. The other two "View Unread" and "View your posts" work.
Generated by SRT Generator ($Rev: 4351 $)
Last edited by ric323 on Mon Sep 20, 2010 2:30 pm, edited 1 time in total.
Reason: removed test user details
User avatar
ric323
Former Team Member
Posts: 22910
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Vew New Posts not working

Post by ric323 »

I removed the test user details, as that user has some admin permissions. Was that intended?
Also, I could see in your ACP that you have some Karma MOD partly installed. What happened there?
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52169
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Vew New Posts not working

Post by Brf »

The newest post I see on there as a Guest is one from a week ago. Are there other posts in hidden forums?
Zzodhi
Registered User
Posts: 53
Joined: Mon Jun 21, 2010 12:43 am

Re: Vew New Posts not working

Post by Zzodhi »

Yes, use the test user log in supplied in the support. Click on View New Posts and there should be many.
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52169
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Vew New Posts not working

Post by Brf »

Ric removed the details of that login from your post.
You should not be posting administrator passwords on public forums like this one. We only needed a regular user password.
User avatar
ric323
Former Team Member
Posts: 22910
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Vew New Posts not working

Post by ric323 »

Zzodhi wrote:Yes, use the test user log in supplied in the support. Click on View New Posts and there should be many.
As I posted above, I removed that info from your post, because the account you posted has some admin permissions, and therefore access to some parts of your ACP.
If that was deliberate, then please re-post the username and password, or create a new account with just standard user permissions.
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52169
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Vew New Posts not working

Post by Brf »

As your test user, I can see there was a post on the 13th, 16th, and 17th, but those are not "New" since your test user was logged in since then.

If you will make a new post as a different user, I can test "New Posts".

nevermind.

The new post I made as your test user, is showing up fine in "View new posts"
Zzodhi
Registered User
Posts: 53
Joined: Mon Jun 21, 2010 12:43 am

Re: Vew New Posts not working

Post by Zzodhi »

Yes, I saw that and when I relogged in as my user it showed up. I had reinstalled everything without any mods but mChat and it still wasn't working for members. They claimed it never worked.

Maybe it is now although when I checked this morning it wasn't working.

Thanks for the help.
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52169
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Vew New Posts not working

Post by Brf »

Well. You have not had very many new posts.
Remember that "New Posts" are posts made since your last login, so if you log out and back in, then the list will be empty.
Locked

Return to “[3.0.x] Support Forum”