Page 1 of 1

Topic Edit Issue

Posted: Tue Nov 23, 2010 4:09 pm
by sam_8085
I have a issue on my board,

Topic Edity By Default

1. When user Edit a topic, it should not change topic position to first on forum, it has to do only when it has posts (viewforum)

2. When user got reply to his topic, topic should moved to first of the respective forum (viewforum) and aslo updated on index.php.


On my Board its not working fine, whats happening is...

1. When user Edit his topic, Topic is moving onto first of that respective forum (viewforum). with out updating index.php. (This is NOT working ok on my board)

2. When user got reply it his topic, topic is moving to first of the forum (viewforum) and also updated on index.php (This is working ok on my board)

Hope it can be fixed !

Re: Topic Edit Issue

Posted: Tue Nov 23, 2010 4:12 pm
by Brf
Editing a post does not change its topic's position in viewforum and such. If yours is changing, then you have some sort of mod that is doing that.

Re: Topic Edit Issue

Posted: Tue Nov 23, 2010 4:20 pm
by sam_8085
Brf wrote:Editing a post does not change its topic's position in viewforum and such. If yours is changing, then you have some sort of mod that is doing that.
Yes, I have installed plenty of mods, how could I find it ?

Re: Topic Edit Issue

Posted: Wed Nov 24, 2010 2:00 am
by sam_8085
So, no one can help me ?

Re: Topic Edit Issue

Posted: Wed Nov 24, 2010 3:04 am
by stevemaury
We would have no idea what MODs you installed.

Re: Topic Edit Issue

Posted: Wed Nov 24, 2010 4:12 am
by sam_8085
stevemaury wrote:We would have no idea what MODs you installed.
You mean, no way to sort this out ?

Re: Topic Edit Issue

Posted: Wed Nov 24, 2010 11:54 am
by Brf
We would have to guess, since we have no access to your code.

If your problem is in viewforum, look for the mod that changed viewforum.

Re: Topic Edit Issue

Posted: Wed Nov 24, 2010 2:07 pm
by sam_8085
Brf wrote:We would have to guess, since we have no access to your code.

If your problem is in viewforum, look for the mod that changed viewforum.
I'm not so good at finding out the code which can fix my issue. So how to I provide access to phpbb support team ?

Re: Topic Edit Issue

Posted: Wed Nov 24, 2010 4:31 pm
by stevemaury
We do not support or repair MOD-related issues. You need to review all the edits made by your MODs and see which one(s) affect viewforum.php and then seek support in the support area for that MOD.

Your other alternative is this:

*NOTE: Before proceeding backup all files and the database.*
  • Upload all new files from a download of the full version 3.0.8, except for config.php, the /images and /files folders.
  • Go to yoursite.com/forumfolder/install/database_update.php
  • Let that run and then delete the install folder.
  • You now have a new up to date board containing all your users and posts but without any MODs that you might have had installed.

Re: Topic Edit Issue

Posted: Wed Nov 24, 2010 5:22 pm
by sam_8085
Thanks for your reply and alternative solution ! I have gone through the recent mods I have installed, restored them. But no positive results...

I have run this SQL very recently !

Code: Select all

ALTER TABLE phpbb_forums ADD adp_enable tinyint(1) NOT NULL DEFAULT 1;
ALTER TABLE phpbb_forums ADD adp_admins tinyint(1) NOT NULL DEFAULT 0;
ALTER TABLE phpbb_forums ADD adp_modos tinyint(1) NOT NULL DEFAULT 0;
ALTER TABLE phpbb_forums ADD adp_auto_edit tinyint(1) NOT NULL DEFAULT 1;
ALTER TABLE phpbb_forums ADD adp_text_edit varchar(255) NOT NULL DEFAULT '-- %D --';
ALTER TABLE phpbb_forums ADD adp_always tinyint(1) NOT NULL DEFAULT 1;
ALTER TABLE phpbb_forums ADD adp_days int(11) NOT NULL DEFAULT 1;
ALTER TABLE phpbb_forums ADD adp_hours int(11) NOT NULL DEFAULT 0;
ALTER TABLE phpbb_forums ADD adp_mins int(11) NOT NULL DEFAULT 0;
ALTER TABLE phpbb_forums ADD adp_secs int(11) NOT NULL DEFAULT 0;
It has any chance to do this ?

Re: Topic Edit Issue

Posted: Wed Nov 24, 2010 6:01 pm
by stevemaury
Merely adding columns to a table would not do this, but again, in this forum we do not support MODs nor repair MOD issues. All I can tell you is to try the second step I give above to replace the files, and then reinstall your MODs one at a time and test.

Re: Topic Edit Issue

Posted: Thu Nov 25, 2010 3:40 pm
by sam_8085
Ok, what if i upgrade to 3.0.8 ? any chance to get it back with all my installed mods ?

;)

Re: Topic Edit Issue

Posted: Thu Nov 25, 2010 5:03 pm
by stevemaury
Sure, but this issue will still exist. It is caused by a MOD.

Re: Topic Edit Issue

Posted: Fri Nov 26, 2010 2:51 am
by sam_8085
stevemaury wrote:Sure, but this issue will still exist. It is caused by a MOD.
Ok, can you please let me know which file may effect like this.
So that I'll take some time and role back mods related to file you mentioned.

Thanks in advance !