can't lock anything etc as an Admin

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Ideas Centre
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
Sonia10
Registered User
Posts: 53
Joined: Thu Nov 18, 2010 12:53 pm

can't lock anything etc as an Admin

Post by Sonia10 » Tue Nov 30, 2010 10:55 pm

Hi
I thought I set things so I can lock, move etc on the forum posts by members as I am admin. I can't do it anymore Can you tell me what to do to make sure I have this set ok.
Thanks in advance and a setp by step to make sure I have done it correctly
Sonia

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50862
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: can't lock anything etc as an Admin

Post by stevemaury » Tue Nov 30, 2010 10:58 pm

Make sure you are a member of the Global Moderators group and that that group has a full moderator permission role.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

Sonia10
Registered User
Posts: 53
Joined: Thu Nov 18, 2010 12:53 pm

Re: can't lock anything etc as an Admin

Post by Sonia10 » Tue Nov 30, 2010 11:16 pm

How do I make sure I am in the Global moderators group

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50862
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: can't lock anything etc as an Admin

Post by stevemaury » Tue Nov 30, 2010 11:52 pm

ACP, Users and Groups, Manage groups, Global moderators, Members.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

tarekz
Registered User
Posts: 61
Joined: Wed Mar 09, 2011 11:09 pm

Re: can't lock anything etc as an Admin

Post by tarekz » Thu Jun 02, 2011 10:41 am

I have the same issue... I did all the steps mentioned in this thread.
I gave Full Access for Moderator Forum permissions to Global Moderators for that particular forum.
But still when I lock a topic it asks me to confirm, and then goes back to the topic. When I check on the forum this topic is still open. Same goes for the Sticky action (and probably all the others).

Thanks in advance

User avatar
AGC
Registered User
Posts: 292
Joined: Sat Sep 15, 2007 10:26 pm
Contact:

Re: can't lock anything etc as an Admin

Post by AGC » Thu Jun 02, 2011 2:51 pm

Try to purge your cache and check again.
(phpBB 2.0.x): []Admin Topics List[] MOD. << Description & Download. , []Highlight Author[] MOD.

Donate-paypal
(phpBB 3.0.x)[ver] MODs: [RC1] >Import old *.pak files MOD. + . . .[8] > ACP - Modules Quick Access (MQA) MOD. + . . . [7-PL1] > Multi Smile (actions) MOD

tarekz
Registered User
Posts: 61
Joined: Wed Mar 09, 2011 11:09 pm

Re: can't lock anything etc as an Admin

Post by tarekz » Thu Jun 02, 2011 3:26 pm

That did not solve the problem...

I have asked another question on the forum and it seemed like I was going about configuring permissions the wrong way. I think I have added the moderators and admins under the permission tab, instead of just making them members of the Global Moderators. Could that interfere?

That said, when i check the mask for forum based permissions these user have all green...

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50862
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: can't lock anything etc as an Admin

Post by stevemaury » Mon Jun 06, 2011 4:56 pm

You need to use the mask for global moderation permissions.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

tarekz
Registered User
Posts: 61
Joined: Wed Mar 09, 2011 11:09 pm

Re: can't lock anything etc as an Admin

Post by tarekz » Tue Jun 07, 2011 9:39 pm

They are all green... I tried an admin I create temporarily. Added him to the Administrators group so he can see the forums. This Admin1 can basically do all the actions!! But not the other admins.

I am going to compare the roles assigned to these two admins and see what is the difference.

Also, I want to point out that the other admins and moderators login through a special auth module I wrote.
Would this be interfering with them getting their permissions? All i know is they show up in red and green.
And when I look in the permission masks, they all are green.

Thanks in advance,

tarekz
Registered User
Posts: 61
Joined: Wed Mar 09, 2011 11:09 pm

Re: can't lock anything etc as an Admin

Post by tarekz » Wed Jun 08, 2011 12:48 am

I compared the two admins.
The one I created using SQL has user_type = 3 while the one that was added to the Administrator group has user_type 0.

How would I change the user type for the second admin to 3 using the Administrator Control Panel?

tarekz
Registered User
Posts: 61
Joined: Wed Mar 09, 2011 11:09 pm

Re: can't lock anything etc as an Admin

Post by tarekz » Wed Jun 08, 2011 6:28 pm

I used fiddler to see what happens when each of the admins try to lock a post.

Here are the results:

Admin that can not perform any actions:
/mcp.php?f=53&t=78&quickmod=1&redirect=.%2Fviewtopic.php%3Ff%3D53%26t%3D78%26sid%3D369bdddc38df772d9884ec5ce847b1c0&sid=369bdddc38df772d9884ec5ce847b1c0
/style.php?id=2&lang=en&sid=b3d237c96dbc9395f9447fc09678e34b
/mcp.php?f=53&t=78&quickmod=1&redirect=.%2Fviewtopic.php%3Ff%3D53%26t%3D78%26sid%3D369bdddc38df772d9884ec5ce847b1c0&sid=b3d237c96dbc9395f9447fc09678e34b&confirm_key=1N7IO33M5I
/viewtopic.php?f=53&t=78&sid=282aa92cd6aa338ab8c48ada9c761812
/style.php?id=2&lang=en&sid=d437643ed81074b8c1fbbc668299c7e0


Admin that can do all the actions:
/mcp.php?f=50&t=78&quickmod=1&redirect=.%2Fviewtopic.php%3Ff%3D50%26t%3D8172%26sid%3Db7a88107bcdbf179b58ed759c5010971&sid=b7a88107bcdbf179b58ed759c5010971
/mcp.php?f=50&t=78&quickmod=1&redirect=.%2Fviewtopic.php%3Ff%3D50%26t%3D8172%26sid%3Db7a88107bcdbf179b58ed759c5010971&sid=b7a88107bcdbf179b58ed759c5010971&confirm_key=3GT7JOM15O
/viewtopic.php?f=50&t=78&sid=b7a88107bcdbf179b58ed759c5010971


It seems that the session of the first admin gets invalidated while doing the action.
This means I have a problem in my custom auth.

I will be taking the question to the appropriate forum.

Thanks all for your help!

tarekz
Registered User
Posts: 61
Joined: Wed Mar 09, 2011 11:09 pm

Re: can't lock anything etc as an Admin

Post by tarekz » Thu Jun 16, 2011 6:04 pm

This problem no longer occurs once i delete the validate_session function in the custom authentication file.
That function was creating a new session every time the user clicks a link and hence the actions were not being carried out.

Thanks for your help!

Locked

Return to “[3.0.x] Support Forum”