Page 1 of 7

Spam Bots Attacking! Please Help!

Posted: Tue Jan 04, 2011 7:05 pm
by hancholo
Can someone tell me please step by step how to set the registration question to ask if people are a spam bot or not? I had this set before but now looks like spam bots are still coming in so I thought I would just change the registration question to something else, but I cant figure out how to do it.

Someone else asked this and the answer just said to go to the APC CAPTCHA settings but I need someone more savvy to please explain step by step what tab and where to look and where to click.

Thank you!

Re: Spam Bots Attacking! Please Help!

Posted: Tue Jan 04, 2011 7:13 pm
by stevemaury
You need to use the Q&A CAPTACHA in the ACP, General tab, Spambot countermeasures, Available plugins drop down, Q&A.

Re: Spam Bots Attacking! Please Help!

Posted: Tue Jan 04, 2011 11:47 pm
by hancholo
Steve can you please give a detailed explanation? Step by step. Im in the APC general tab, now what? Im using version 3.0.7-PL1 Can you explain click by click...with these things if you miss one little step its easy to get lost.

Your answer might be good to some but for us newbies you lost me...

Re: Spam Bots Attacking! Please Help!

Posted: Wed Jan 05, 2011 12:12 am
by King Rhyono
ACP > click "Spambot Countermeasures" in the list on the left hand side > set all three things to "Enabled" > choose one of the "installed plugins" (I use GD image) > Submit.

Re: Spam Bots Attacking! Please Help!

Posted: Wed Jan 05, 2011 12:13 am
by stevemaury
That is step-by-step, click-by-click. Have you tried it?

Re: Spam Bots Attacking! Please Help!

Posted: Wed Jan 05, 2011 1:53 am
by Sheldon469
This was a good read.

Re: Spam Bots Attacking! Please Help!

Posted: Wed Jan 05, 2011 1:57 am
by prdp141
I have just had a similar experience with spambots and was doing the same mod as you. eg changing from GD 3D captcha to a Q&A. At the same time I tried to change the default question from 'Are you human?' to 'Is Donald duck a horse, duck or goat?'.

I found that if I left the original question in place, my new question did not show. So you may have delete the original question for it to show as there is no option to select different questions on the spambots/countermeasures page. Well..not in my case anyhow.

Refer my post: Captcha's don't change/display on Reg'n Page

Hopefully you'll have better success than I have had 'cause I can't find a solution.

Anyhow try deleting the original question if you haven't already.

Phil

Re: Spam Bots Attacking! Please Help!

Posted: Wed Jan 05, 2011 6:51 pm
by stevemaury
There is no default question in the phpBB Q&A CAPTCHA. You are talking about some MOD.

Re: Spam Bots Attacking! Please Help!

Posted: Wed Jan 05, 2011 9:51 pm
by prdp141
I have the question Are you Human? which appears in my preview window with the other captchas eg GD Image and GD 3D Image,and is displayed also on the New Members registration page. Been there since ver. 3.0.7 and I didn't do any mods, so I totally assumed it was a standard inclusion. I only tried to use the Q&A captcha a couple of days ago as I have always used (for 12 months+) the GD 3D Image.

Any ideas as to what's going on then?

Thanks
Phil

Re: Spam Bots Attacking! Please Help!

Posted: Thu Jan 06, 2011 6:20 am
by DBM
I have been getting a sudden huge surge in spambot attacks in the past 48 hours too - and it's specifically my phpBB board that is being targeted despite there being other parts of the site that are potentially vulnerable to spambots, such as a Wordpress blog.

None of them have actually been able to post yet as I have newly registered accounts on moderation but it's still annoying having to clean up their crap.

I was using the Q&A captcha and do change the questions quite often - I hadn't had a successful spambot registration in months. I've changed tack and tried the reCaptcha module for now, which has slowed them down a bit, plus I've been blocking every IP range they've been using (nearly all Russian and Ukrainian) at server level.

Since several people are now reporting this sudden upsurge at the same time, it does look to me like phpBB boards are being very specifically targeted in this wave of attacks.

Re: Spam Bots Attacking! Please Help!

Posted: Thu Jan 06, 2011 6:30 am
by DBM
edited

Re: Spam Bots Attacking! Please Help!

Posted: Thu Jan 06, 2011 2:29 pm
by Travisher
I've been running with Q&A for nearly a year and I have administrative activation. The questions I have are very specific to my niche interest group and can only be answered by careful reading of the site. In the last 3 weeks the number of attempted spam sign-ups has rocketed. Occam's razor says that the spambots have a way of bypassing the CAPCHA completely since unless they are programmed with the answers they cannot answer the questions.

One very good mod would be to display the question that was answered in the activation email to the admin. That way you would have a good idea if your questions were 'worn out' when they came in with an attempted spam signup.

Re: Spam Bots Attacking! Please Help!

Posted: Thu Jan 06, 2011 2:43 pm
by DBM
Travisher wrote:I've been running with Q&A for nearly a year and I have administrative activation. The questions I have are very specific to my niche interest group and can only be answered by careful reading of the site. In the last 3 weeks the number of attempted spam sign-ups has rocketed. Occam's razor says that the spambots have a way of bypassing the CAPCHA completely since unless they are programmed with the answers they cannot answer the questions.
It's a good point. I'm careful not to set "multiple choice" questions as I think a reasonably sophisticated bot can find the right answer by trying information given in the question.

Things have slowed a little for me by switching to the reCaptcha module - but it's hard for me to know how much of an impact this actually had as I've now also banned entire swathes of Russian and Ukrainian IP ranges at server level (I've never had any genuine punters from those countries).

I think you're right, it seems a bit of a coincidence that the bots should suddenly be able to find the answers to multiple sites' Q&A captcha at the same time. I thought they may be using humans to crack the captcha - but, as you say, they may have found a way to bypass it altogether.

Re: Spam Bots Attacking! Please Help!

Posted: Thu Jan 06, 2011 2:45 pm
by stevemaury
Travisher wrote:I've been running with Q&A for nearly a year and I have administrative activation. The questions I have are very specific to my niche interest group and can only be answered by careful reading of the site. In the last 3 weeks the number of attempted spam sign-ups has rocketed. Occam's razor says that the spambots have a way of bypassing the CAPCHA completely since unless they are programmed with the answers they cannot answer the questions.

One very good mod would be to display the question that was answered in the activation email to the admin. That way you would have a good idea if your questions were 'worn out' when they came in with an attempted spam signup.

A link to your site, please?

Re: Spam Bots Attacking! Please Help!

Posted: Thu Jan 06, 2011 2:52 pm
by Travisher
Sure Steve,
http://www.bodgers.org.uk

most of the recent attacks have been from Ukraine and Russia but then I ban the whole of China at server level.
I've also seen a number of what are probably human attempts from Vietnam which may just be an extension of China as far as the bots are concerned.