Page 1 of 1

Forum problems - Backup/Restore questions

Posted: Sun Jan 09, 2011 5:27 pm
by jdirty
Support Request Template
What version of phpBB are you using? phpBB 3.0.8
What is your board's URL? http://private
Who do you host your board with? self-hosted
How did you install your board? I used the download package from phpBB.com
Is your board a fresh install or a conversion? Fresh Install
Do you have any MODs installed? Yes
Is registration required to reproduce this issue? No
What MODs do you have installed? last topic title
Gallery
phpbbchat
What styles do you currently have installed? only default
What language(s) is your board currently using? english
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP and phpBB
When did your problem begin? during uninstallation of mod
Please describe your problem. it seems an uninstallation of a mod has causes some problems on my board.
The .MOD directory now displays an error:
Fatal error: Call to undefined method cache::obtain_album_list() in C:\devproject\xampp\htdocs\forum\gallery\includes\permissions.php on line 42

Here is what I want to do:

I want to backup the forum structure and posts, wipe out this phpBB installation and reinstall a fresh copy, then restore the backup.

My problem is, last time I tried this 'backup' process, it did NOT work. After reinstalling the board and running a restore, nothing happened, except the loss of all users and data.

Would a backup also save the misconfig that is causing this error? I dont want to backup the problem and transfer it to the new board.

Any suggestions? Now things are really acting funny. I couldn't get the phpbbchat mod to work until i UNinstalled it. Yea, thats right.. I have uninstalled the phpbbchat mod, refreshed and purged caches, and now the chat works. I uninstalled the phpBB Gallery, and now it has all kinds of errors. Something is really screwy, so I thought a fresh reinstall would be the best avenue to take.
Generated by SRT Generator ($Rev: 4502 $)

Re: Forum problems - Backup/Restore questions

Posted: Mon Jan 10, 2011 1:41 am
by Noxwizard
If you download the Full Package and overwrite all of your files (except for config.php!) with those, it will remove all MODs from your board. Then just purge the cache and it should be good to go.