New styles not showing up in install list

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
maxsteele
Registered User
Posts: 6
Joined: Wed Apr 04, 2007 6:01 am

New styles not showing up in install list

Post by maxsteele »

Hey everyone,

I have a new installation of phpbb3 (3.0.8) , and I am attempting to install a new style. I grabbed this style from phpbb3styles.net - http://demo.phpbb3styles.net/MinecraftBB+-+Dark . I placed it into my /var/www/phpBB3/styles/ folder, along with the other two default style folders that come with phpBB3.

When I go into my Administration Control Panel, and select the Styles tab, the 'uninstalled styles' section is blank. I've tried logging out and back into the control panel, and I cannot get this style to show up.

Does anyone have any ideas why this isn't working? Thanks in advance!
User avatar
KevC
Support Team Member
Support Team Member
Posts: 70861
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: New styles not showing up in install list

Post by KevC »

What's the address of your site?
-:|:- Support Request Template -:|:-
Image
"Use of unnecessary violence in the apprehension of the Blues Brothers has been approved"
maxsteele
Registered User
Posts: 6
Joined: Wed Apr 04, 2007 6:01 am

Re: New styles not showing up in install list

Post by maxsteele »

craftersrealm.com .
User avatar
KevC
Support Team Member
Support Team Member
Posts: 70861
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: New styles not showing up in install list

Post by KevC »

You haven't uploaded it to the place you think.

http://craftersrealm.com/styles/

There are only the 2 default styles in there.
-:|:- Support Request Template -:|:-
Image
"Use of unnecessary violence in the apprehension of the Blues Brothers has been approved"
maxsteele
Registered User
Posts: 6
Joined: Wed Apr 04, 2007 6:01 am

Re: New styles not showing up in install list

Post by maxsteele »

Hmm...

I'm doing a redirect in Apache to have craftersrealm.com look at /var/www/phpBB3/ for the index page. PhpBB3 shouldn't care about that though, and still look for the styles directory at /var/www/phpBB3/styles/ .

The two default styles are located in /var/www/phpBB3/styles/ , so I don't see why it wouldn't pick it up the new style directories in the same path.

I can try creating a new 'styles' folder in this type of path:

/var/www/styles/

But I'm not sure that would work.
User avatar
KevC
Support Team Member
Support Team Member
Posts: 70861
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: New styles not showing up in install list

Post by KevC »

There's no directory on your server called /phpBB3.

Your board is in the root of the address you posted. I'm not sure why you're fiddling around with redirections.
-:|:- Support Request Template -:|:-
Image
"Use of unnecessary violence in the apprehension of the Blues Brothers has been approved"
maxsteele
Registered User
Posts: 6
Joined: Wed Apr 04, 2007 6:01 am

Re: New styles not showing up in install list

Post by maxsteele »

Yes, there is a directory called /phpBB3/ . I created it. :)

I have apache looking at /www/phpBB3/ as the root directory, which has it load up the forum when going directly to craftersrealm.com . That's the reason for it, so people don't have to type craftersrealm.com/phpBB3 .
Regardless of all of that, I do see when going to craftersrelam.com/styles/ , only the two default ones show, yet when SSHed into my box, the other directory for the style is most definitely present.

Not sure what the issue is, but I can see that until I have the directory showing up from the web page, for whatever reason phpBB3 isn't going to see it.
User avatar
KevC
Support Team Member
Support Team Member
Posts: 70861
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: New styles not showing up in install list

Post by KevC »

If you type
craftersrealm.com/phpBB3
you get
Not Found
The requested URL /phpBB3 was not found on this server.
-:|:- Support Request Template -:|:-
Image
"Use of unnecessary violence in the apprehension of the Blues Brothers has been approved"
maxsteele
Registered User
Posts: 6
Joined: Wed Apr 04, 2007 6:01 am

Re: New styles not showing up in install list

Post by maxsteele »

That is because i have a virtual host configured under apache.

The DocumentRoot I have selected for www.craftersrealm.com is /var/www/phpBB3/ . When you type craftersrealm.com/phpBB3 , what you're actually doing is:

/var/www/phpBB3/phpBB3/ . Which of course, doesn't exist.

As explained, I did this so when a user types in craftersrealm.com , they go directly to the forum, which is located at /var/www/phpBB3/, but it looks like the root of craftersrealm.com .

It's possible this is throwing off phpBB3, but if that's the case, I'm not sure how it's able to see any type of directory structure at all.

I'll have to see if this is a configuration issue with the virtualhost in Apache or not.
User avatar
KevC
Support Team Member
Support Team Member
Posts: 70861
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: New styles not showing up in install list

Post by KevC »

I don't think your method of redirection is helping.

Whey not just make an index.html file with a redirection line in it? Sure you won't 'hide' the real path but your users won't care anyway.
-:|:- Support Request Template -:|:-
Image
"Use of unnecessary violence in the apprehension of the Blues Brothers has been approved"
maxsteele
Registered User
Posts: 6
Joined: Wed Apr 04, 2007 6:01 am

Re: New styles not showing up in install list

Post by maxsteele »

Yeah, I can do that as well, I just did it this way. :)

Turns out the directories I uploaded and created did not get proper permissions. I'm correcting that now. :)
Locked

Return to “[3.0.x] Support Forum”