auto login not working...

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Ideas Centre
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
User avatar
spaceace
Registered User
Posts: 1999
Joined: Wed Jan 30, 2008 8:50 pm
Contact:

auto login not working...

Post by spaceace »

Support Request Template
What version of phpBB are you using? phpBB 3.0.8
What is your board's URL? http://www.livemembersonly.com
Who do you host your board with? ICDSoft
How did you install your board? I used the download package from phpBB.com
Is your board a fresh install or a conversion? Update from a previous version of phpBB3
Do you have any MODs installed? Yes
Is registration required to reproduce this issue? Yes
What version of phpBB3 did you update from? phpBB 3.0.7
What MODs do you have installed? prime quick reply
board3 portal 1.0.6
ajax chat (Handyman's)
lowen exchange mod
nv who was here v1.0.2
faq manager
download centre 0.0.6
nv advanced last topic titles v1.2.9
phpbb tracker 0.3.0
lock new topic on submit
acp add user
advertisement management 1.0.10
What styles do you currently have installed? Bluespace, Prospace, Midnightspace, Deepspace, Concept, Black Pearl
What language(s) is your board currently using? en
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP but not phpBB
What username can be used to view this issue? testuser
What password can be used to view this issue? tester
When did your problem begin? don't know. members just reported the issue a few days ago.
Please describe your problem. auto login does not work. here's my cookie settings:
cookie domain - .livemembersonly.com
cookie name - phpbb3_21lmo
cookie path - /

Allow persistent logins - yes
Persistent login key expiration length (in days) - 0
Generated by SRT Generator ($Rev: 4502 $)
Last edited by Pit$Bull on Fri Jan 21, 2011 4:02 pm, edited 1 time in total.
Reason: Topic icon changed
Pit$Bull
Former Team Member
Posts: 23099
Joined: Sat Dec 02, 2006 4:08 pm
Name: Can't Remember

Re: auto login not working...

Post by Pit$Bull »

Try changing your cookies to
phpbb3_o2x9m
Then use the board link 'delete all board cookies'
User avatar
spaceace
Registered User
Posts: 1999
Joined: Wed Jan 30, 2008 8:50 pm
Contact:

Re: auto login not working...

Post by spaceace »

ok, made the change but have to wait to hear back from the members to see if it's fixed.
Pit$Bull
Former Team Member
Posts: 23099
Joined: Sat Dec 02, 2006 4:08 pm
Name: Can't Remember

Re: auto login not working...

Post by Pit$Bull »

The issue wasn't affecting you?
You may also want to check
Session IP validation:
Determines how much of the users IP is used to validate a session; All compares the complete address, A.B.C the first x.x.x, A.B the first x.x, None disables checking. On IPv6 addresses A.B.C compares the first 4 blocks and A.B the first 3 blocks.
You can try setting to A.B.
ACP->main page->security settings.
User avatar
spaceace
Registered User
Posts: 1999
Joined: Wed Jan 30, 2008 8:50 pm
Contact:

Re: auto login not working...

Post by spaceace »

Pit$Bull wrote:The issue wasn't affecting you?
You may also want to check
Session IP validation:
Determines how much of the users IP is used to validate a session; All compares the complete address, A.B.C the first x.x.x, A.B the first x.x, None disables checking. On IPv6 addresses A.B.C compares the first 4 blocks and A.B the first 3 blocks.
You can try setting to A.B.
ACP->main page->security settings.
i didn't know it was an issue as i never use the auto login function.

i went to my site a couple of minutes ago and i was not logged in anymore, so i'm now waiting to see if the A.B. setting will work.
User avatar
spaceace
Registered User
Posts: 1999
Joined: Wed Jan 30, 2008 8:50 pm
Contact:

Re: auto login not working...

Post by spaceace »

just checked on my site and auto login still don't work. but the cookie seems to remember the style information as i'm working on a new style and i have a different one for default and the style i'm working on came up instead of the default one. it's just not remembering the login.
Pit$Bull
Former Team Member
Posts: 23099
Joined: Sat Dec 02, 2006 4:08 pm
Name: Can't Remember

Re: auto login not working...

Post by Pit$Bull »

If you are checking the 'Log me on automatically each visit' box when doing your login and it still doesn't work then it's your portal or one of the installed MOD causing the issue.
User avatar
spaceace
Registered User
Posts: 1999
Joined: Wed Jan 30, 2008 8:50 pm
Contact:

Re: auto login not working...

Post by spaceace »

Pit$Bull wrote:If you are checking the 'Log me on automatically each visit' box when doing your login and it still doesn't work then it's your portal or one of the installed MOD causing the issue.
this happens if i use the board index login and the login link as well. but i'll remove the portal to see if it will fix it.
User avatar
spaceace
Registered User
Posts: 1999
Joined: Wed Jan 30, 2008 8:50 pm
Contact:

Re: auto login not working...

Post by spaceace »

i found out what my issue was.

it was this line

Code: Select all

$user->session_begin();
in the modified shout.php file from the ajax chat i have on my site ;)

all fixed :D
Locked

Return to “[3.0.x] Support Forum”