Search not working - redirects back to board index

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Ideas Centre
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
hobbes487
Registered User
Posts: 17
Joined: Thu Oct 20, 2005 9:07 pm

Search not working - redirects back to board index

Post by hobbes487 » Sat Feb 05, 2011 10:26 pm

Support Request Template
What version of phpBB are you using? phpBB 3.0.8
What is your board's URL? http://www.opensourceautomation.com/forum
Who do you host your board with? Siteground
How did you install your board? I used the download package from phpBB.com
Is your board a fresh install or a conversion? Fresh Install
Do you have any MODs installed? No
Is registration required to reproduce this issue? No
What styles do you currently have installed? Avalon Blue
What language(s) is your board currently using? English
Which database type/version are you using? MySQL 5
What is your level of experience? Comfortable with PHP and phpBB
When did your problem begin? Just noticed it today, but could have always been a problem
Please describe your problem. Search is not working. When a user goes to the search page, enters a query and clicks search, no results are returned and it just redirects back to the board index. It doesn't even show a results page with no results. I have tried deleting and recreating the indexes.
Generated by SRT Generator ($Rev: 4778 $)
http://www.opensourceautomation.com - An open source home automation project

User avatar
Noxwizard
Support Team Leader
Support Team Leader
Posts: 10341
Joined: Mon Jun 27, 2005 8:41 pm
Location: Texas, USA
Name: Patrick Webster
Contact:

Re: Search not working - redirects back to board index

Post by Noxwizard » Sun Feb 06, 2011 2:39 am

Your search form's action is pointing to http://www.opensourceautomation.com/for ... b_v=search instead of ./search.php.
[Support Template] - [Read Before Posting] - [phpBB Knowledge Base]
Do not contact me for private support, please share the question in our forums.

hobbes487
Registered User
Posts: 17
Joined: Thu Oct 20, 2005 9:07 pm

Re: Search not working - redirects back to board index

Post by hobbes487 » Sun Feb 06, 2011 2:43 am

So how do I change that?
http://www.opensourceautomation.com - An open source home automation project

User avatar
Noxwizard
Support Team Leader
Support Team Leader
Posts: 10341
Joined: Mon Jun 27, 2005 8:41 pm
Location: Texas, USA
Name: Patrick Webster
Contact:

Re: Search not working - redirects back to board index

Post by Noxwizard » Sun Feb 06, 2011 3:02 am

Are you sure that you haven't made any modifications to the board? All of your form actions to point to index.php, with the full address. For example, your login page action is:
http://www.opensourceautomation.com/forum/index.php?mode=login&rb_v=ucp
It should be ./ucp.php?mode=login
[Support Template] - [Read Before Posting] - [phpBB Knowledge Base]
Do not contact me for private support, please share the question in our forums.

Locked

Return to “[3.0.x] Support Forum”