Page 1 of 1

gow to get rid of sid= on url

Posted: Sat Jun 25, 2011 10:37 am
by rain-13
I see that most forums dont have have sid= on url. but mine has. It's quite annoying that when you remove sid= from url then you simply get logged out.


How do I make session cookie based?

Re: gow to get rid of sid= on url

Posted: Sat Jun 25, 2011 10:51 am
by KevC
Your cookie is probably wrong.
What's the address of the board?

Re: gow to get rid of sid= on url

Posted: Sat Jun 25, 2011 2:58 pm
by rain-13
http://autoit.net.ee/forum/ mostly it's for testing but this sid is still annoying.

Re: gow to get rid of sid= on url

Posted: Sat Jun 25, 2011 3:08 pm
by KevC
Cookie domain
autoit.pri.ee

It should be

.autoit.pri.ee

Re: gow to get rid of sid= on url

Posted: Sat Jun 25, 2011 6:13 pm
by rain-13
Cookie settings > Cookie domain: changed to: .autoit.net.ee but didn't help

my site changed from pri.ee to net.ee few month ago? maybe anyting else it messed up? or is there toggle to switch between sid= or cookie?

edit: had to change Domain name:

Re: gow to get rid of sid= on url

Posted: Sat Jun 25, 2011 6:57 pm
by KevC
So is it working now?

Re: gow to get rid of sid= on url

Posted: Fri Jul 29, 2011 6:03 pm
by HollyRidge
I changed my cookie settings as instructed however I am still getting the sid in the url of some pages. Is there something else I need to do to get rid of it?

Re: gow to get rid of sid= on url

Posted: Fri Jul 29, 2011 6:17 pm
by KevC
Without a bit more information it's hard to tell.

Which pages?
What's the site address?

Re: gow to get rid of sid= on url

Posted: Fri Jul 29, 2011 6:35 pm
by HollyRidge
URL: http://forums.domain.net

I get it when I logout and the page refreshes it pops up there as well as when I login and the page refreshes. If I click on any of the links there it goes away until I click logout.

My cookie settings are as follows...

cookie domain: .forums.domain.net
cookie name: user_phpbb
cookie path: /
cookie secure: disabled

Re: gow to get rid of sid= on url

Posted: Fri Jul 29, 2011 6:39 pm
by KevC
Remove the . at the start of your cookie domain.
You only need a dot there if it start in www and yours doesn't.

Then delete your site cookie in your browser.

Re: gow to get rid of sid= on url

Posted: Fri Jul 29, 2011 6:50 pm
by HollyRidge
changed it as you requested and cleared all cookies and cache. still doing it.

the forums here do it too. right now as i type the reply the url has a sid in it.

Re: gow to get rid of sid= on url

Posted: Fri Jul 29, 2011 6:57 pm
by KevC
I just created an account. It's working ok.

You get the sid on your first visit to the index page, then on any other page you visit it disappears, even in the index. That's ok.

You can delete the phpbbtest account.

Re: gow to get rid of sid= on url

Posted: Fri Jul 29, 2011 7:01 pm
by HollyRidge
thanks kevin, but is there a way to get rid the sid in the url altogether?

Re: gow to get rid of sid= on url

Posted: Fri Jul 29, 2011 7:06 pm
by KevC
It's only on the very first visit to the very first page. If it wasn't you wouldn't be able to log in.
It's also in the admin panel pages.

I've got gone back to the site and it's not there as I'm still on the same login session.

Re: gow to get rid of sid= on url

Posted: Fri Jul 29, 2011 8:33 pm
by HollyRidge
Thanks Kevin for all of your time and help.

Been away from phpbb for a little while, now gotta figure this new system out.