Problem with upgrade(solved)

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
DougE
Registered User
Posts: 47
Joined: Tue Jul 12, 2011 5:38 pm
Location: Richmond,Ky
Contact:

Problem with upgrade(solved)

Post by DougE »

I uploaded all the update files and the install folder to my root.

When I run: http://www.rollyourownresource.com/foru ... update.php

I get the following error: Warning: require(./../includes/startup.php) [function.require]: failed to open stream: No such file or directory in /hermes/web01/b2558/moo.rollyourownresourcec/forums/install/database_update.php on line 52

Fatal error: require() [function.require]: Failed opening required './../includes/startup.php' (include_path='.:/usr/local/lib/php-5.2.17/lib/php') in /hermes/web01/b2558/moo.rollyourownresourcec/forums/install/database_update.php on line 52
Last edited by DougE on Thu Jul 14, 2011 9:44 pm, edited 1 time in total.
User avatar
KevC
Support Team Member
Support Team Member
Posts: 70279
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Problem with upgrade

Post by KevC »

Download a full version of 3.0.9 and make sure you upload the includes/startup.php file.
It's a new file in this version and it looks like it hasn't recognised that you need it.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"
DougE
Registered User
Posts: 47
Joined: Tue Jul 12, 2011 5:38 pm
Location: Richmond,Ky
Contact:

Re: Problem with upgrade

Post by DougE »

Kevin Clark wrote:Download a full version of 3.0.9 and make sure you upload the includes/startup.php file.
It's a new file in this version and it looks like it hasn't recognised that you need it.
ok. I have that downloaded also. I need to upload all but the config.php file, correct?
User avatar
KevC
Support Team Member
Support Team Member
Posts: 70279
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Problem with upgrade

Post by KevC »

No, upload the includes/startup.php file.

If you have no MODs you can do the full file change you're thinking of.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"
DougE
Registered User
Posts: 47
Joined: Tue Jul 12, 2011 5:38 pm
Location: Richmond,Ky
Contact:

Re: Problem with upgrade

Post by DougE »

Kevin Clark wrote:No, upload the includes/startup.php file.

If you have no MODs you can do the full file change you're thinking of.
I have no mods and uploaded the full version minus the config.php file.

Still getting the same error.

Warning: require(./../includes/startup.php) [function.require]: failed to open stream: No such file or directory in /hermes/web01/b2558/moo.rollyourownresourcec/forums/install/database_update.php on line 52

Fatal error: require() [function.require]: Failed opening required './../includes/startup.php' (include_path='.:/usr/local/lib/php-5.2.17/lib/php') in /hermes/web01/b2558/moo.rollyourownresourcec/forums/install/database_update.php on line 52
User avatar
KevC
Support Team Member
Support Team Member
Posts: 70279
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Problem with upgrade

Post by KevC »

/includes/startup.php is not on the server.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"
DougE
Registered User
Posts: 47
Joined: Tue Jul 12, 2011 5:38 pm
Location: Richmond,Ky
Contact:

Re: Problem with upgrade

Post by DougE »

Kevin Clark wrote:/includes/startup.php is not on the server.
It is there according to my filemanager on the server.
User avatar
KevC
Support Team Member
Support Team Member
Posts: 70279
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Problem with upgrade

Post by KevC »

Oh don't use filemanager. That's rubbish.

Get a proper FTP application like filezilla. That'll do it properly.

If you navigate to that exact address it should show you a white page. It actally says 404 not found and the error message you're seeing says the same too.
includes/startup.php) [function.require]: failed to open stream: No such file or directory
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"
DougE
Registered User
Posts: 47
Joined: Tue Jul 12, 2011 5:38 pm
Location: Richmond,Ky
Contact:

Re: Problem with upgrade

Post by DougE »

I used filezilla for the upload. All the files are there on the server.
User avatar
KevC
Support Team Member
Support Team Member
Posts: 70279
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Problem with upgrade

Post by KevC »

PM me your FTP info, I'll have a look too.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"
DougE
Registered User
Posts: 47
Joined: Tue Jul 12, 2011 5:38 pm
Location: Richmond,Ky
Contact:

Re: Problem with upgrade

Post by DougE »

Done. And thanks a lot for helping me out here.
DougE
Registered User
Posts: 47
Joined: Tue Jul 12, 2011 5:38 pm
Location: Richmond,Ky
Contact:

Re: Problem with upgrade

Post by DougE »

Thanks for all the help, Kevin. Everything is looking good now. :D
User avatar
kateland
Registered User
Posts: 198
Joined: Wed Nov 22, 2006 7:08 pm
Location: Philadelphia, PA
Contact:

Re: Problem with upgrade(solved)

Post by kateland »

How was this solved? I'm having this trouble after using the update package to 3.0.10
here's your love letter
you bloodletter
you disappointed every time
User avatar
KevC
Support Team Member
Support Team Member
Posts: 70279
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Problem with upgrade(solved)

Post by KevC »

kateland wrote:How was this solved? I'm having this trouble after using the update package to 3.0.10
Please start a new topic with your exact problem and fill out the Support Request Template Generator too.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"
User avatar
kateland
Registered User
Posts: 198
Joined: Wed Nov 22, 2006 7:08 pm
Location: Philadelphia, PA
Contact:

Re: Problem with upgrade(solved)

Post by kateland »

Thanks Kevin...my problem was that my install/index overwrote my root/index. I uploaded from a backup and was able to preserve my mods and such.
here's your love letter
you bloodletter
you disappointed every time
Locked

Return to “[3.0.x] Support Forum”