Fatal error: Class 'pcr_phpbb' not found

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Suggested Hosts
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
User avatar
crazynlazyguy
Registered User
Posts: 38
Joined: Tue Jul 19, 2011 5:12 am
Location: Iowa
Name: Matt
Contact:

Fatal error: Class 'pcr_phpbb' not found

Post by crazynlazyguy »

I keep getting this error when I go to the /install folder to attempt to run the auto update.

What is causing this issue and how can I fix it???

Fatal error: Class 'pcr_phpbb' not found in /home/snap/public_html/boards/includes/hooks/hook_post_count_requirements.php on line 63
User avatar
Mick
Support Team Member
Support Team Member
Posts: 22919
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket probably.

Re: Fatal error: Class 'pcr_phpbb' not found

Post by Mick »

First check that /includes/hooks/hook_post_count_requirements.php actually exists otherwise you need to ask in the discussion support area for Post Count Requirements
"The more connected we get the more alone we become" - Kyle Broflovski©
User avatar
crazynlazyguy
Registered User
Posts: 38
Joined: Tue Jul 19, 2011 5:12 am
Location: Iowa
Name: Matt
Contact:

Re: Fatal error: Class 'pcr_phpbb' not found

Post by crazynlazyguy »

Yes it exists. So a mod is preventing me from running the auto upgrade?
User avatar
Mick
Support Team Member
Support Team Member
Posts: 22919
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket probably.

Re: Fatal error: Class 'pcr_phpbb' not found

Post by Mick »

If the message you posted is correct then it looks like it. You should try asking the mod author in the link I provided.
"The more connected we get the more alone we become" - Kyle Broflovski©
User avatar
crazynlazyguy
Registered User
Posts: 38
Joined: Tue Jul 19, 2011 5:12 am
Location: Iowa
Name: Matt
Contact:

Re: Fatal error: Class 'pcr_phpbb' not found

Post by crazynlazyguy »

Mixstar wrote:If the message you posted is correct then it looks like it. You should try asking the mod author in the link I provided.
I will but in the meantime I think I might just uninstall the mod and continue with the upgrade for security reasons.
Locked

Return to “[3.0.x] Support Forum”