Big problem Members disconnected each time they click a link

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
nexum
I've Been Banned!
Posts: 156
Joined: Tue May 25, 2004 8:36 pm

Big problem Members disconnected each time they click a link

Post by nexum »

Message to mods: We decided to just delete all downloads on our forum, so there is not any music downloads anymore. Anyway it was too much trouble and most of the links were broken. Now can i get some help from this forum and can you please stop closing my topic ?


Hello,

My forum Anarcho-Punk.net have been working perfectly for a long long time. I haven't touched anything since months, but around 2 weeks ago my webhosting company decided to upgrade PHP to PHP 5.3

Since they upgraded to PHP 5.3, my forum members are getting a lot of problems. They get disconnected almost every time they click a link... After investigating i discovered that they get disconnected only when they access an URL that doesn't include the Session ID in the URL

Example:
http://www.anarcho-punk.net/index.php?s ... 9bfabcb4d6 will work
http://www.anarcho-punk.net/ will get you disconnected

So i tryed to add the Session ID to ALL links on the forum but i can't fix everything. Examples:

- If a member login then get back to the forum typing http://www.anarcho-punk.net URL in their browser it won't include Session ID so they will get disconnected

- If a member post an internal link inside a forum post, session ID isnt included so they will get kicked out

- member's bookmarks doesnt include Session ID



So i really don't know how to fix this problem. And i don't understand why the problem didnt show up until my webhost upgraded to PHP 5.3

I desesperatly need help! My forum activity is going down since the bug happenned, many active members are threatening to leave the forum :( This is one of my last forum using PHPBB, all others are on vbulletin and i want to keep this one on phpbb :( Please help me !


I contacted my webhost, they told me to check if phpbb got specific instructions related to "memcache" but im really confused.....


UPDATE: Yesterday the glitches disseapeared during a couple of hours. I could click links without SID and i wouldnt get disconnected. But today the problem is back... It is really weird..

Note: i am using PHPBB 3.0.5
User avatar
Noxwizard
Support Team Leader
Support Team Leader
Posts: 10416
Joined: Mon Jun 27, 2005 8:41 pm
Location: Texas, USA
Name: Patrick Webster
Contact:

Re: Big problem Members disconnected each time they click a

Post by Noxwizard »

Your board seems to be operating fine at the moment. SIDs are not being put on URLs once the cookie is established. It's possible that it was a misconfiguration by your host for memcache because you shouldn't have noticed anything unless you had specifically enabled it in phpBB. phpBB supports that as a caching method as of 3.0.6 and it shouldn't be a problem. It's what we use here at phpbb.com.
[Support Template] - [Read Before Posting] - [phpBB Knowledge Base]
Do not contact me for private support, please share the question in our forums.
nexum
I've Been Banned!
Posts: 156
Joined: Tue May 25, 2004 8:36 pm

Re: Big problem Members disconnected each time they click a

Post by nexum »

Well sometimes it works, then a couple of hours after the bug comes back...

I just tryed to login, then i clicked a link on the left menu and i am now disconnected...

Is it possible that it is a problem related to memcache ? I use phpbb 3.0.5 so if i understand correctly, memcache is not supported. I tryed a mod that is supposed to enable support for memcache with phpbb 3.0.5 but it didnt work, it would just crash my board.
User avatar
Noxwizard
Support Team Leader
Support Team Leader
Posts: 10416
Joined: Mon Jun 27, 2005 8:41 pm
Location: Texas, USA
Name: Patrick Webster
Contact:

Re: Big problem Members disconnected each time they click a

Post by Noxwizard »

Just having it installed on the server isn't supposed to do anything. I have seen in the past though, were misconfigured caching modules would cause problems, even if they weren't in use by phpBB. (example)
Typically this shouldn't cause a problem, unless the host is possibly trying to force caching on all pages. Generally you should let the application try to do the caching.

How caching works in phpBB
By default, phpBB uses file caching. It writes files into the /cache directory and reads them to save time on either retrieving heaving database queries or compiling template files. If you're using 3.0.6 or greater, you can choose to take advantage of caching modules that are installed on the server. This includes APC, eAccelerator, Memcache, Null, or XCache. Simply having it installed on the server (your case) does not make phpBB try to use it. You have to change the $acm_type value in config.php in order for phpBB to switch to the new caching methods.

Typically, when things break sporadically, it's something that your host is doing. As to whether we have specific instructions related to memcache, we don't, as your board isn't using it.
[Support Template] - [Read Before Posting] - [phpBB Knowledge Base]
Do not contact me for private support, please share the question in our forums.
User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51686
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Big problem Members disconnected each time they click a

Post by stevemaury »

Locking - Team members see user notes.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)
Locked

Return to “[3.0.x] Support Forum”