banning *@gmail.com not working, please help ...

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Get Involved
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
letchworthvillage
Registered User
Posts: 8
Joined: Mon Nov 14, 2011 12:31 am

banning *@gmail.com not working, please help ...

Post by letchworthvillage » Mon Nov 14, 2011 12:36 am

I've been getting a lot of spam (human) registrations from gmail.com email accounts, so I added *@gmail.com to the ban email list (as 'permanent'), but the system is still allowing gmail accounts to register as new users ... I've removed it from the list, and then readded it (a few times), but no matter what I do, gmail accounts can still register as new users ... Am I missing something? (I am using the latest version of phpbb) Can someone please help me?

User avatar
Netframe
Registered User
Posts: 64
Joined: Fri Jun 10, 2011 4:39 am

Re: banning *@gmail.com not working, please help ...

Post by Netframe » Mon Nov 14, 2011 3:25 am

Banning the gmail.com domain isn't the best idea since it is heavily used by a lot of people as an email source.

However this is just me.

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: banning *@gmail.com not working, please help ...

Post by Oyabun1 » Mon Nov 14, 2011 4:03 am

It is very unlikely the spammers are human. Are you sure the users you think are joining aren't just inactive users that joined before you added the ban? Are you sure the spammers are using @gmail.com accounts, sometimes they use special characters in their addresses that look almost the same but can get around the ban?

See the sticky near the top of this forum, Preventing Spam in phpBB3, for better ways of stopping spammers.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

letchworthvillage
Registered User
Posts: 8
Joined: Mon Nov 14, 2011 12:31 am

Re: banning *@gmail.com not working, please help ...

Post by letchworthvillage » Mon Nov 14, 2011 12:51 pm

They are definitely human spammers; I've tried different Captchas and they still register ... I know many real people use gmail and I hate to ban it, but the # of spammers using it overwhelms the # of real people ... I know they are spammers because they are coming from IP addresses from China, Ukraine, Poland, Netherlands, etc .... Is there a way to block all IP's that are outside of the USA ?? (or only allow USA IP addresses to register?)

My forum (http://www.letchworthvillage.info/forum/ .. which is a forum for the site www.LetchworthVillage.info) does not have heavy traffic, so it is annoying when 99% of the registrations are spammers and I don't know how to otherwise block them. I do not have problems withs bots, but the human spam farms overseas is what's killing me as an Admin/Moderator.

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69215
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: banning *@gmail.com not working, please help ...

Post by KevC » Mon Nov 14, 2011 12:58 pm

letchworthvillage wrote:They are definitely human spammers; I've tried different Captchas and they still register
They're definitely not human. You're still using captchas which were beaten by the bots nearly a year ago.

You need to be using the Q&A captcha with a non searchable question. eg, enter the first 4 letters of the name of the village.

Do that and they'll stop.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51758
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: banning *@gmail.com not working, please help ...

Post by Brf » Mon Nov 14, 2011 1:08 pm

When I try to register at your board using a gmail address, I get the message
The e-mail address you entered is not allowed to be used.
so they are not registering that way.

I see your board has only one topic, other than the Welcome one, but I could not read it. That blue-on-grey color scheme is not readable for me.

letchworthvillage
Registered User
Posts: 8
Joined: Mon Nov 14, 2011 12:31 am

Re: banning *@gmail.com not working, please help ...

Post by letchworthvillage » Mon Nov 14, 2011 3:21 pm

I was able to fix the gmail issue, but I do realize I will lose all legit gmail users, so I will unban it and try to put the custom field in where I ask a question like you mentioned ... Thanks for all the replies :)

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50557
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: banning *@gmail.com not working, please help ...

Post by stevemaury » Mon Nov 14, 2011 3:23 pm

If you have 3.0.6 or newer, you will not use a custom field - you will use the built-in Q&A CAPTCHA.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

letchworthvillage
Registered User
Posts: 8
Joined: Mon Nov 14, 2011 12:31 am

Re: banning *@gmail.com not working, please help ...

Post by letchworthvillage » Mon Nov 14, 2011 3:43 pm

OK .. I was able to change the captcha to the Q&A captcha ... and I unbanned all email domains .. let's cross our fingers! .. Again, thank you to all that replied. :)

Locked

Return to “[3.0.x] Support Forum”